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1 Signal Generator Overview

CAUTION To avoid damaging or degrading the performance of the instrument, do not exceed  
33 dBm (2W) maximum of reverse power levels at the RF input. See also Tips for 
Preventing Signal Generator Damage on www.agilent.com.

• Signal Generator Features on page 2

• Modes of Operation on page 4

• Front Panel Overview on page 5

• Front Panel Display on page 9

• Rear Panel Overview on page 12
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Signal Generator Overview
Signal Generator Features
Signal Generator Features
• N5171B/N5181B, RF analog models: 9 kHz to 1 (N5171B only), 3, or 6 GHz (Options 501, 503, and 

506 respectively)

• N5172B/N5182B, RF vector models: 9 kHz to 3 or 6 GHz (Options 503, and 506 respectively)

• step & list sweep of frequency, power, or frequency and power

• vector models can include waveforms in list sweep

• automatic leveling control (ALC)

• real- time modulation filtering

• 8648/ESG code compatible

• 10 MHz reference oscillator with external output

• two channel power meter display

• user settable maximum power limit 

• user flatness correction

• external analog I/Q inputs (vector models)

• enhanced assembly replacement

• GPIB, USB 2.0, and 100Base–T LAN interfaces

• deep amplitude modulation providing greater dynamic range

• manual power search (ALC off)

• SCPI and IVI–COM driver 

• multiple baseband generator synchronization when using multiple signal generators (master/slave 
setup)

• with Signal Studio Software, vector models can generate 802.11 WLAN, W–CDMA, cdma2000, 
1xEV–DO, GSM, EDGE, and more

• real- time baseband generator (Option 660)

• pulse train generator (Option 320)

• LF multifunction generator (Option 303)

• narrow pulse modulation, including internal pulse generator (Option UNW)

• analog differential I/Q outputs (vector models, Option 1EL)

• analog modulation: AM, FM, and ΦM (Option UNT)

• arbitrary I/Q waveform playback up to 200 MSa/s (vector models, Option 656/657)

• external AM, FM, and ΦM inputs (Option UNT)

• Wideband AM (vector models, Option UNT)

• flexible reference input, 1 – 50 MHz (Option 1ER)

• LO In/Out for phase coherency (Option 012)

• phase noise interference (vector models, Option 432)
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 Signal Generator Overview
Signal Generator Features
• expanded license key upgradability (Option 099)

For more details on hardware, firmware, software, and documentation features and options, refer to 
the data sheet shipped with the signal generator and available from the Agilent Technologies website 
at http://www.agilent.com/find/X- Series_SG. 
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Signal Generator Overview
Modes of Operation
Modes of Operation
Depending on the model and installed options, the Agilent X- Series signal generator provides up to 
four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital 
modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to 
a single frequency and power level. Both the analog and vector models can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the 
analog and vector models provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog 
modulation types available depend on the installed options. 

Option UNT provides AM, FM, and ΦM modulations. Some of these modulations can be used together. 

NOTE The Mod On/Off hardkey and LED functionality are only valid for instruments with Option 
UNT installed.

Refer to 14. Mod On/Off and LED.

Option 303 provides a multifunction generator that consists of seven waveform generators.

Option UNW provides standard and narrow pulse modulation capability.

Digital Modulation (Vector Models with Option 65x Only)

In this mode, the signal generator modulates a CW signal with a arbitrary I/Q waveform. I/Q 
modulation is only available on vector models. An internal baseband generator (Option 65x) adds the 
following digital modulation formats:

• Custom Arb Waveform Generator mode can produce a single–modulated carrier or 
multiple–modulated carriers. Each modulated carrier waveform must be calculated and generated 
before it can be output; this signal generation occurs on the internal baseband generator. Once a 
waveform has been created, it can be stored and recalled, which enables repeatable playback of 
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 265.

• Custom Real- Time Waveform Generator mode can produce a single–modulated carrier or 
multiple–modulated carriers. Each modulated carrier waveform must be calculated and generated 
before it can be output; this signal generation occurs on the internal baseband generator. Once a 
waveform has been created, it can be stored and recalled, which enables repeatable playback of 
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 265.

• Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, 
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer 
to “Creating a Custom Multitone Waveform” on page 297.
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 Signal Generator Overview
Front Panel Overview
• Two–tone mode produces two separate continuous wave signals (or tones). The frequency spacing 
between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 12, 
"Multitone and Two–Tone Waveforms (Option 430)".

• Dual ARB mode is used to control the playback sequence of waveform segments that have been 
written into the ARB memory located on the internal baseband generator. These waveforms can 
be generated by the internal baseband generator using the Custom Arb Waveform Generator 
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to 
“Dual ARB Player” on page 130. 

Front Panel Overview

1. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. The 
instrument also has a rear panel device USB connector (see page 14) used to remotely control the 
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status 

Connector Type A

USB Protocol 2.0

22. Power Switch and LEDs 

21. More and LED 
20. Return 

18. Knob 

19. Incr Set 15. Page Down 

16. I Input 

17. Q Input 

12. RF 
Output 

13. RF On/Off and LED 

14. Mod On/Off and LED 

7. MENUS  11. Preset 
and User 
Preset 

9. Local 
Cancel/(Esc) 

5. Arrows and Select 

6. Page Up 

8. Trigger 

4. Numeric 
Keypad 3. Softkeys 2. Display 1. Host USB 10. Help 
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Signal Generator Overview
Front Panel Overview
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located 
on the right hand side of the display. See also, “Front Panel Display” on page 9.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign 
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 35.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing. 
See “Entering and Editing Numbers and Text” on page 35.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on 
page 36. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Down key (page 7) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access 
information.

See page 57

See page 50

See page 37

See page 63

See page 113Active only on 
vector models.

See page 37

See page 40

See page 19

See page 69

See page 129

See page 62

See page 74
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 Signal Generator Overview
Front Panel Overview
8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a 
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, 
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on 
page 34.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user–defined). See “Presetting 
the Signal Generator” on page 34.

12. RF Output

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The 
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation 
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on 
page 48).

The MOD ON/OFF LED lights when modulation of the output is enabled.

NOTE The Mod On/Off hardkey and LED functionality are only valid for instruments with Option 
UNT installed.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on 
page 36. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Up key (page 6) to scroll text.

Connector Standard: 
Option 1EM: 
Impedance:

female Type–N 
Rear panel female Type–N 
50 Ω

Damage Levels 50 Vdc, 2 W maximum RF power
Agilent MXG and EXG X-Series Signal Generators User’s Guide 7



Signal Generator Overview
16. I Input (vector models only)

See also, “I/Q Modulation” on page 188.

17. Q Input (vector models only)

See also, “I/Q Modulation” on page 188.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, 
character, or item in a list. See also, “Front Panel Knob Resolution” on page 22.

19. Incr Set 

This hardkey enables you to set the increment value of the currently active function. The increment 
value also affects how much each turn of the knob changes an active function’s value, according to 
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 22).

20. Return 

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key 
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More 
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED 
lights and all signal generator functions deactivate. The signal generator remains connected to the 
line power, and some power is consumed by some internal circuits. In the on position, the green LED 
lights and the signal generator functions activate.

Connector Type: female BNC Impedance: 50 Ω

Signal An externally supplied analog, in–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms

Connector Type: female BNC Impedance: 50 Ω

Signal An externally supplied analog, quadrature–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms
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 Signal Generator Overview
Front Panel Display
Front Panel Display

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the 
current frequency setting appears. If the currently active function has an increment value associated 
with it, that value also appears. 

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error 
conditions. An annunciator position may be used by more than one annunciator; in this case, only 
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

ΦM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.

ARB The ARB generator is on. ARB is running and not waiting on a trigger.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and 
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

5. Error Message Area 6. Text Area 
 
7. Softkey Label Area 

4. Amplitude Area 3. Annunciators 2. Frequency Area 1. Active Function Area 

Scroll Bar
If there is more 
text than can be 
displayed on one 
screen, a scroll 
bar appears here. 
Use the Page Up 
and Page Down 
keys to scroll 
through the text.
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Front Panel Display
4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed 
out).

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. 
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator 
(see UNLOCK, below).

CHANCORR The internal channel correction is enabled.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at 
temperature.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of 
the error messages or clear the error queue (see “Reading Error Messages” on page 62).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ΦM annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or 
VXI–11/Sockets (LAN) interface.

M–TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 107).

OFFS An output offset is set (see “Setting an Output Offset” on page 105).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI–11/Sockets (LAN) interface. When the 
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 106).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI–11/Sockets (LAN) 
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI–11/Sockets 
(LAN) interface.

T–TONE Two–Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of 
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, 
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the 
error messages (see “Reading Error Messages” on page 62).

WATRG The current modulation mode is waiting on the Arb trigger.

WINIT The signal generator is waiting for you to initiate a single sweep.

This annunciator appears when...
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 Signal Generator Overview
Front Panel Display
5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent 
message remains displayed. See “Reading Error Messages” on page 62.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other 
information such as sweep lists and file catalogs. This area also enables you to perform functions 
such as managing information (entering information, and displaying or deleting files).

7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of 
the display. Softkey labels change, depending on the function selected.
Agilent MXG and EXG X-Series Signal Generators User’s Guide 11
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Rear Panel Overview
Rear Panel Overview

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the 
Installation Guide.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not 
been permanently saved to non- volatile memory, the signal generator should always be 
powered down either via the instrument’s front panel power button or the appropriate 
SCPI command. Signal generators installed in rack systems and powered down with the 
system rack power switch rather than the instrument’s front panel switch display a 
Error - 310 due to the instrument not being powered down correctly.

4. SWEEP OUT 

2. EXT 1 & 
EXT 2 

5. PULSE 

6. TRIG 1 & 2 

7. REF IN 

9. GPIB 10. LAN 

11. Device USB 

8. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM
only 

See page 7

Digital Modulation Connectors (Vector Models Only) on page 15

12. Host USB 

13. SD Card 3. LF OUT 
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Rear Panel Overview
2. EXT 1 & EXT 2

3. LF OUT

4. SWEEP OUT

5. PULSE

6. TRIG 1 & 2

7. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this connector 
and automatically switch from internal to external reference operation. See “Presetting the Signal 
Generator” on page 34. With Option 1ER (flexible reference input), you must explicitly tell the signal 
generator the external reference frequency you wish to use; enter the information through the front 

Connector female BNC Impedance nominally 50 Ω

Signal An externally supplied ±1 Vp signal that produces the indicated depth.

Damage Levels 5 Vrms and 10 Vp

Connector female BNC Impedance 50 Ω

Signal Voltage range: 0 to +5 Vp 
Offset: - 5 V to +5 V, nominal

For more information, see page 69.

Connector female BNC  
Can drive 2 kΩ.

Impedance <1 Ω

Signal Voltage range: 0 to +10 V, regardless of sweep width 
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V 
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 42 and 113.

Connector female BNC Impedance nominally 50 Ω

Signal Externally supplied: +1 V = on; 0 V = off 

Damage Levels ≤ −0.3 and ≥+5.3 V

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point 
in manual sweep mode or an LF sweep in external sweep mode. 
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5 and ≥+5.5 V

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.
Agilent MXG and EXG X-Series Signal Generators User’s Guide 13
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Rear Panel Overview
panel or over the remote interface.

8. 10 MHz OUT

9. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 10. LAN and 
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this connector, 
which enables a LAN–connected computer to remotely program the signal generator. The LAN 
interface supports auto−MDIX. The signal generator is limited to 100 meters on a single cable 
(100Base–T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

12. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. The 
instrument also has a rear panel device USB connector (see page 14) used to remotely control the 
instrument.

13. SD Card

Holds the Secure Digital (SD) non- volatile memory card.

Connector female BNC Impedance nominally 50 Ω

Signal A nominal signal level greater than 4 dBm.

Connector Type B

USB Protocol Version 2.0

Connector Type A

USB Protocol 2.0
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Digital Modulation Connectors (Vector Models Only)

I OUT, Q OUT,  OUT,  OUT

NOTE  OUT and  OUT, require Option 1EL.

Connector Type: female BNC Impedance: 50 Ω  
DC–coupled

Signal

 I OUT The analog, in–phase component of I/Q modulation from the internal baseband generator.

 Q OUT The analog, quadrature–phase component of I/Q modulation from the internal baseband 
generator.

  OUT Used in conjunction with the I OUT connector to provide a balanceda baseband stimulus.

aBalanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity 
(180 degrees out of phase).

  OUT Used in conjunction with the Q OUT connector to provide a balanceda baseband stimulus.

Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50 Ω Load

• 0.5 Vpk, typical, corresponds to one unit length of the I/Q vector

• 0.69 Vpk (2.84 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.5

• 0.71 Vpk (3.08 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.35

• Typically 1 Vp–p maximum

I Q

I Q

I

Q
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y 

 

BB TRIG 1 & BB TRIG 2

EVENT 1

PAT TRIG

DIGITAL BUS I/O

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not 
operational for general purpose use. Signals are present only when a signal creation software option 
is installed (for details, refer to http://www.agilent.com/find/signalcreation).

NOTE The X- Series’ Digital BUS I/O connector can be used for enabling operation with the Agilent 
Technologies N5106A PXB MIMO Receiver Tester.

Connector female BNC Impedance nominally 50 Ω

Signal Reserved for arbitrary and real- time baseband generators I/O, such as markers or trigger 
inputs.

Connector female BNC Impedance: nominally 50 Ω
Signal A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  

Adjustable to ± one timeslot; resolution = one bit 
Markers 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Marker 1 level = +3.3 V CMOS high (positive polarity selected); –3.3 V CMOS low (negative polarit
selected).  
Output on this connector occurs whenever Marker 1 is on in an Arb–based waveform (see “Using
Waveform Markers” on page 145).

Damage Levels < −4 and > +8 V

Connector female BNC Impedance: nominally 50 Ω
Signal A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.  

The input to this connector triggers the internal digital modulation pattern generator to start 
a single pattern output or to stop and re–synchronize a pattern that is being continuously 
output. To synchronize the trigger with the data bit clock, the trigger edge is latched, then 
sampled during the falling edge of the internal data bit clock.  
This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse 
Width

(high or low) = 100 ns

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods

Damage Levels < −4 and > +8 V
16 Agilent MXG and EXG X-Series Signal Generators User’s Guide
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AUX I/O 

18 1

1936

Event 1, 2, 3, and 4 (pins 1 - 4) 
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  
Adjustable to ± one timeslot; resolution = one bit
Markers 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Marker level = +3.3 V CMOS high (positive polarity selected); –3.3 V CMOS low (negative polarity selected).

Sample Rate Clock Out (pin 5) 
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data.  
Damage levels:< −0.5 and > +5.5 V.

Pin 1 = Event 1
Pin 2 = Event 2
Pin 3 = Event 3
Pin 4 = Event 4
Pin 5 = Sample Rate Clock Out
Pin 6-36 = application specific*

* Refer to the application’s help for more 
information.The AUX I/O connector is a shielded .050 series board mount connector.

View looking into rear panel female 36–pin connector
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2 Setting Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus in 
which you can enable instrument options.

Display Settings on page 20

Front Panel Knob Resolution on page 22

Power On and Preset on page 21

Enabling an Option on page 29

GPIB Address and Remote Language on page 24
Configuring the LAN Interface on page 25
Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11” on page 26
Configuring the Remote Languages on page 27

User Preferences

Remote Operation 

Setting Time and Date on page 22

Upgrading Firmware on page 23

Hardware Assembly Installation and Removal Softkeys on page 31

Reference Oscillator Tune on page 23
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Setting Preferences & Enabling Options 
User Preferences 
User Preferences
From the Utility menu, you can set the following user preferences:

• Display Settings, below

• Power On and Preset on page 21

• Front Panel Knob Resolution on page 22

Display Settings

NOTE With the brightness set to minimum, the display may be too dark to see the softkeys. If this 
happens, use the figure above to locate the brightness softkey and adjust the value so that 
you can see the display.

Range: 0 to 100

Range: 1 to 12 hours, in 1 hour increments

Light Only: turns the display light off, leaving the text visible at a low intensity. 

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to 
prevent the text from burning the display.

When on, commands executed through 
the remote control bus update the signal 
generator display accordingly.

Bright without color

Utility > Display 

See also, Using Secure Display on page 308.

For details on each key, use key help 
as described on page 34.

page 308

Dark text on a light 
background.

Light text on a dark 
background.
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Setting Preferences & Enabling Options
User Preferences
Power On and Preset

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Command 
Reference.

Utility > Power On/Preset 

Restores persistent settings  
(those unaffected by a power 
cycle*, preset, or recall) 
to their factory defaults.

Available only when 8648 is either the selected preset language or 
the selected remote language (see page 24).

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to 
non-volatile memory, the X-Series signal generator should always be powered down either via the instrument’s front 
panel power button or the appropriate SCPI command. X-Series signal generators installed in rack systems and 
powered down with the system rack power switch rather than the instrument’s front panel switch display a Error -310 
due to the instrument not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.
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Setting Preferences & Enabling Options 
User Preferences 
Front Panel Knob Resolution

Setting Time and Date

The signal generator’s firmware tracks the 
time and date, and uses the latest time 
and date as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time–based licenses, 
and that you are resetting the signal generator’s time/date reference point. When you set a new time 
or date that is later than the signal generator’s current reference point, that date becomes the new 
reference point. If you then set the date back, you run the risk described in the next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the 
reference point. If you set the time back more a few hours, you disable the signal generator’s ability 
to use time–based licenses, even if there is no license installed at the time that you set the time 

Changing the time or date can 
adversely affect the signal 
generator’s ability to use time−based 
licenses, even if a time−based 
license is not installed.

Makes the increment value of the current function the active entry.

Utility >  
Instrument Adjustments 

The increment value and the step/knob ratio determine how much each 
turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the 
step/knob ratio is 50 to 1, each turn of the knob changes the active 
function by 0.2 dB (1/50th of 10 dB). 

To change the amount for each turn of the knob, modify the increment 
value, the step/knob ratio, or both.

For details on each key, use key help 
as described on page 34.

 page 23.

 page 22.

Executes the ALC Modulator Bias Adjustment. When using 
the ALC in open loop mode, this compensates for open loop 
power drift due to temperature and humidity.

SCPI Commands:
:CALibration:ALC:MODulator:BIAS

Utility >  
Instrument Adjustments >CAUTION

Original time/date reference point

Time

New time/date reference point
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Setting Preferences & Enabling Options
Upgrading Firmware
back. In this case, you can re- enable the signal generator’s ability to use time–based licenses by 
moving the clock forward to the original time or simply waiting that length of time.

Reference Oscillator Tune

Upgrading Firmware
For information on new firmware releases, go to http://www.agilent.com/find/upgradeassistant.

Tunes the internal VCTXCO oscillator frequency. 

The user value offsets the factory tuned value (the value is added to the 
factory calibrated DAC value). The tune value of 0 sets the factory 
calibrated value.
The range; –8192 to 8192, can be set by using the front panel keypad, 
knob or remote command. 

For details on each key, use key help 
as described on page 34.

See also the SCPI Command Reference.

Utility > Instrument Adjustments 
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Setting Preferences & Enabling Options 
Remote Operation Preferences 
Remote Operation Preferences
For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

page 25

page 26

NOTES
USB is also available. It is not shown in the menu because it requires no configuration.

For details on using the instrument remotely, see the Programming Guide.

Select the desired language. 

This setting is not persistent and is cleared by performing an 
instrument Preset. In most cases, it is best to use Utility > 
Power On/Preset > Language for a permanent language 
change. See page 27. 

For details on each key, use key help as described on page 34.

Select On to view the associated SCPI command for a key 
press.

Select On to log SCPI commands ???
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Setting Preferences & Enabling Options
Remote Operation Preferences
Configuring the LAN Interface

NOTES 
Use a 100Base–T LAN cable to connect the 
signal generator to the LAN. 

Use a crossover cable to connect the signal 
generator directly to a PC.

For details on using the instrument remotely, 
refer to the Programming Guide and to 
www.agilent.com and search on FAQs: Hardware 
Configurations and Installation for the Agilent 
MXG.

Utility > I/O Config

Values are listed in the 
Programming Guide

For details on each key, use key help as described on page 34.

 page 26.
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Setting Preferences & Enabling Options 
Remote Operation Preferences 
Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11” 

Enable remote 
(browser) access to the 
instrument’s file system. Use a browser to control 

the signal generator.

Utility > I/O Config

For details on each key, use key help 
as described on page 34.

License Manager Server 
(On) allows updates of the 
instrument licenses, disable 
for additional instrument 
security.

For more information refer to 
the Programming Guide.
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Setting Preferences & Enabling Options
Remote Operation Preferences
Configuring the Remote Languages

Utility > I/O Config

For details on each key, use key help 
as described on page 34.

Select the desired Remote language.

Refer to the SCPI Command Reference.
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Setting Preferences & Enabling Options 
Remote Operation Preferences 
Configuring the Preset Languages

Figure 2-1 N5171B/72B/81B/82B

Utility > Power On/Preset 

For details on each key, use key help 
as described on page 34.

Select the desired Remote language.

page 21

Refer to the SCPI Command Reference.
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Setting Preferences & Enabling Options
Enabling an Option
Enabling an Option
There are two ways to enable an option: 

• Use the License Manager software utility:

1. Run the utility and follow the prompts.

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files 
from an external USB Flash Drive (UFD).

• Use SCPI commands, as described in the Programming Guide.
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Setting Preferences & Enabling Options 
Enabling an Option 
Viewing Options and Licenses

Utility >  
Instrument Info

Service Software Licenses 

Waveform licenses from some 
Instrument options appear 
here. A check mark means that 
an option is enabled.

For details on each key, use key help 
as described on page 34.

Signal Studio applications appear here.

appear here.
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Setting Preferences & Enabling Options
Hardware Assembly Installation and Removal Softkeys
 Hardware Assembly Installation and Removal Softkeys
Utility > More  2 of 2 > Service For details on each key, use key help 

as described on page 34.

NOTE: Functionality of inactive keys on this 
page will be implemented in a future release.

Verify output attenuator operation using a power 
meter at the RF Output.
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Setting Preferences & Enabling Options 
Hardware Assembly Installation and Removal Softkeys 
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation, 
refer to the Programming Guide.

• Presetting the Signal Generator on page 34

• Viewing Key Descriptions on page 34

• Entering and Editing Numbers and Text on page 35

• Setting Frequency and Power (Amplitude) on page 37

• Setting ALC Bandwidth Control on page 39

• Configuring a Swept Output on page 40

• Modulating the Carrier Signal on page 48

• Working with Files on page 50

• Reading Error Messages on page 62
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Basic Operation 
Presetting the Signal Generator 
Presetting the Signal Generator

Viewing Key Descriptions

To return the signal generator to a known state, press either Preset or User Preset. 

Preset is the factory preset; User Preset is a custom preset** (see also, page 21). 

To reset persistent settings (those unaffected by preset, user preset, or power cycle*), 
press: Utility > Power On/Preset > Restore System Defaults.

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to 
non-volatile memory, the instrument should always be powered down either via the instrument's front panel power 
button or the appropriate SCPI command. instrument's installed in rack systems and powered down with the system 
rack power switch rather than the instrument's front panel switch display a Error -310 due to the instrument not 
being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-9 on page 60).

The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.
2. Press the desired key. 

The help displays and the key’s normal function does not execute. 
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 Basic Operation
Entering and Editing Numbers and Text
Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Entering Alpha Characters

Data entry softkeys appear in various 
menus. If their meaning is not clear in 
context, use the help key (described on 
page 34) to display an explanation. Use 
the softkey next to the alpha table for 
help on the table.

Selecting data that accepts alpha 
characters, displays one of the menus 
shown at right.

Use the arrow keys or knob to highlight 
the desired letter, then press the Select 
hardkey (or the softkey next to the 
alpha table). To correct errors, use Bk 
Sp or Clear Text.

To terminate the entry, press the Enter 
softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the 
letters A through F (use the numeric keypad for other values).

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

To specify a negative value, enter the
negative sign either before or after

Backspace moves the cursor to the left,
deleting characters as it goes.

Left/right arrow keys move the cursor horizontally.

Page up/down keys move tables of data up and down within the display area.

 

Use the number keys and decimal point to enter numeric data.

Note: Rotating the knob increases or
decreases a numeric value, changes a 
highlighted digit or character, or steps 
through lists or items in a row.

See also, Front Panel Knob Resolution on page 19

the numeric value (this key is a toggle).

For details on each key, see page 34.

Use the Select hardkey to choose part of an entry, as when entering alpha 
characters. In some menus, the Select key also acts as a terminator, and is 
equivalent to the Enter softkey.

to move the cursor 
within the active value 
rather than within the 
alpha table, turn the 
alpha table off.

Add/edit comments for saved 
instrument state files (see page 57).

Note: File names are limited to 25 characters.
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 35



Basic Operation 
Entering and Editing Numbers and Text 
Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor 
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.

2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor. 

4. (Optional) Display the selected item in the active function area: Press Select.

5. Modify the value:

• If the value is displayed in the active function area, use the knob, arrow keys, or numeric 
keypad to modify the value.

• If the value is not displayed in the active function area, use the numeric keypad to enter the 
desired value (which then appears in the active function area).

6. Terminate the entry:

• If available, press the desired units.
• If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.

Cursor

Table Editor Softkeys Table Editor Name Table Items

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable) 
item, either press Select, or simply enter the desired value.

Table items are also 
called data fields.

Used to load, navigate, modify, and 
store table item values. For details 
on each key, use the key help: 
Press the Help hardkey and then 
the desired key.

Active Function Area

Current / Total Number of Pages

Indicates that 
another menu 
is available; to 
display the 
second menu, 
press More.

(vector models only)
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 Basic Operation
Setting Frequency and Power (Amplitude)
Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

 

page 105

To display the next menu, press More.

For details on each key, use key help 
as described on page 34.

page 38

Refer to the SCPI Command Reference.

Opens the 
Atten/ALC 
Control 
menu.

Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off.
The optimize signal–to–noise softkey changes the attenuator and alc setting to provide 
optimal signal–to–noise performance; it does not change the RF output power. 
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of 
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and 
EVM.
Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation 
type. A settings conflict error will be generated if attentuator hold or any modulation is 
activated when optimize signal–to–noise is active (On).

page 39

This softkey sets a user 
determined maximum power 
level on the instrument that is 
persistent.

Available on vector 
models with BBG.
Enables the instrument 
to select between two 
power levels with a 
hardware marker or 
using an external BNC.

page 82

In Amplitude mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

In Frequency mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

Sets the current relative phase of 
the RF output signal as the zero 
reference.
All subsequent adjustments are 
relative to this adjustment.

dBuVemf terminates 
the value as dBuV 
electromotive force. 
Emf is the output 
voltage with no 
load. This unit is 
external only. 
Internal 
representation as 
well as increment 
and decrement 
values are in dBm. 
Note: dBuV, mV, 
and nVemf behave 
similarly (i.e. Values 
are external only. 
Internal 
representation as 
well as increment 
and decrement 
values are in dBm.).

Enables the mode to improve non-harmonics performance (low spurs mode). 
Note: When this mode is enabled, the instrument switching speed and behavior of 
the source’s settled signal are affected.

Modifies the attenuator and ALC settings 
for optimal performance. It does not 
change the RF output power.
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Basic Operation 
Setting Frequency and Power (Amplitude) 
Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output
1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the 
front panel display areas are shown on page 9).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz. 

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active 
entry area.

3. Set the amplitude to −20 dBm: Press Amptd > –20 > dBm.

The display changes to −20 dBm in the AMPLITUDE area of the display, and the amplitude value 
becomes the active entry. Amplitude remains the active function until you press another function 
key.

4. Turn on the RF Output: Press RF On/Off.

The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT 
connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

 

For details on each key, use key help as described on page 34.

Range: 1 to 50 MHz
For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth, 
operation using frequencies below 2 MHz is not guaranteed.

Freq > More

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the 
external reference you are using is noisy or spurious, use the narrow bandwidth mode.

With Wide bandwidth selected, if you select a frequency less than 2 MHz, the signal 
generator displays a warning message.

uses the signal generator’s internal reference oscillator.

uses the REF IN connector to get it’s Frequency Reference. Note: An 
error screen is displayed if the reference is not connected or is tuned 
to the wrong frequency.
uses the signal generator’s internal reference unless a signal is 
present at the rear panel REF IN connector. If an external signal is 
present, that signal is used as  the reference.

uses the baseband generator clock (BBG) as the reference oscillator 
source. Available on vector models with BBG.
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 Basic Operation
Setting ALC Bandwidth Control
Figure 3-2 Using an External Reference Oscillator

Setting ALC Bandwidth Control

Figure 3-3 Amplitude Softkeys

To display the next menu, press 
More.

For details on each key, use key help 
as described on page 34.

Refer to the SCPI Command Reference.

Enables the 
automatic 
ALC 
bandwidth 
mode 
(Auto).
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Basic Operation 
Configuring a Swept Output 
Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 42) provides a linear or logarithmic progression from one selected frequency, 
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along the 
sweep. The sweep can progress forward, backward, or manually. 

List sweep (page 44) enables you to enter frequencies and amplitudes at unequal intervals, in 
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current 
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep 
data in the file catalog (page 55).
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 Basic Operation
Configuring a Swept Output
Figure 3-4 Sweep Softkeys

Sweep without waiting for  
a trigger at each point.  
Point Trigger pauses for the dwell 
time prior to the first sweep. See 
page 109.

Apply a TTL/CMOS signal to the 
Trigger In connector.

Periodically issue a trigger event to 
whatever selects it as a source.

Using timer trigger with single 
sweep results in a delay prior to the 
first sweep. See page 109.

Trigger on a remote command.

Down sweeps from 
stop to start 
frequency/amplitude.
 
Up sweeps from start 
to stop 
frequency/amplitude.

page 44

The selected sweep type determines the displayed parameter.  
Selecting step sweep also displays the step spacing (Lin or Log).

On vector models:
Available when 
Sweep Type = List

page 48

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

Progress Bar: Note that very fast sweeps 
can appear to sweep randomly or 
backward.

page 42

For details on each key, use key help as described on page 34.

 page 42
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Basic Operation 
Configuring a Swept Output 
Routing Signals

Sweep > More > More > Route Connectors

Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or 
both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The 
sweep can progress forward, backward, or be changed manually. 

Figure 3-5 Signal Routing Softkeys

These softkeys are 
only available for 
the vector models 
with a BBG.

Routes non Step 
or List Sweep 
signals (i.e. SCPI 
command 
development.

Source Settled is 
not affected by 
Trig Out Polarity 
Neg Pos softkey 
selection.

Routes Step or 
List Sweep 
signals.

For details on each key, use key help as described on page 34.

Opens a menu for 
routing Markers 1 
through 4 to the 
rear panel 
baseband BNC 
connectors.

Routes a signal to the Trig Out (Trig 1 or Trig 2) rear 
panel connectors as follows:
None: No signals are routed to Trig 1 or Trig 2 BNCs
Sweep Trigger Out: Sweep Trigger Out signal (trigger 
handshake)
Source Settled: Source Settled signal
Pulse Sync: Pulse Modulation Synchronization signal
Pulse Video: Pulse Modulation Video signal
LXI: LXI Trigger Output
Sweep Run: Sweep Run signal (sweep is running)
Other Trigger BNC: The signal on the other Trigger 
BNC
Pulse BNC: The signal on the PULSE IN BNC
Swept Func Done: Swept Function Sweep Done signal
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 Basic Operation
Configuring a Swept Output
Figure 3-6 Sweep Softkeys

Example: Configuring a Continuous, Linear Step Sweep

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing 
selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude. 
The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the 
amplitude display, and the progress bar.

5. Turn the RF output on: Press RF On/Off. 

The RF LED lights, and the continuous sweep is available at the RF Output connector.

Output: A signal that continuously sweeps from 500 to 600 MHz and from −20 to 0 dBm, with a dwell time 
of 500 ms at each of six equally−spaced points.

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz

Amplitude at the beginning of the sweep, −20 dBm: Press Amptd Start > −20 > dBm

Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds: Press More > Step Dwell > 500 > msec

Dwell Time = the time that the signal is settled and you can make 
a measurement before the sweep moves to the next point.

(Point to point time is the sum of the value set for the dwell plus 
processing time, switching time, and settling time.) 

Lin = steps equally spaced over the sweep; the output changes 
linearly.

Log = step spacing increases logarithmically over the sweep; the 
output changes exponentially.

Step Sweep and List Sweep dwell times are set independently.

For details on each key, use key help 
as described on page 34.

Sets the step size for a linear step sweep in frequency (the difference 
between frequency points).
NOTE: Setting the step size will determine the number of points in the 
step sweep based on the current start and stop frequencies. Due to the 
integer number of step points, the step size may be adjusted in order to 
yield a true linear sweep between the start and stop frequencies.
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Basic Operation 
Configuring a Swept Output 
List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear 
ascending, descending, or random order. List sweep also enables you to copy the current step sweep 
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file 
catalog (page 55). Dwell time is editable at each point. For fastest switching speeds, use list sweep.

Figure 3-7 List Sweep Configuration Softkeys and Display

see page 45

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell 
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the 
sweep moves to the next point.

Point–to–Point Time = the sum of the value set for the dwell plus processing time, switching 
time, and settling time. 

Each line defines the 
corresponding point in 
the sweep. For example, 
line 1 defines point 1.

page 42

Available only on vector models,  
and  
only when Sweep Type = List.

Displays the selected 
sweep type parameters 
(see page 45)

Vector models only

page 42

For details on each key, use key help 
as described on page 34.
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 Basic Operation
Configuring a Swept Output
Example: Configuring a List Sweep Using Step Sweep Data
1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep 

configured on page 43.

2. In the SWEEP menu, change the sweep type to list:  
Press SWEEP > Sweep Type List Step to highlight List. 

The display shows sweep list parameters, as shown below.

3. Open the List Sweep menu: Press More > Configure List Sweep.

4. Clear any previously set values from the menu and load the points defined in the step sweep into 
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset. 

The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the 
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off.  
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Vector Models:

Presetting the list clears 
any previously selected 
waveforms. 

For information on 
selecting a list sweep 
waveform, see Example: 
Editing List Sweep 
Points on page 46.

Waveforms are available 
only on vector models.
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Basic Operation 
Configuring a Swept Output 
Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 36.

1. Create the desired list sweep. This example uses the list sweep created in the previous example.

2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error. 

3. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight List. 

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row. 

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row 
5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency 
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the 
power and dwell time entries do not shift down).

8. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5 
is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for 
points 5 and 6 by one row: Press Insert Item > −2.5 > dBm. 

10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy 
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12. Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform. 
The signal generator displays the available waveforms, as shown in the following example.

b. Highlight the desired waveform (in this example, SINE_TEST) and press either the Select 
hardkey or the Select Waveform softkey.

Either select a waveform, 

or  

select no modulation.
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Configuring a Swept Output
13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The 
following figure shows an example of how this might look.

14. Turn sweep on:  
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on:  
Press RF On/Off. 

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping, 
and the progress bar shows the progression of the sweep. 

NOTE If the instrument is in manual sweep (page 48), the active row (row 6 in the figure above) is 
the selected (manual) point, and the signal generator outputs the settings for that selection 
when the RF output is on.

Example: Using a Single Sweep
1. Set up either a step sweep (page 43) or a list sweep (page 45).

2. In the List/Sweep menu, set the sweep repeat to single:  
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to 
be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

A single repetition of the configured sweep is available at the RF Output connector. 

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the 
progress bar shows the progression of the sweep. 

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.

The empty entry is equivalent to 
choosing CW (no modulation).
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 47



Basic Operation 
Modulating the Carrier Signal 
Example: Manual Control of Sweep
1. Set up either a step sweep (page 43) or a list sweep (page 45).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

5. Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF output 
changes to the settings in that selection.

Modulating the Carrier Signal
To modulate the carrier signal, you must have both 

• an active modulation format 
and

• modulation of the RF output enabled

Example
1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating 
that a modulation format is active.

The parameters of the selected sweep point (point 3 
of 6 in this example) define the signal available at the 
RF Output connector.

When you enter a manual point, 
the progress bar moves to and 
stops at the selected point.

The SWMAN annunciator 
indicates that the sweep 
is in manual mode.

When you turn manual mode on, the 
current sweep point becomes the 
manual point.

The currently sweeping 
parameter stops and 
displays the selected point.
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Modulating the Carrier Signal
3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not 
modulate until you subsequently turn on a modulation format.

NOTE To turn modulation off, press the Mod On/Off key until the LED turns off. 
 
When the Mod On/Off key is off, the carrier signal is not modulated, even with an active 
modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/Off key until 
the LED lights.

See also: “Using Analog Modulation (Option UNT)” on page 63 
“Using Pulse Modulation (Option UNW or 320)” on page 113 
“I/Q Modulation” on page 188

 

Annunciator indicates active AM modulation

AM modulation format on.

A lit LED indicates that any active 
modulation format can modulate 
the carrier.
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Simultaneous Modulation

NOTE The Agilent X- Series signal generators are capable of simultaneous modulation. All 
modulation types (AM, FM, φM, and Pulse) may be simultaneously enabled. But, there are 
some exceptions. Refer to Table 3- 1.

Working with Files

• File Softkeys on page 51

• Viewing a List of Stored Files on page 52

• Storing a File on page 53

• Loading (Recalling) a Stored File on page 55

• Moving a File from One Media to Another on page 56

• Working with Instrument State Files on page 57

• Selecting the Default Storage Media on page 61

The signal generator recognizes several types of files, such as instrument state files, license files, and 
list sweep files. Files can be stored either in the signal generator’s internal storage or on the USB 
media. This section provides an overview of how to navigate the signal generator’s file menus, and 
how to view, store, load, and move files.

The Agilent MXG and EXG non- volatile internal memory is allocated according to a Microsoft 
compatible file allocation table (FAT) file system. Refer to the Programming Guide.

See also: Storing, Loading, and Playing a Waveform Segment on page 132.

Table 3-1 Simultaneous Modulation Type Combinations

AMa

aLinear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 4.

FM φM Pulseb

bPulse modulation requires Option UNW. Refer to Chapter 6.

AM - - x x x

FM xc

cFM and φM cannot be enabled simultaneously.

- - not applicable x

φM xc not applicable - - x

Pulse x x x - -
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File Softkeys

Instrument operating parameters (see page 57).

Sweep data from the List Mode Values table editor.

User flatness calibration corrections.

page 307

Note: Available file types depend on the installed options.

For details on each key, use key help as described on page 34.

Deletions require 
confirmation.

Available only with USB connected 
(i.e. Without external USB connected, 
softkeys are greyed out).

page 61

This key changes, depending on 
the selected file. See page 55.

Shows the current directory

page 56

page 56

Requires 
confirmation

The display indicates when the current directory is the default storage path.  
For information on setting the default storage path, see page 61.

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you 
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the 
signal generator displays the message External Media Not Detected.

The signal generator does not 
format USB media or change file 
permissions. Use a computer to 
perform these operations.

Available only when the 
current directory is not the 
top level directory.

Display internal or USB 
files, depending on the 
selected storage media. 

page 52

Displays IQ Files

Displays FSK 
Files

Displays FIR 
Files

Displays a list of 
Pulse Train files.

Displays Bit 
Files
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Working with Files 
ARB File Softkeys

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to 
Auto, as described on page 61.

Viewing a List of Files Stored in the Signal Generator
1. If USB media is connected, disconnect it. The signal generator’s storage media switches to 

internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press  > Catalog Type > desired catalog (in this example, All). The 
selected files appear in alphabetical order by file name, as shown in the following figure. 

For details on each key, use key help as described on page 34.

Waveform files and their associated 
marker and header information.

Note: Available file types depend on the installed options.

The selected file catalog and 
the storage media
52 Agilent MXG and EXG X-Series Signal Generators User’s Guide 



 Basic Operation
Working with Files
Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can 
display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

• With the USB media connected, select the desired file catalog: press  > Catalog Type > 
desired catalog. The selected files appear in alphabetical order by file name. 

Using the USB File Manager:

• With USB media connected, open the USB File Manager: press File > More > USB File Manager.  
The instrument displays the default directory on the USB Media, as shown in the following figure. 
Note that when you attach USB media, the display goes directly to this menu.

Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument 
states, lists, and waveforms.

• An instrument state file contains instrument settings. For this type of file, use the Save hardkey 
shown in Figure 3- 8 on page 57.

• For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Use the Page Up and 
Page Down hardkeys to scroll 
through the contents of the 
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Use this menu to enter the file name, 
as described on page 35.

For details on each key, use key help as described on page 34.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

File Length (including extension)
Internal Media: 25 characters
USB Media: 39 characters
54 Agilent MXG and EXG X-Series Signal Generators User’s Guide 



 Basic Operation
Working with Files
Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

• For an instrument state file, use the Recall hardkey shown in Figure 3- 8 on page 57.

• For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Loading a File From USB Media

To load a file from USB media, use the USB file manager shown below.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Recall From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

This key changes, depending 
on the selected file. 

If the signal generator does not recognize the file, 
you must select how the file is to be used.

File Type
List
State
Waveform
User Flatness
User Preset
License
Pulse Train

Extension
.list
.state
.waveform
.uflat
.uprst
.lic
.ptrain

Pressing Select with file highlighted...
loads list and starts sweep
load instrument state
loads and plays waveform
loads and applies user flatness
loads and executes user preset
installs purchased license
loads and applies pulse train

For details on each key, use key help as described on page 34.

 
  Copy & Select User Flatness
  Copy & Play Waveform
  Copy & Play Sequence
  Enter Directory
  Recall Instrument State
  Load List
  Load Pulse Train
  Install licenses
  No action (USB disconnected)
  Use As

File > Catalog Type > <type> > More > USB File Manager 
or
File > More > USB File Manager
or
Insert the USB media
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 55



Basic Operation 
Working with Files 
Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

Selecting a waveform or 
an unknown file type 
displays this softkey.

File > Catalog Type > <type> > More > USB File Manager
or
File > More > USB File Manager
or
Insert the USB Flash Drive (UFD)

For details on each key, use key help as described on page 34.

This key changes, 
depending on the selected 
file. See page 55

Whether a menu is available 
depends on the selected file. 

Requires confirmation

Catalog Type Menu
page 51

Requires confirmation

Moves up one directory level 
These softkeys are only 
available on vector 
models with BBG.

These softkeys are 
only available on 
vector models with 
BBG.

If the file type is recognized 
the “Filename.xxx copied 
to Internal Storage” is 
displayed.
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Working with Instrument State Files
• Saving an Instrument State on page 58

• Saving a User Preset on page 58

• Recalling an Instrument State on page 58

• Recalling an Instrument State and Associated Waveform File on page 59

• Recalling an Instrument State and Associated List File on page 59

• Moving or Copying a Stored Instrument State on page 60

Figure 3-8 Save and Recall Softkeys

The following information is not stored in a state file:

System Security Level Sweep lists Hostname Remote Language Step increment values

System Security Level Display Pulse Train lists IP Address FTP Server ARB Files

System Security Level State Display State On/Off Subnet Mask Manual DHCP MAC

Web Server (HTTP) Files Default Gateway VXI–11 SCPI User Power Correction

Sockets SCPI (TELNET) I/Q Calibration Data

When saved to the signal generator, instrument settings 
(states) save to instrument state memory*. Instrument 
state memory is divided into 10 sequences (0 through 9); 
each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you 
to delete the contents of a specific register, or the contents 
of all sequences in the state file catalog. 

The signal generator requires that you confirm a deletion.

*Caution 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved 
to non-volatile memory, the instrument should always be 
powered down either via the instrument's front panel 
power button or the appropriate SCPI command. 
instrument's installed in rack systems and powered down 
with the system rack power switch, rather than the 
instrument's front panel switch display a Error -310 due to 
the instrument not being powered down correctly.For details on each key, use key help 

as described on page 34.
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Saving an Instrument State
1. Preset the signal generator and set the following:

2. (Optional, vector models only) Associate a waveform file with these settings: 

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first 

move it from internal or external media to BBG media, see page 132. 

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg. 

If a waveform is currently selected, saving the instrument state also saves a pointer to the 
waveform file name. 

5. Add a descriptive comment to sequence 1 register 01: 

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in 
the Saved States list when you press Recall. If the instrument state has an associated waveform, 
entering the waveform name in the comment makes it easy to identify which instrument state 
applies to which waveform. 

Saving a User Preset

A user preset is a special type of instrument state file.

1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as containing 
user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 60). 

2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State
1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored in the 
registers in that sequence; RECALL Reg is the active entry. 

3. Select the desired instrument state: 

If the desired state is listed in the currently selected sequence, press desired number > Enter. 
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.

• Frequency: 800 MHz • Amplitude: 0 dBm • RF: on
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Recalling an Instrument State and Associated Waveform File 
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 132). 

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform name. It 
does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in 
internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

The name is displayed as the selected waveform. 

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File 

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency 
and/or amplitude values. Because you must load the list file from the file catalog, when you store a 
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Load the desired list file: 

a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This 
is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].

4. Press Re–SAVE Seq[n] Reg[nn]. 

This overwrites previously saved instrument state settings with the new comment. 
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Moving or Copying a Stored Instrument State

Figure 3-9 Instrument State File Catalog

A user–created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same 
name as an existing file. If you rename a state file to something other than a valid sequence/register 
name, the file does not appear in either the Save or Recall menu.

Sequence Register

The signal generator recognizes only the file named USER_PRESET as user preset information (page 58). 
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Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external 
USB media. To automatically switch between USB media and internal storage, depending on whether 
USB media is attached, select Automatically Use USB Media If Present. To avoid storing any confidential 
information in the instrument, select Use Only USB Media. To avoid storing any confidential information 
to USB media, select Use Only Internal Storage.

This selection is unaffected by power−cycle or preset.

File > More > 

Current 
selection

Memory in the instrument is used, and USB media is ignored.

Media attached to the front panel USB connector is used, and no user 
data is stored to internal storage.

This is the recommended selection. When USB media is attached to the 
front panel, it is the selected media; when USB media is not attached, 
internal storage is used.

For details on each key, use key help as described on page 34.

Select the directory on the USB media to be used for all file operations 
when USB media is attached and enabled.
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Reading Error Messages
If an error condition occurs, the signal generator reports it to both the front panel display error 
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the Programming Guide.

Error Message Format

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue Press: Error > Clear Error Queue(s)

Unresolved Errorsa

aErrors that must be resolved. For example, unlock.

Re–reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue: 
No Error Message(s) in Queue    0 of  0

Error Number Error Message
Error Description

(May be truncated on the 

−222        Data out of range;   value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal 
source frequency that is beyond the specific limits 

Explanation is provided in the Error Message file (see page 316)
(This is not displayed on the instrument)

Message number and longer description

new indicates a message generated 
since messages were last viewed.

The annunciator indicates an unviewed message.

Error messages appear in the lower left corner 
of the display as they occur.
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4 Using Analog Modulation (Option UNT)

NOTE The Mod On/Off hardkey and LED functionality are only valid for signal generators with 
Option UNT installed.

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

• Using an Internal Modulation Source on page 66

• Using an External Modulation Source on page 67

• Removing a DC Offset on page 67

• Using Wideband AM on page 67

• Configuring the LF Output (Option 303) on page 69
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Analog Modulation Waveforms 
Analog Modulation Waveforms
The signal generator can modulate the RF carrier with four types of analog modulation: amplitude, 
frequency, phase, and pulse. For pulse modulation information, refer to Chapter 6, “Using Pulse 
Modulation (Option UNW or 320),” on page 113.

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Analog Modulation Sources
The signal generator provides the following internal and external modulation input sources. Internal 
modulation sources generate the five waveforms listed above unless noted otherwise.

Ext1 & Ext2  an externally applied signal is used as the modulation input. Connect the signal to 
the EXT 1 or EXT 2 connector on the rear panel of the instrument.

Func Gen 1  sine wave from the internal function generator. Instruments with Option 303 have 
additional waveform choices listed above.

Func Gen 2  Func Gen 2 has the same capability as Func Gen 1. Available on instruments with 
Option 303.

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent- of-  
peak- amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak- to- peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruments with Option 303.
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Analog Modulation Sources
Figure 4-1 Analog Modulation Softkeys

page 67page 67 page 67

For details on 
each key, use 
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Using an Internal Modulation Source 
Using an Internal Modulation Source
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 310.

See also “Modulating the Carrier Signal” on page 48.

AM FM  ΦM

a. Press AM

b. Set the AM type (Linear or Exponential):  
   AM Type to highlight desired type.

c. Set the AM Mode (Normal or Deep). 
Default is Deep. To select Normal enable 
More to highlight desired type.   

d. Set the AM Depth:    AM Depth > value

Default 0.01%

Range   0.01 to 100%

e. Set the rate:  
   More > Setup AM Source > AM Rate > value 
> frequency unit

a. Press FM/ΦM

b. Set the deviation:  
   FM Dev > value > frequency unit

c. Set the rate:  
   More > Setup FM Source > FM Rate > 
value > frequency unit

a. Press FM/ΦM > FM ΦM

b. Set the BW (normal or high): 
   FM ΦM to highlight desired type

c. Set the deviation:  
   ΦM Dev > value > pi rad

d. Set the rate:  
   More > Setup ΦM Source > ΦM Rate > 
value > frequency unit

AM FM  ΦM

AM Off On softkey to On FM Off On softkey to On  ΦM Off On softkey to On
66 Agilent MXG and EXG X-Series Signal Generators User’s Guide



 Using Analog Modulation (Option UNT)
Using an External Modulation Source
Using an External Modulation Source 

Removing a DC Offset

To eliminate an offset in an externally applied FM or ΦM signal, perform a DCFM or DCΦM 
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually 
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.

2. Press FM/ΦM > FM Source > Ext1 or Ext2 > More > Setup FM Source > Ext DC Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, 
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal, 
perform the calibration again to reset the carrier to the correct zero reference.

Using Wideband AM

Wideband AM uses the I input of the I/Q modulation system. When the wideband AM is turned on, 
the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source 
is set to internal, then the wideband AM turns off.

Rear panel inputs are 
described on page 12

AM, FM or ΦM inputs

Default

Currently selected 
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Using an External Modulation Source 
NOTE For frequencies between 9kHz and 5 MHz, Wideband AM turns off.

Figure 4-2 Wideband AM Softkey Menu

Setting the Wideband AM
1. Set up and enable the desired modulation type.

2. Press AM > AM Path 1 2 WB to WB.

AM > AM Path 1 2 WB

Enables and disables the 
wideband AM feature.
Note: If the I/Q is turned 
off or the I/Q source is set 
to internal, then the 
wideband AM turns off.

For details on each key, use key help 
as described on page 34.

When the Wideband AM is enabled, these fields are 
active.
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Configuring the LF Output (Option 303)
The signal generator has a low frequency (LF) output. The LF output’s source can be switched 
between an internal modulation source or an internal function generator.

Using internal modulation (Int Monitor) as the LF output source, the LF output provides a replica of 
the signal from the internal source that is being used to modulate the RF output. The specific 
modulation parameters for this signal are configured through the AM, FM, or ΦM menus. The internal 
source (AM, FM, or ΦM) must be configured for the LF Out to provide a signal.

Using function generator as the LF output source, the function generator section of the internal 
modulation source drives the LF output directly. Frequency and waveform are configured from the LF 
output menu, not through the AM, FM, or ΦM menus. You can select the waveform shape from the 
following choices:

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Pulse  pulse with adjustable period and width

LF Out Modulation Sources

The signal generator provides the following modulation input sources. Internal modulation sources 
generate the five waveforms listed above unless noted otherwise.

Int Monitor  uses AM, FM or ΦM settings.

Func Gen 1  waveforms from the internal function generator 

Func Gen 2  waveforms from the internal function generator

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent- of-  
peak- amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak- to- peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruements with Option 303.

DC  selects a DC voltage level as the LF output BNC source

NOTE The LF Out Off On softkey controls the operating state of the LF output. However when the LF 
output source selection is Int Monitor, you have three ways of controlling the output. You can 
use the modulation source (AM, FM, or ΦM) on/off key, the LF output on/off key, or the Mod 
On/Off softkey.
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The RF On/Off hardkey does not apply to the LF OUTPUT connector.

Configuring the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source. See Figure 4- 3.

NOTE Internal modulation (Int Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source
1. Press Preset.

2. Press the FM/ΦM hardkey.

3. Press FM Dev > 75 > kHz.

4. Press More > Setup FM Source > FM Rate > 10 > kHz. 

5. Press Return > Return > FM Off On. 

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is 
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output
1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > V. 

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is 
frequency modulated using the Int Monitor source selection (default source).

Figure 4-3 Configure the LF Out Source with FM

For details on each key, use key help 
as described on page 34.

LF Out using the Int Monitor source (default selection).

FM Modulation as the LF Out Source

FM and LF annuciators indicate Frequency Modulation is the LF Out source
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Configuring the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source
1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Out Source > Func Gen 1.

Configuring the Waveform
1. Press Setup LF Out Source > LF Out Waveform > Sine.

2. Press LF Out Freq > 500 > Hz.

3. Press Return.

This returns you to the top LF Output menu. 

Configuring the Low Frequency Output
1. Press LF Out Amplitude > 3 > V.

This sets the LF output amplitude to 3 V.

2. Press LF Out Off On.

Figure 4- 4 shows that the LF output is now transmitting a signal using the function generator that is 
providing a 3 V sine waveform. 

Figure 4-4 LF Out Status Display

For details on each key, use key help 
as described on page 34.LF Out configuration

LF Out annunciator
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5 Optimizing Performance

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

• Using the Dual Power Meter Display on page 74

• Using Flatness Correction on page 82

• Using Internal Channel Correction on page 91

• Using External Leveling on page 94

• Using Unleveled Operating Modes on page 102

• Using an Output Offset, Reference, or Multiplier on page 105

• Using Free Run, Step Dwell, and Timer Trigger on page 109

• Using a USB Keyboard on page 112
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Using the Dual Power Meter Display
The dual power meter display can be used to display the current frequency and power of either one 
or two power sensors. The display outputs the current frequency and power measured by the power 
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 5- 2, 
Figure 5- 2, and Figure 5- 3.

Figure 5-1 Dual Power Meter Display with Power Sensors A and B Calibrated

Once turned on, the 
power meter 
readings are always 
visible, even if 
another instrument 
feature is selected 
(i.e. Sweep, AM, 
etc.).

This area is the main 
display for the dual 
power meter 
calibration frequency 
and current power 
measured.

If channel A or 
channel B power 
sensors or both are 
displayed, and the 
AMPTD or the FREQ 
softkeys are pressed, 
the large power 
meter measurements 
remains displayed.
After the first 
connection, if the 
connection is 
successful, the 
model number and 
serial number of the 
power sensor is 
displayed.

For details on each key, use key help as described on page 34.
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Figure 5-2 Dual Power Meter Display Menu

See 
page 76

Enables the power sensor on  
channel A.

Enables the power sensor on 
channel B.

Channel B is configured similarly to 
channel A. See page 76

For details on each key, use key help 
as described on page 34.
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Figure 5-3 Configuring the Power Sensor Channels

AUX Fctn > Power Meter 
Measurements 

Sockets LAN: Sets the 
IP port to 5025 (standard) 
or 5023 (telnet) 
programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address (Sockets 
LAN and VXI–11 LAN only).

Whether a softkey is available 
depends on the selected 
Connection Type. 

VXI–11 LAN: Opens a 
menu for entering a 
device name for the 
power meter being used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Sensors do not require the 
sensor to be calibrated.

The MXG/EXG use the 
USB U2000A Series Power 
Sensor’s “Internal” zero. 
Refer to the USB U2000A 
Series Power Sensor’s 
documentation.

Zero Sensor and Calibrate 
Sensor softkeys are 
inactive during a 
measurement.

Selects the frequency that channel 
A has been calibrated to.

Selects the channel on the 
external power meter that the 
power sensor is connected to.

Enables a power offset in dB for 
the current channel.

Enables averaging. Instrument 
default is Auto with 1024 points.

Note: This figure illustrates channel A; channel B is similar.

For details on each key, use key help as 
described on page 34.
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Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A 
P–Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and 
calibrated, as required.

On the signal generator:

1. Setup for Step Sweep. “Configuring a Swept Output” on page 40.

CAUTION Verify RF Output power is off before continuing. 

2. Connecting the Channel A power sensor: Connect USB sensor to the signal generator. The 
MXG/EXG should display a message across the bottom that reads similar to:  
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 5-4   MXG/EXG Displays Connection to U2000 USB Power Sensor

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > Connection Type > 
USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a 
different serial number is connected to the signal generator (refer to Figure 5- 5). After the U2000 
has been recognized by the signal generator, the U2000 power sensor is saved as a softkey in the 
instrument and the dialog box in Figure 5- 5 won’t be displayed (press DONE, if you see this 
message).

Figure 5-5   Diagnostic Dialog Box for USB Sensor 
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A Running Calibration(s) bar is displayed on the signal generator. Refer to Figure 5- 6 on 
page 78.

Figure 5-6   Running Calibration(s) Bar (Zeroing Sensor)

NOTE The U2000 Series USB Power Sensor, does not require a 50 MHz calibration. If a 
calibration is attempted with the U2000 Series Power Sensors, the signal generator 
displays a message reading:  
The U2000 series power sensor does not require a 50 MHz calibration. Refer to 
Figure 5- 7 on page 78.

Figure 5-7   Diagnostic Dialog Box Displayed for U2000 Power Sensor

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the 
instrument's display and in the upper right portion of the display under Power Meter. Refer to 
Figure 5- 8.

For details on 
each key, use key 
help as described 
on page 34.

For details on 
each key, use key 
help as described 
on page 34.
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Figure 5-8   Channel A Power Sensor Displayed on MXG/EXG

6. On the N1912A P–Series Power Meter (Channel B power sensor): Connect the N1912A P–Series 
Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

NOTE It is recommended, but not required to use the channel B on the N1912A. This provides 
continuity with the signal generator’s dual display. For this example, the U2004A has 
already used up the channel A position on the signal generator.

8. Connect the power sensor input to the 50 MHz reference of the power meter.

9. Press Channel B Setup

10. Press Connection Settings > Sockets

11. Press IP Address > IP address > Enter

NOTE The IP address of the power meter should be displayed in the ChB section of the display.

Figure 5-9   Channel B Power Sensor with IP Address Entered

12. Press Return > Channel Settings > External Power Meter Channel to B.

For details on 
each key, use key 
help as described 
on page 34.

For details on 
each key, use key 
help as described 
on page 34.
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13. On the signal generator: Press Channel B to On and then back to Off again. This initializes the 
signal generator to the external power meter.

14. Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the 
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 5- 10 on page 80). 

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 5-10   Diagnostic Dialog Box for Channel B

15. Press Done

The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait.... 

16. After Running Calibration(s) bar disappears: Press Calibrate Sensor 

Diagnostic Dialog box is displayed that prompts for verifying the connection of the power sensor 
to the power meter 50 MHz reference (refer to Figure 5- 11 on page 80).

Figure 5-11   Diagnostic Dialog Box for Calibration

For details on 
each key, use key 
help as described 
on page 34.

For details on 
each key, use key 
help as described 
on page 34.
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17. Press Done

Calibration progress bar is displayed. Refer to Figure 5- 12 on page 81.

Figure 5-12   Running Calibration(s) Bar (Calibrating Sensor)

18. Press Return > Channel B to On

19. The current power meter sensor reading should be displayed on the signal generator in the ChB 
portion of the display and in the upper right corner of the display under Power Meter and to the 
left of the Power Meter power sensor reading.

Figure 5-13   Channel B Power Sensor Displayed on MXG/EXG

20. The power sensors are now ready to be connected in a measurement setup.

For details on 
each key, use key 
help as described 
on page 34.

For details on 
each key, use key 
help as described 
on page 34.
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Using Flatness Correction
User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in cables, 
switches, or other devices. Using an Agilent N1911A/12A, E4419A/B, or U2000 Series power 
meter/sensor to calibrate the measurement system, a table of power level corrections can 
automatically be created for frequencies where power level variations or losses occur. Supported 
connection types to the power meter/sensor are Sockets LAN, VXI–11 LAN, USB, and GPIB via 
VXI–11 LAN using a LAN–GPIB gateway (e.g. E5810A Gateway or equivalent).

NOTE A power meter with GPIB requires using the Connection Type VXI–11 softkey, as well as a 
LAN–GPIB gateway, to control a power meter. Refer to the Agilent Connectivity Guide 
USB/LAN/GPIB Connectivity Guide (E2094–90009), Agilent X- Series FAQs “How do I connect 
to the LAN?”, and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.

If you do not have an Agilent N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A 
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction 
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may 
save individual user flatness correction tables to the signal generator’s memory catalog and recall 
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal 
generator’s RF output (see page 86).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on page 90 
to recall a user flatness file from the memory catalog and apply it to the signal generator’s RF 
output.
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Figure 5-14 User Flatness Correction Softkeys

Confirm

For details on each key, use key help 
as described on page 34.

See 
page 86

Starts the 
user  
flatness 
calibration.
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array 
contains ten frequency correction pairs (amplitude correction values for each specified frequency), 
from 500 MHz to 1 GHz. 

An Agilent N1911A/12A or E4419A/B power meter and E4413A power sensor are used to measure 
the RF output amplitude at the specified correction frequencies and transfer the results to the signal 
generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter and E4413A 
power sensor.) The signal generator reads the power level data from the power meter, calculates the 
correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a LAN, 
GPIB, or USB interface, you can enter correction values manually. 

Required Equipment
• Agilent N1911A/12A or E4419A/B power meter (a power meter is not required with the 

U2000A/01A/02A/04A Power Sensor)

• Agilent E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor

• GPIB, LAN, or USB interface cables, as required

• adapters and cables, as required

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 85.

NOTE During the process of creating the user flatness correction array, the power meter is 
remotely controlled by the signal generator.
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Connect the Equipment

• Agilent N1911A/12A or E4419A/B power metera

• Agilent U2000A/01A/02A/04A power Sensora

aFor operating information, refer to the power meter/sensor documentation.

• LAN, GPIB, or USB interface cables, 
as required

• adapters and cables, as required

The LAN, GPIB*, and USB connections are 
for convenience. If your power meter does 
not have LAN, GPIB, or USB, then manually 
enter corrections as described in the 
correction entry step in this section.

*GPIB control of a power meter requires a 
LAN–GPIB gateway and use of the connection type 
VXI–11. Refer to the Agilent Connectivity Guide 
USB/LAN/GPIB Connectivity Guide (E2094–90009), 
Agilent X-Series FAQs “How do I connect to the 
LAN?”, and to the E5810A User’s Guide or 
equivalent LAN/GPIB gateway device.

Power Sensor

Power Meter  
(if applicable)

Signal 
Generator

Device Under Test

Out In

Input Port

RF Output

Cables
and other
Devices

Flatness 
Corrected 
Output 

LAN/ 

Note: Agilent U2000 Series 
USB Power Sensors connect 
directly to the signal generator’s 
front panel USB port (i.e. the 
power meter is not applicable).

USB port for connecting 
USB–compatible power 
meters/sensors (e.g. 
N1911A/12A Power Meters 
and U2000A Series USB 
Power Sensors).

GPIB E5810A 
LAN/GPIB Gateway
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Figure 5-15 Configure Power Meter Menu Softkeys

Basic Procedure
1. Create a user flatness array.

a. Configure the power meter/sensor

b. Connect the equipment

c. Configure the signal generator

d. Enter the user flatness correction values

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

AMPTD > More > User 
Flatness > Configure Power 
Meter

Sockets LAN: Sets the 
IP port to 5025 (standard) 
or 5023 (telnet) 
programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address 
(Sockets LAN and VXI–11 
LAN only).

This softkey is dependent 
on the selected 
Connection Type. 

VXI–11 LAN: Opens a 
menu for entering a 
device name for the 
power meter being used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Meters do not require the 
sensor to be calibrated.

For details on 
each key, use key 
help as described 
on page 34.

Open a menu 
to enter the 
USB device 
name.
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Configure the U2000A/01A/02A/04A Power Sensor
1. Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect the 

Equipment” on page 85.

2. Zero the power sensor using the signal generator softkeys.

CAUTION Verify the signal generator RF Output power is set to the desired amplitude before 
performing the power meter zero. No RF Output amplitude check is done by the signal 
generator during zero.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power 
sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor, 
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware 
has turned off the RF Output’s power. 

For operating information on your particular power sensor, refer to its operation guide.

Configure the E4419A/B and N1911A/12A Power Meter
1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal 
generator or the front panel of the power meter.

3. Enter the power sensor calibration factors into the power meter as required.

4. Enable the power meter’s cal factor array.

NOTE The signal generator’s RF Output LED remains unchanged during zeroing of the power 
sensor (e.g. if the RF Output LED was on prior to starting the Zeroing of the power sensor, 
the LED remains on throughout the zero/calibration). But, actually the instrument’s firmware 
has turned off the RF Output’s power.

For operating information on your particular power meter/sensor, refer to its operating 
guide.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i. Press AMPTD > More > User Flatness > Configure Power Meter > Connection Type > connection 
type.

ii. If connection type is USB:

1. Zero Sensor

2. Go to step c.
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else 
 
If Sockets LAN or VXI–11 LAN: Press Power Meter IP Address > power meter’s or LAN–GPIB 
gateway IP address > Enter.

iii. If Sockets LAN: Press Power Meter IP Port > IP port > Enter.

else

If VXI–11: Press PM VXI–11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the 
power meter’s documentation. Typically, this is “inst0” and is case sensitive for some 
power meters. Refer to your power meter’s documentation, the Agilent Connectivity Guide 
USB/LAN/GPIB Connectivity Guide (E2094–90009), and Agilent X- Series FAQs “How do I 
connect to the LAN?”

When connecting via a LAN–GPIB gateway, enter the SICL address of the power meter. 
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the 
gateway and “13” is the GPIB address of the power meter. Refer to the Agilent 
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Agilent X- Series 
FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or equivalent, 
LAN/GPIB gateway device.

c. Open the User Flatness table editor and preset the cal array: 
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

d. In the Step Array menu, enter the desired flatness–corrected start and stop frequencies, and 
the number of points: 

e. Populate the user flatness correction array with the step array configured in the previous 
step: 

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

f. Set the output amplitude to 0 dBm.

g. Turn on the RF output.

Press More > Configure Step Array > 

Freq Start > 500 > MHz >

Freq Stop > 1 > GHz >

# of Points > 10 > Enter
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2. Connect the power meter to the RF output and enter the correction values:

The user flatness correction array title displays User Flatness: (UNSTORED), without a name, 
indicating that the current user flatness correction array data has not been saved to the file 
catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any 
user flatness correction files saved to the catalog can be recalled, loaded into the correction array, 
and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

• Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the 
array is applied to the RF output.

With a Power Meter Over LAN, GPIB, or USB Manually

i. Create the correction values: 

Press More > User Flatness > Do Cal.

The signal generator begins the user  
flatness calibration, and displays a progress bar.

The amplitude correction values load 
automatically into the  
user flatness correction array.

ii. View the stored amplitude correction values: 
Press Configure Cal Array. 

i. Open the User Flatness table editor and highlight  
the frequency value in row 1:  
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of  
the table row containing the cursor. 

ii. Note the value measured by the power meter.

iii. Change the sign on the delta value (e.g. the delta 
value of the 0 dBm reference value (step f), and the 
measured value from ii is –.34, change the value to 
+.34).

iv. Highlight the correction value in row 1.

v. Press  
Select > enter the delta calculated in step iii > dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output amplitude  
based on the correction value entered.

vi. Repeat steps ii − v until the power meter reads 0 dBm.

vii. Highlight the frequency value in the next row. 

viii.Repeat steps ii through vii for the remaining rows.
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Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If 
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction 
Values on page 87.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.

b. Press Load/Store.

c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:  
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using Internal Channel Correction
The internal channel correction feature corrects the 100 MHz baseband bandwidth flatness and phase 
for arbitrary center frequencies. This feature is off by default, as the switching speed performance of 
the instrument is impacted when this feature is on. 

This calibration should be run when the ambient temperature has varied by at least ±5 degrees 
Celsius from the ambient temperature at which the previous calibration was run.

NOTE There is an internal calibration routine that can be run to collect correction data for both 
the baseband and RF magnitude and phase errors over the entire RF frequency range on any 
unit with options 653 and 656. The internal channel correction cannot be turned on until 
after the correction has been executed once. 

When this feature is off, the box will behave as it always has. When this feature is on, the internal 
I/Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by 
more than 1 kHz, the firmware will calculate a channel correction filter ±50 MHz about the specified 
frequency. For List/Sweep, the calculation will be done prior to the first sweep using the specified 
frequencies when either waveform sweep is active or the baseband is on and the instrument is 
optimized for the internal path. This calculation will cache corrections for up to the maximum 
number of cache points (256). For list/sweep, the sweep will pause and recalculate the correction 
caches before running again.

CAUTION In the case of arbitrary frequency switching, once the correction cache is full (256 
unique frequency points), the oldest frequency corrections will be forgotten as new 
frequencies are selected. 

Whenever I/Q Timing Skew, I/Q Delay, Quadrature Angle Adjustment, or the Int 
Equalization Filter is adjusted, all caches are forgotten.

Additional characteristics of the internal channel correction:

• When the internal channel correction is on, arbitrary frequency switching while the baseband is 
on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified. 
After the first time that a frequency is selected, switching to that frequency again takes an 
additional 1 ms.

• If a frequency sweep is activated, then the calculation and caching will occur up front for the 
first 256 unique frequencies, and all additional unique frequencies will have the characteristics of 
arbitrary frequency switching.

• If the I/Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections 
will be applied and the frequency switching will be unaffected.

• If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be 
convolved with the internal channel correction. A hamming window is applied and the resulting 
filter will be truncated to 256 taps.
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Figure 5-16 Internal Channel Correction Softkeys

SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0

[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?

:CALibration:BBG:CHANnel

For details on each key, use key help as described on page 34.

I/Q > More Toggles on or off the application of 
the internal baseband generator 
RF and baseband magnitude and 
phase corrections across the 
160MHz baseband bandwidth at 
the current RF frequency.
When this feature is on, arbitrary 
frequency switching while the 
baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms 
the first time that frequency is 
specified.  After that, switching to 
that frequency will take up to an 
additional 1.3ms.  
Up to 1024 unique frequencies can 
be cached before the oldest cache 
will be forgotten. If a frequency 
sweep is activated, then the 
calculation and caching will occur 
up front for the first 1024 unique 
frequencies, and all further unique 
frequencies will have the 
characteristics of arbitrary 
frequency switching.
If the I/Q Correction Optimized 
Path is set to Ext I/Q Output then 
only the baseband corrections will 
be applied and the frequency 
switching speed will be unaffected.
This correction will be convolved 
with the ACP Internal I/Q Channel 
Optimization filter and the 
Equalization filter if they are active.  
The resulting filter will be truncated 
to 256 taps.

Provides additional correction to the DUT.
Specify the start and stop frequencies, 
configure the power meter, then execute 
the calibration.
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Configure Internal Channel Correction

The following is a basic configuration for using the signal generator’s internal channel correction. 
Refer to Figure 5- 16.

On the signal generator:

1. Set the center frequency:

Press Freq > 3 > GHz

2. Set the I/Q to internal (default):

Press I/Q > I/Q Source > Internal

3. Press I/Q to On

4. Perform internal channel correction:

Press More > Int Channel Correction Off On to On
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Using External Leveling

CAUTION While operating in external leveling mode, if either the RF or the DC connection between 
the signal generator and the detector is broken, maximum signal generator power can 
occur. This maximum power may overstress a power–sensitive device under test.

Atten Hold sets to On and grays out (inactive) with Ext Detector 
selection. When re–selecting Internal, the softkey becomes 
active, but attenuator hold remains on. If desired, manually set it 
to off.

With the Ext Detector selection, Set Atten has no effect on the 
output power level. During external detector use, use the 
attenuator to keep the ALC power level at approximately 0 dBm 
when using negative dBm power levels. See page 97.

These settings do not change the output power amplitude of the 
signal generator, they only let you modify the front panel display 
amplitude value so it closely approximates the power level 
measured at the output of the coupler/splitter. See page page 101.

This softkey works with only the Ext Detector selection. It uses 
16 dB as its zero reference point.
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External leveling lets you move the ALC feedback source closer to the device under test (DUT) so 
that it accounts for most of the power uncertainties inherent to the cabling and components in a test 
setup. Refer to Figure 5- 17.

Figure 5-17 ALC Circuity

The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT 
connector based on the power level at the detector. As the RF power level at the coupler’s/power 
splitter input changes, the external detector returns a compensating negative voltage. The ALC circuit 
uses this negative voltage to level the RF output power by raising and lowering the signal’s power, 
thus ensuring a constant power level at the point of detection (external detector). Since the point of 
detection does not occur at the output of the device to which the detector is connected, there is 
some power loss that is not compensated for by the external detector. For example on a coupler, the 
coupled port siphons some of the signal’s energy to drive the external detector. In addition the 
coupler experiences some insertion loss between the coupled port and the output.

Figure 5- 19 on page 97 shows the input power versus output voltage characteristics for typical 
Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the 
diode detector input by measuring the external detector output voltage. For a coupler, you must then 
add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values shown 
in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that the 
detector, coupler/power splitter are specified for the power and frequency range of interest. To 
determine the signal generator’s actual power range during external leveling, see “Determining the 
Signal Generator’s Amplitude Range” on page 99.

With external leveling, the displayed amplitude value can vary significantly from the actual output 
power of the coupler/power splitter to which the external detector is connected (see Figure 5- 18). 
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling 
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display 
an accurate amplitude value. Also components between the signal generator and the external detector 
can affect the output power of the coupler/power splitter. You can compensate for this power display 
difference by using the  

External Detector

Power Splitter

Component
DUT

RF

Cabling

OUTPUT

ALC INPUT

ALC Modulator

ALC Internal DetectorDriver

Signal Generator

Leveled Output

(Amp, Filter,
Atten, etc.)

(Negative output)

or Coupler

Opt 1E1 Output 
Attenuator 
(see page 97).
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Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two softkeys is 
that the Ext Leveling Amptd Offset functions only while external leveling is active. For more information 
on using the external leveling offset feature, see “Adjusting the Signal Generator Display’s Amplitude 
Value” on page 101.

Figure 5-18 Power Value Differences with External Leveling

Measured output power 
of a coupler

Signal generator set power level
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Figure 5-19 Typical Diode Detector Response at 25° C

Option 1EQ Output Attenuator Behavior and Use

When using the internal detector, the Option 1EQ output attenuator enables signal generator power 
levels down to −127 dBm at the RF Output connector. It accomplishes this by adding attenuation to 
the output signal after the ALC detection circuit. The output power value (shown in the Amplitude 
area of the display) is the resultant of the Set Atten and Set ALC Level values (see page 94). With the 
external detector selected, the output attenuator no longer attenuates the output signal since the 
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feedback for the detection circuit has been moved beyond the output attenuator. Because the 
attenuator no longer affects the amplitude of the output signal, the output amplitude is determined 
by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range 
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet). 
As stated earlier, the actual output power may vary due to the external detector and the 
coupler/power splitter performance characteristics.

NOTE When the internal detector (Internal selection) is reselected, the signal generator does not 
turn the attenuator hold off.

Even though the output attenuator no longer affects the output power, it is still useful to drive the 
ALC circuit to its mid–power point of approximately 0 dBm, which is optimal for the internal leveling 
circuitry and typically provides the best amplitude flatness results. This is useful with negative power 
values of −5 dBm or less. For example, to drive the ALC to approximately mid–power with a −20 
dBm power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (−20 + 25).

NOTE If there is too much attenuation, it will drive the ALC circuit too high and cause the signal 
generator to go unleveled. Ensure that you decrease the attenuation as you increase the 
power level.

Configure External Leveling

Basic Setup Process
• If working with a single frequency signal, perform Steps 1 through 5.

• If working with multiple frequencies:

a. Perform Steps 1 through 4.

b. Perform a user flatness correction, see “Using Flatness Correction” on page 82.

• If working with a sweep:

a. Perform Steps 1 through 4.

b. Setup the sweep, see “Configuring a Swept Output” on page 40.

1. Setup the equipment, see “Equipment Setup” on page 98

2. Configure the carrier signal, see “Configuring the Carrier” on page 99

3. Select external leveling, see “Selecting External Leveling” on page 99.

4. Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude Range” 
on page 99

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude Value” on 
page 101

Equipment Setup

Set up the equipment as shown in Figure 5- 20 on page 99. Place the external detector (detector and 
coupler/power splitter) as close as possible to the DUT.
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Recommended Equipment

• Agilent 8474E negative detector

• Agilent 87301D directional coupler

• cables and adapters, as required

Figure 5-20 Typical External Leveling Setup using a Directional Coupler

Configuring the Carrier 
1. Press Preset.

2. Set the carrier frequency.

3. Set the power level to 0 dBm:

• If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:

a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.

b. Press Set Atten > 0 > dB.

c. Press Set ALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Pwr Meter Cont.

Determining the Signal Generator’s Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency 
points and there is a need to know the maximum output amplitude for each frequency point, refer to 
the “Amplitude” section of the X- Series Data Sheet. Then use this procedure to determine the 
maximum amplitude for each band.

Leveled Signal

Signal Generator CouplerAmplifier

Negative Detector

RF OUTPUT

ALC INPUT
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With external leveling and Option 1EQ, the signal generator’s power range approximates that of a 
standard option instrument (no Option 1EQ). But Option 1EQ does let you use the attenuator to 
drive the ALC to its mid–power point when using negative amplitude values. However adding 
attenuation does decrease the upper range limit. For more information, see “Option 1EQ Output 
Attenuator Behavior and Use” on page 97.

1. If Option 1EQ is installed, adjust the attenuator to the desired level.

NOTE If the Option 1EQ output attenuator value is too high (approximately ≥ 55 dB), it will cause 
an unlevel condition to occur when the RF output is turned on.

a. Press AMPTD > Atten/ALC Control > Atten Hold On > Set Atten.

b. Enter the attenuator value.

2. Turn on the RF output: Press RF On/Off to On

3. Set the AMPTD step increment value to one dB.

• Press AMPTD > Incr Set > 1 > dB.

4. Determine the minimum amplitude value:

a. Set the amplitude to −25 dBM.

b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.

c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range 
value.

5. Determine the maximum amplitude value:

a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message 
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

• If the unleveled annunciator appeared, decrease the amplitude until the annunciator is 
gone. The value where the annunciator disappears is the maximum upper range value.

• If the signal generator displays Error: 501, Attenuator hold setting over range at 
the bottom of the display, the value showing is the maximum upper range value. 

To remove the error message, press the down arrow key until the message is gone. The 
error appears when an attempt is made to increase the amplitude beyond the maximum 
value as it relates to the current attenuator setting.
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Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the 
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference, 
the signal generator provides two methods for configuring the displayed power value so that it closely 
matches the measured value at the output of the coupler/splitter. 

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:

• If using the Ext Leveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal 
detector.

a. On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

b. While viewing the carrier amplitude value on the signal generator display, use the RPG 
knob (detent knob) to adjust the offset value until the integer part of the displayed 
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB. 

c. Using the number keypad, make the necessary fractional adjustments to the display 
amplitude value.

• If using the Amptd Offset Softkey:

a. On the signal generator, press AMPTD > Leveling Control > More > Amptd Offset.

b. Calculate the difference between the signal generators displayed Amplitude value and the 
measured value.

c. Using the numeric keypad, enter this difference as the Amptd Offset softkey value.
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Using Unleveled Operating Modes

Figure 5-21 Power Search and ALC Off Softkeys

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry. Turning ALC off is 
useful when the modulation consists of very narrow pulses that are below the pulse width 
specification of the ALC or when up converting external IQ signals and the modulation consists of 
slow amplitude variations or bursts that the automatic leveling would remove or distort. When using 
the internal IQ baseband generator, the best technique is to use the ALC hold marker function vs. 
ALC off for the types of signals just described.

NOTE After the ALC has been turned off, power search must be executed to set the proper output 
power level requested on the front panel. Power search is executed automatically by default, 
but the these settings can be overridden by using the Manual mode

Available only when
ALC = Off

Available only when
Power Search Reference =

Available only when 
Power Search = Span 

Auto: The calibration routine executes whenever 
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the 
power search calibration routine once over a 
selected frequency range.
The corrections are stored and used whenever you 
tune the signal generator to within the calibrated 
frequency range.

For details on each key, use key help 
as described on see page 34.

RMS: Value is a DC 
bias equivalent to the 
value derived from the 
file header or the 
calculated value from 
the current I/Q data.
Fixed: Uses a fixed 0.5 
Vrms value (Same 
value is used with Ext 
I/Q data).
Manual: Allows user to 
specify the DC bias 
voltage value  
(0–1.414 Vrms).
Modulated: Uses the 
AC bias from the actual 
modulating signal.

Manual

User: Enables the 
user to set the 
signal generator 
frequency settings.
Full: The signal 
generator selects 
its full frequency 
range for the power 
search.

Only available when 
I/Q is on. 

These 
softkeys are 
only active 
when an ARB 
waveforms is 
playing in 
memory.

Manual: User must explicitly execute a power 
search to calibrate the open loop ALC level.  
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Power Search Mode

NOTE The power search mode cannot be used with bursted signals input via the external IQ inputs.

The MXG/EXG has three power search modes (for internal and external I/Q modulation) and four 
power search references (for external I/Q modulation only). Refer to Figure 5- 21 on page 102.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the 
current RF output, and then disconnects the ALC circuitry.

Power Search Modes (Applies to External and Internal I/Q Modulation)

• Auto — A power search is executed at each frequency or power change, and at each change to the 
AM, burst, pulse, or I/Q modulation state.

• Span — When Power Search is set to Span, pressing Do Power Search executes the power search 
calibration routine over a range of user- defined frequencies. The power search is stored and used 
when the signal generator is tuned within a user- defined range. After the Span softkey is pressed, 
select either Full or User. If User is selected, then the start and stop frequencies need to be 
selected.

• Manual — When Power Search is set to Manual, pressing Do Power Search executes the power search 
calibration routine for the current RF frequency and amplitude. In this mode, if there is a change 
in RF frequency or amplitude, you will need to press Do Power Search again.

Power Search References (Only applies to Internal I/Q Modulation)

The four Power Search References control the power search function. These four references select the 
reference voltage used while the RF signal is being I/Q modulated. (Power search references are not 
used for analog modulation: FM, φM, or pulse modulation.)

CAUTION If the power search reference has the incorrect RMS voltage, the output power will be 
incorrect. Refer to Figure 5- 22, "Calculating the Output Power Error for a Single 
Waveform Sample Point" and Figure 5- 23, “Calculating the RMS Voltage of the 
Waveform.”

NOTE A successful power search is dependent on a valid power search reference.

• Fixed – Reference level is 0.5 Vrms. 

This reference functions with internal, external IQ and bursted signals. This is the instrument’s 
default setting. 

• RMS – User provided reference level 0–1.414 Vrms placed in the Waveform Header. Refer to 
“Saving a Waveform’s Settings & Parameters” on page 139.

This reference functions with internal IQ and bursted signals.

• Manual – User provided reference level 0–1.414 Vrms. 

This reference functions with internal, external IQ and bursted signals. 

• Modulated – Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external IQ. It is not functional with bursted signals or 
a signal with varying Vrms.
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Figure 5-22 Calculating the Output Power Error for a Single Waveform Sample Point

Figure 5-23 Calculating the RMS Voltage of the Waveform

The RMS and MANUAL references are the most powerful selections. The user provides the reference 
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the 
RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value of 
the waveform. 

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated 
rms value of 1 and can be measured using SINE_TEST_WFM. 

The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not 
require the IQ signal to be present.

NOTE The MXG/EXG reference voltage is designed to operate between 0.1 Vrms to 1 Vrms 
nominally, but it can overrange to 1.414 Vrms. (The RMS can overrange to 1.414, if the 
constant values are loaded manually and all “1”s are entered for the I and Q values.) See 
also “Saving a Waveform’s Settings & Parameters” on page 139.

CAUTION The minimum reference level that results in a successful power search is dependent on 
RF Frequency, RF Amplitude, and Temperature. An MXG/EXG power search using a 
reference level of 0.1 Vrms for 0 dBm at 1 GHz may fail.

20 10 V1( ) V2( )⁄( )log×=

Where:
V1 is the actual waveform RMS voltage
V2 is the entered RMS voltage

The Output Power Error

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired. 
If the RMS voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

The signal generator can calculate the RMS value automatically.if more 
than two contiguous IQ data points are zero, the signal generator 
calculation ignores those zero points. Also, because the RMS calculation, 
that is done by the signal generator, is slow and may not be appropriate 
for your application, it is recommended that the user calculate and enter 
in their measured RMS value for the waveform file.

RMS value for the waveform =

SCPI Commands:
[:SOURce]:RADio:ARB:HEADER:RMS <"file_name">,<val>|UNSPecified 
[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the 
Documentation CD that came with this instrument.
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Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:

• The I/Q modulation enabled On.

• The RF output enabled On.

• The Automatic Leveling Circuitry deactivated (Off).

• The RF Blanking set to On. 

This function prevents power spikes during the power search (refer to “Using the RF Blanking 
Marker Function” on page 156.)

• When using summing for the internal Arb and the external I/Q, all four power reference modes 
are available (e.g. Fixed, RMS, Manual, and Modulated).

• When using the external IQ inputs, use the MANUAL reference mode, and make sure the external 
I/Q signal is present when executing a power search. If the external I/Q signal is not present, the 
power search will fail.

Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control: 

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change 
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes. 
The Do Power Search feature enables you to decide when to execute a power search to compensate 
for changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) from the entered value.

RF Output = entered value − offset value

Displayed Value = output frequency + offset value

To set an offset:

• Frequency: Press Freq > Freq Offset > offset value > frequency unit.
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• Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

When using the signal generator as a local oscillator (LO), you can use the offset to display the 
frequency of interest, as illustrated below:

Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) by the entered value from a chosen reference value. 

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set  
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”  

Parameter Example
#1

Example
#2

Example
#3 Comments

Entered (and displayed) Value: 300 MHz 300 MHz 2 GHz The entered value must be positive.

Offset: 50 MHz −50 MHz −1 GHz An offset value can be positive or negative.

Output Frequency: 250 MHz 350 MHz 3 GHz The signal generator alerts you if the  
output frequency or amplitude is out of range.

Indicates that an offset is on

IF AmplifierRF Amplifier Mixer Filter

Signal Generator
(local oscillator)

Output Frequency = 1000 MHz

IF = 321 MHz

Antenna tuned to 1321 MHz

Selected Offset
321 MHz
−679 MHz

SIgnal Generator Display
1321 MHz  (Antenna Frequency)
  321  MHz (IF Output)

IF Output
321 MHz
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All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set 
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.” 
All amplitudes entered are interpreted as being relative to this reference amplitude.

Examples

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the 
steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple 
(positive or negative) of the output value. 

Displayed Value = multiplier value × output frequency

Output Frequency = displayed value ÷ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency. 
The display equals the output frequency times the multiplier value.

Parameter Example
#1

Example
#2

Example
#3 Comments

Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) Value: 2 MHz −2 MHz −1 GHz The entered value can be positive or negative.

Output Frequency: 52 MHz 48 MHz 1 GHz The signal generator alerts you if the output frequency or 
amplitude is out of range.

Indicates that a reference is on
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Examples

When using the signal generator as the input to a system, you can set the frequency multiplier so 
that the signal generator displays the output of the system, as illustrated below using a doubler:

When measuring mixers, the frequency multiplier and frequency offset are often used together. In the 
upconverter example below, the multiplier is set to −1 and the offset is set to 3 GHz so that the 

Parameter Example
#1

Example
#2

Example
#3 Comments

Frequency Multiplier: 3 −3 4 The multiplier range can be set from:

 +0.001 to +1000

 –1000 to –0.001

Entered (and displayed) Value: 600 MHz −600 MHz 8 GHz

Output Frequency: 200 MHz 200 MHz 2 GHz The signal generator alerts you if the output frequency is 
out of range.

Indicates that a frequency multiplier is on

Signal Generator Doubler

Output = 4 GHzX2Input = 2 GHz Selected 
Multiplier
2

Signal Generator 
Output
2 GHz

Entered/Displayed 
Frequency
4 GHz
108 Agilent MXG and EXG X-Series Signal Generators User’s Guide



 Optimizing Performance
Using the Frequency and Phase Reference Softkeys
signal generator displays fRF.

Using the Frequency and Phase Reference Softkeys
The MXG/EXG can be set to have either a user- determined frequency or phase reference.

Figure 5-24 Frequency Reference and Frequency Offset Softkeys

Using Free Run, Step Dwell, and Timer Trigger
Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in 
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 5- 25 on page 111) the signal generator waits for the signal to 
settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition, 
the time to complete the entire sweep can vary. There is always a minimum value of Step Dwell for 
each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The 
time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling 
time is dependent on frequency, amplitude, band crossings, and other factors, so the time between 
frequency points can vary. 

Mixer

Signal Generator
(local oscillator)

fLO = 800 − 600 MHz

fIF = 3000 MHz

Selected 
Multiplier 

−1
−1

Signal Generator 
Output (fLO) 

800 MHz
600 MHz

fRF = 2200 – 2400 MHz

Selected 
Offset 

3000 MHz
3000 MHz

Entered/Displayed 
Frequency 
(fRF)
2200 MHz
2400 MHz
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Optimizing Performance 
Using Free Run, Step Dwell, and Timer Trigger 
Timer Trigger instead of Free Run (Figure 5- 25 on page 111) the signal generator generates equally 
spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time 
between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast, 
the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the 
point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point can 
vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal 
generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is 
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms, 
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers. 
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 Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger
Figure 5-25 Free Run, Set Dwell, and Timer Trigger Softkeys

Sweep > Configure Step 
Sweep > More 

Use Step Dwell with Free Run when additional measurement wait 
time is desired after settling.
If the signal is to be settled for a minimum specific time at each point 
and it is not important if the point to point time is consistent, use 
Step Dwell and Free Run time.

Sweep > More 

If the signal’s point to point time 
requires consistency but the 
specific settling time at each point 
can vary, then use the Timer 
Trigger. Avoid using too fast of a 
sweep which does not allow the 
signal generator to settle.  
If the signal needs to be settled for 
a specific minimum time and 
consistent point to point time is 
required, then you should set the 
Timer Trigger to be the sum of the 
switching time (900 us (Option 
UNZ) or 5 ms (Standard)) plus the 
minimum settled time that is 
needed to make the measurement. 
Example: If you need the signal to 
remain settled for 3 ms, and you 
have Option UNZ which settles in 
0.9 ms, then set the time trigger to 
the sum which is 3.9 ms.For details on each key, use key help as described 
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Optimizing Performance 
Using a USB Keyboard 
Using a USB Keyboard
You can use a USB keyboard to remotely control the RF output state, the modulation state, and to 
select a memory sequence and register. 

The register selection, RF output state, and modulation state are affected by power cycle or preset, 
but the USB keyboard control state and the sequence selection are not.

CAUTION To avoid the loss of data, GPIB settings, or current user instrument states that have not 
been permanently saved to non- volatile memory, the signal generator should always be 
powered down either via the instrument’s front panel power button or the appropriate 
SCPI command. Signal generators installed in rack systems and powered down with the 
system rack power switch rather than the instrument’s front panel switch display a 
Error –310 due to the instrument not being powered down correctly.

Turning the USB keyboard control off disables the USB 
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 34.

USB Keyboard Key
Delete, Enter

Insert

Home, Up Arrow

End, Down Arrow

Page Up, Right Arrow, +

Page Down, Left Arrow, –

Signal Generator Function
RF On/Off

Mod On/Off

Next Sequence

Previous Sequence

Recall Next State Register

Recall Previous State Register
Deletes every register in every sequence.

NOTE: You cannot recover the registers after 
deleting them.
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6 Using Pulse Modulation (Option UNW or 320)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

• Pulse Characteristics on page 115

• The Basic Procedure on page 117

• Example on page 117

• Pulse Train (Option 320 – Requires: Option UNW) on page 119
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Using Pulse Modulation (Option UNW or 320) 
 

Figure 6-1 Pulse Softkeys

page 117

page 117

Latency from the external 
pulse input to the pulse 
sync output ≈ 50−60 ns.
Width      Period
50 ns       > 50 ns
20 ns       ≤ 50 ns

For details on each key, use key help 
as described on page 34.

Determines how the signal generator 
responds to an external pulse signal.
Normal = high state.
Invert = low state.

Low = settled

TTL signal

See also, page 13 
and page 16

Select the signal 
routed to each 
output connector.

Available on vector 
instruments with 
BBG.

These softkeys are 
only available when 
the Pulse–Source is 
set to Adjustable 
Doublet.

page 119

Note: Pulse Period 
and Pulse Width are 
not available when 
Pulse Train is selected 
as the Pulse Source.
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 Using Pulse Modulation (Option UNW or 320)
Pulse Characteristics
Pulse Characteristics

NOTE When using very narrow pulses that are below the signal generator’s ALC pulse width 
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn 
ALC off (see page 102).

Pulse Source Type Perioda

aAll delays, widths, and periods have a resolution of 10 ns.

Width & Delaya Uses Trigger Eventb,

bA signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Square Internal free run pulse train with 
50% duty cycle.

Determined by 
user defined rate. ⎯ ⎯

Free Run  
(default) Internal free run pulse train User Defined User Defined ⎯

Triggered Internal pulse train ⎯ User Defined ✓

Adjustable  
Doublet

Two internal pulse trains for each 
trigger event. ⎯

User Defined:

First pulse is relative to the 
rising edge of trigger signal.

Second pulse is relative to the 
rising edge of first pulse.

See Figure 6- 2 on page 116

✓

Trigger  
Doublet

Two internal pulse trains for each 
trigger event. ⎯

The first pulse follows the 
trigger signal.

Second pulse is user defined.

See Figure 6- 3 on page 116

✓

Gated Internal gated pulse train ⎯ User Defined ✓

External External pulse signal at the rear 
panel Pulse connector ⎯ ⎯ ⎯

Pulse Train Internal pulse train
User Defined

User Defined:

See Figure 6- 4 on page 119

✓
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Using Pulse Modulation (Option UNW or 320) 
Pulse Characteristics 
 

Figure 6-2 Adjustable Doublet

Figure 6-3 Trigger Doublet

 

Rear panel inputs are described on page 12

External pulse input

The delay of the first pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The delay of the second pulse is measured from 
the leading edge of the first pulse.

Delay Width
Pulse 2Pulse 2

Pulse 1Pulse 1

The delay of the second pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The first pulse follows the 
external trigger signal.

Pulse 1 Pulse 1
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 Using Pulse Modulation (Option UNW or 320)
The Basic Procedure
The Basic Procedure
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 48.

Example
The following example uses the factory preset pulse source and delay.

1. Preset the signal generator.

2. Set the frequency to 2 GHz.

3. Set the amplitude to 0 dBm.

Square Free Run 
(default)

Triggered Adjustable Doublet Trigger Doublet Gated Pulse 
Traina

a Requires Option 320.

External

Pulse Rate ⎯ ⎯ ⎯ ⎯ ⎯ ⎯ ⎯

⎯ Pulse 
Period

⎯ ⎯ ⎯ Pulse Period ⎯ ⎯

⎯ Pulse 
Delay

Pulse Delay Pulse Delay Pulse Delay ⎯ Pulse Delay ⎯

⎯ Pulse 
Width

Pulse Width Pulse Width Pulse Width Pulse Width ⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Delay ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Width ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Onb

b Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user defined.

⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Offb ⎯

Output: A 2 GHz, 0 dBm carrier modulated by a 24 μs pulse that has a period of 100 μs.
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Using Pulse Modulation (Option UNW or 320) 
Example 
4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

5. Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

6. Turn on both the pulse modulation and the RF output. 

The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 310. 
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 Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 – Requires: Option UNW)
Pulse Train (Option 320 – Requires: Option UNW) 
The Option 320 Pulse Train feature enables the specification of up to 2047 independent pulse cycles, 
each of which has an “On Time”, during which the RF output is measurable at the RF output 
connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is similar 
in function to other X- Series signal generator Pulse modes—the Pulse Train feature has up to 2047 
cycles, instead of only a maximum of two (with Doublets). There are also repeat counts available for 
each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other 
common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of 
the decimal separator and a column separator. The import allows specification of the decimal 
separator (to allow for ","), but the column separator is auto- detected. Refer to “Pulse Train Menu 
Softkeys” on page 119 and “Display Pulse Train Menu Softkeys” on page 121.

Figure 6-4 Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train 

Free-Run continuously plays 
the pulse train, ignoring all 
triggers.
Triggered runs the pulse 
train (after waiting the Pulse 
Delay) each time an external 
trigger is supplied to the 
PULSE BNC, the Trigger 
Immediately softkey is 
pressed, or the Trigger SCPI 
command is sent.
Gated runs the pulse train 
while an external trigger is 
supplied (level triggered) to 
the PULSE BNC connector. 
The state of the GATEd 
trigger is detected only when 
the playback is transitioning 
to or in idle. This means that, 
once started, playback is 
always completed, even if 
the GATE trigger changes to 
the inactive state.

For details on each key, use key help as described on page 34.

Display area indicates Pulse Train is the current pulse 
source.

Trigger Immediately causes 
the pulse train to run once.

SCPI Commands:

[:SOURce]:PULM:INTernal:TRAin:TRIGger FRUN|{TRIGgered}|GATEd
[:SOURce]:PULM:INTernal:TRAin:TRIGger:IMMediate  

Refer to the SCPI Command Reference.
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Using Pulse Modulation (Option UNW or 320) 
Pulse Train (Option 320 – Requires: Option UNW) 
Figure 6-5 Edit Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train

page 121

This column indicates the 
row of a each pulse train 
cycle.
Note: When the cycles 
(elements) are repeated, 
the row numbers are 
skipped in the displayed 
count for the number of 
pulse cycles repeated.
Example: For the pulse 
train displayed above, in 
row 2, the 3 us On Time 
and 2 us Off Time pulse 
cycle is repeated twice. 
But, only row 2 is 
displayed for that pulse 
cycle (i.e. row 3 is not 
displayed). 

This column 
displays the on 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the off 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the repeat 
times for each 
pulse cycle 
(element) in the 
pulse train.

These softkeys provide 
ease of use in changing 
the pulse cycle settings 
in the pulse train.

SCPI Commands:
[:SOURce]:PULM:INTernal:TRAin:LIST:PRESet
[:SOURce]:PULM:INTernal:TRAin:OFFTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:OFFTime?
[:SOURce]:PULM:INTernal:TRAin:OFFTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:ONTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:ONTime?
[:SOURce]:PULM:INTernal:TRAin:ONTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:REPetition <1-2047>
[:SOURce]:PULM:INTernal:TRAin:REPetition?
[:SOURce]:PULM:INTernal:TRAin:REPetition:POINts? 

Refer to the SCPI Command Reference.

SCPI Commands (continued):
:MEMory:CATalog:PTRain? 

:MEMory:DELete:PTRain

:MEMory:EXPort[:ASCii]:PTRain <"filename">

:MEMory:EXPort[:ASCii]:SEParator:COLumn 
TAB|SEMicolon|{COMMa}|SPACe

:MEMory:EXPort[:ASCii]:SEParator:COLumn?

:MEMory:EXPort[:ASCii]:SEParator:DECimal 
{DOT}|COMMa

:MEMory:EXPort[:ASCii]:SEParator:DECimal?

:MEMory:IMPort[:ASCii]:PTRain <"filename">

:MEMory:IMPort[:ASCii]:SEParator:DECimal 
{DOT}|COMMa

:MEMory:IMPort[:ASCii]:SEParator:DECimal?

:MMEMory:LOAD:PTRain <"filename">

:MMEMory:STORe:PTRain <"filename">

For details on each key, use key help as described on page 34.

page 122
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 Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 – Requires: Option UNW)
Figure 6-6 Display Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > Display Pulse Train

Use these softkeys to optimize 
the view of the different 
characteristics of the pulse 
train.

This softkey shifts the time 
offset from the left hand side 
of the display to the one 
specified. Increments and 
decrements are 1/20th of 
the visible pulse train.

This value can be 
adjusted with the 
Time Offset softkey.

These are the division markers currently 
set at 10.00 us/div for the currently 
displayed view. Use the zoom softkeys 
to change the time/div value.

This is the initial 
pulse cycle (row 1) 
note that the On 
Time portion of this 
pulse is not showing 
due to the  
2 us offset.

5th, 6th, and 7th 
pulse cycles 
(elements) or rows 
5, 6, and 7.

Final pulse cycle 
(element) in the 
displayed pulse 
train above. 8th 
pulse cycle or row. 
number 8.

2nd and 3rd 
pulse cycles 
(elements) or 
rows 2 and 3.

4th pulse cycle 
(element) or row 4.

For details on each key, use key help as described on page 34.
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Using Pulse Modulation (Option UNW or 320) 
Pulse Train (Option 320 – Requires: Option UNW) 
Figure 6-7 Pulse Train: Import From Selected File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

page 53

These softkeys delete 
individual On Time or Off 
Time elements as well as the 
Repeat cycle counts.

This file’s data structure uses decimals in the numbers 
and so requires the Import Decimal Separator to be set to 
Dot.

Selects whether the decimal point 
is a "." or a "," during import of 
CSV/ASCII files.
This value is persistent across 
preset/recall and power cycles.

SCPI Commands:
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal DOT|COMMa
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal?

After confirming import of the file 
the new file’s pulse train values 
are displayed.

Deleting all Pulse Cycle rows 
(elements) must be 
confirmed.

For details on each key, use key help as described on page 34.

Note: Column 
separated values are 
auto-detected by the 
instrument.

page 123

page 123
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 Using Pulse Modulation (Option UNW or 320)
Pulse Train (Option 320 – Requires: Option UNW)
Figure 6-8 Pulse Train: Export to File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

page 122

Use the text editor keys to 
rename the file to be exported 
to the BIN (Binary) folder. 

The Export to File softkey menu, 
writes out a CSV/ASCII file to the 
BINARY directory. You may supply 
your own extender as part of the 
filename.
Example: 
MEM:EXP:PTR "myfile.csv".
SCPI Command:
:MEMory:EXPort[:ASCii]:PTRAin 
<"filename">

Note: Files can be FTP’d to the BIN (Binary) folder in the instrument, or a USB 
stick can be used to download the files to the instrument. Refer to page 55.

For details on each key, use key help as described on page 34.

Note: Since there is already a file named PTRAIN.CSV the new 
filename should be different, to avoid overwriting the original 
PTRAIN.CSV file.

Selects whether the column 
separator is a tab, “;”, “,” or “a “ ” 
during export of the CSV/ASCII 
files. This value is persistent 
across preset/recall and power 
cycles.
SCPI Commands: 
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn 
TAB|SEMicolon|COMMa|SPACe
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn?

Selects whether the 
decimal point is a “.” 
or “, “ ” during export 
of the CSV/ASCII 
files. This value is 
persistent across 
preset/recall and 
power cycles.
SCPI Commands: 
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal DOT|COMMa
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal?
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Using Pulse Modulation (Option UNW or 320) 
Pulse Train (Option 320 – Requires: Option UNW) 
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7 Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 33 and familiarize yourself with the information in that chapter.

See also “Adding Real–Time Noise to a Dual ARB Waveform” on page 229.
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Basic Digital Operation—No BBG Option Installed
I/Q Modulation
I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu provides adjustments and calibration to compensate for some of the differences in the 
I and Q signals or to add impairments. See I/Q Modulation on page 188 for additional information.

See also “Modulating the Carrier Signal” on page 48.

Figure 7-1 I/Q Display and Softkeys

This panel displays the external 
I/Q signal routing.

This panel displays the current status and settings 
of the I/Q adjustments. Grey text indicates I/Q 
adjustments are off.

For details on each key, use key help 
as described on page 34.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The quadrature adjustment key is in 
units of degrees. This adjustment is 
not calibrated. 

Sets the dc 
offset

Toggles between DC, User, and Full IQ calibration types. 
DC: Calibrates I/Q offset, gain and quadrature error for a single 
frequency at the current signal generator settings. 
This calibration requires that the I/Q be on, the optimized path be set to 
RF Out, and the source be set to the internal baseband generator. 
Changing any instrument setting except for I/Q adjustments after 
performing a DC calibration voids the DC calibration and causes the 
signal generator to revert to the factory supplied calibration data. 
User: Calibrates I/Q offset, gain, and quadrature error for all signal 
generator settings over a range of frequencies that you define. 
Full: Calibrates I/Q offset, gain, and quadrature error for all settings 
over the full frequency range of the signal generator.

Starts the I/Q calibration 
routine for the selected 
frequency range. (Use the 
Calibration Type softkey to 
select the frequency range.) 
You can abort the 
calibration by pressing the 
Abort Cal softkey or the 
Local Cancel/(Esc) hardkey. 
If you abort the calibration, 
the previous calibration data 
is restored.
This calibration should be 
run when the ambient 
temperature has varied by 
at least +/-5 degrees 
Celsius from the ambient 
temperature at which the 
previous calibration was 
run.
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Basic Digital Operation—No BBG Option Installed
I/Q Modulation
The following table shows common uses for the adjustments.

Configuring the Front Panel Inputs

The MXG/EXG accepts externally supplied analog I and Q signals through the front panel I Input and 
Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel 
Overview” on page 5. 

a. Connect an analog I signal to the signal generator’s front panel I Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.

3. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 126) as needed.

Table 7-1 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier Feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay
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I/Q Modulation
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8 Basic Digital Operation (Option 653/655/656/657)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 33 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 653 
or 655 (N5172B) or Option 656 or 657 (N5182B).

• Waveform File Basics on page 130

• Storing, Loading, and Playing a Waveform Segment on page 132

• Waveform Sequences on page 135

• Saving a Waveform’s Settings & Parameters on page 139

• Using Waveform Markers on page 145

• Triggering a Waveform on page 162

• Clipping a Waveform on page 169

• Scaling a Waveform on page 178

• Setting the Baseband Frequency Offset on page 184

• I/Q Modulation on page 188

• I/Q Adjustments on page 192

• I/Q Calibration on page 194

• Using the Equalization Filter on page 196

• Using Finite Impulse Response (FIR) Filters in the Dual ARB Real- Time Modulation Filter on page 
198

• Modifying a FIR Filter Using the FIR Table Editor on page 204

• Setting the Real- Time Modulation Filter on page 208

• Multiple Baseband Generator Synchronization on page 209

• Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator 
Synchronization on page 216

• Waveform Licensing on page 221

See Also: 

• Adding Real–Time Noise to a Dual ARB Waveform on page 229

• Real–Time Phase Noise Impairment on page 238

• Multitone and Two–Tone Waveforms (Option 430) on page 297
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Basic Digital Operation (Option 653/655/656/657) 
Waveform File Basics 
Waveform File Basics
There are two types of waveform files: 

• A segment is a waveform file that you download to the signal generator.

For information on creating and downloading waveform files, refer to the Programming Guide. 

• A sequence is a file you create in the signal generator that contains pointers to one or more 
waveform files (segments, other sequences, or both). 

For information on creating sequences, see page 135.

Signal Generator Memory

The signal generator has two types of memory:

• Volatile memory, baseband generator (BBG) media, where waveform files are played from or 
edited.

• Non–volatile memory, either internal (int) or external (USB) media, where waveform files are 
stored.

Dual ARB Player

NOTE The MXG/EXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 
file cache limit has been reached, the waveform switching speed will be much slower for 
additional files loaded into the volatile waveform memory (BBG).

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or 
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player 
also provides markers (page 145), triggering (page 162), clipping (page 169), and scaling (page 178) 
capabilities.

Most procedures in this section start from the Dual ARB menu, shown below. 
130 Agilent MXG and EXG X-Series Signal Generators User’s Guide 



 Basic Digital Operation (Option 653/655/656/657)
Waveform File Basics
Figure 8-1 Dual ARB Softkeys

page 229

page 169

page 178

page 169

page 132

If you set the ARB sample clock when the dual ARB 
is off, the new setting is applied when the dual ARB 
player is turned on; this setting survives toggling 
the Dual ARB player off and on.

page 42

page 139

page 162

For details on each key, use key help 
as described on page 34.

Note: This is second of 
           two Arb menus.

page 135

page 184

page 178

page 178

page 187

page 209

These softkeys are 
only available in 
the Dual ARB’s 
Arb Setup menu.

page 145

Available on  
vector models with 
opt 2xx.

page 221

page 209
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Storing, Loading, and Playing a Waveform Segment

NOTE The MXG/EXG’s ARB Waveform File Cache is limited to 128 files. Consequently, once the 128 
file cache limit has been reached, the waveform switching speed will be much slower for 
additional files loaded into the volatile waveform memory (BBG).

Before using this information, you should be familiar with the signal generator’s file menus. If you 
are not, refer to “Working with Files” on page 50 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 135.

The signal generator has two types of waveform media: non–volatile (internal or USB), and volatile 
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a 
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 8-2 Waveform Segment Softkeys

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence. 
Cycling power or rebooting the signal generator deletes the files in BBG media.

NOTE Each time the instrument powers up, two factory–supplied segments are automatically 
created in BBG media: RAMP_TEST_WFM and SINE_TEST_WFM.

There are additional sample waveforms that are available in the internal storage and that 
can be loaded into memory. Refer to www.agilent.com and search on “Factory Default 
N5182B” and “waveforms”.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

page 145

For details on each key, use key help 
as described on page 34.

Note: When a sequence is selected, this key name 
changes to Show Waveform Sequence Contents.

Use the arrow keys or knob to 
highlight a letter or character.

These keys change to indicate the default media.  
For information on selecting the default media,  
see page 61.
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2. Press Load Store to highlight Load, then use the arrow keys to highlight the desired waveform 
segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press 
Load All From currently selected Media. 

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media 
(page 61). If you have not downloaded a waveform segment, either refer to the Programming Guide, 
or use one of the factory–supplied segments. 

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.

4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.
b. Enter a name for the waveform segment.
c. Press Enter > More.
d. Highlight the waveform segment that was renamed.

5. Press Store Segment to currently selected Media.

6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press 
Store All to currently selected Media.

Playing a Waveform Segment
1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press Select Waveform.

4. Set ARB Off On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the 
waveform modulates the RF carrier. 
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5. Configure the RF Output: 

Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Waveform Sequences

Figure 8-3 Waveform Sequence Softkeys

A waveform sequence is a file that contains pointers to one or more waveform segments or other 
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or 
other sequences, or both thereby eliminating the need to stop waveform playback just to select 
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the 
sequence; you must also store the individual segments or they are lost when you turn off or reboot 
the signal generator. If the segments are located in internal/external media, you must load them into 
BBG media prior to selecting a waveform sequence (see page 132). If you attempt to play a sequence 
without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File 
format invalid. If this happens and the segments are not stored in internal/external media, you 
must recreate the segments using the same file names that the sequence points to before you can 
play the sequence. 

For details on each key, use key help 
as described on page 34.

Mode > 
Dual ARB

Sequence name

Sequence contents

see page 158

To display this softkey, select a waveform sequence.
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Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences 
(nested sequences). The signal generator lets you set the number of times the segments and nested 
sequences repeat during play back. But there is a difference between repeating a segment versus 
repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many 
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence 
counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of 
segments in the nested sequence and the remaining number of allowed segments (1,024). For 
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the 
nested sequence is limited to 250 repetitions:

24 + (4 × 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can 
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of 
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading 
waveform segments into BBG media, see page 132. 

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert 
Waveform.

b. Highlight the desired waveform segment and press Insert.

2. Select the second segment:

a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

Waveform 
Sequence

Sequence A

Sequence B

Sequence A 
repeated 4x

Segment 1

Segment 2

Segment 3

2 segments

9 segments

11 segments

8 Segments
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3. Name and store the waveform sequence to the Seq file catalog:

a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 137 and “Setting Marker Points in a 
Waveform Segment” on page 152.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

• change the number of times each segment or nested sequence plays
• delete segments or nested sequences from the sequence
• add segments or nested sequences to the sequence
• toggle markers on and off (described on page 158)
• save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not 
automatically update the RMS value in its header. You must select and update the 
sequence header information (page 139).

Use the following steps to edit a sequence that has two different segments so that the first segment 
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see 
previous example on page 136).

1. Select the sequence:  
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence > 
Edit Selected Waveform Sequence.
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2. Change the first segment so that it repeats 100 times:  
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry. 

3. Change the repetition for the selected entry to 200:  
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:  
Press More > Name and Store > Enter.

To save the changes as a new sequence: 

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RAMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence. 

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 136.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment 
must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on 
page 132.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RAMP200) from the Sequence On 
column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: 
SEQ:SINE100+RAMP200).

Current waveform selection

Annunciators display with active waveform (ARB On)
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2. Generate the waveform:  
Press ARB Off On to On. 

This plays the selected waveform sequence. During the waveform sequence generation, both the 
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier. 

3. Configure the RF output: 

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector. 

Saving a Waveform’s Settings & Parameters
This section describes how to edit and save a file header. When you download only a waveform file 
(I/Q data, which the signal generator treats as a waveform segment), the signal generator 
automatically generates a file header and a marker file with the same name as the waveform file. 
Initially the file header has no signal generator settings saved to it, and the marker file consists of all 
zeros. For a given waveform, you can save signal generator settings and parameters in its file header 
and marker settings in its marker file (page 145); when you load a stored waveform file into BBG 
media, the file header and marker file settings automatically apply to the signal generator so that the 
dual ARB player sets up the same way each time the waveform file plays. 

Figure 8-4 Header Utilities Softkeys

When you create a waveform sequence (as described on page 136), the signal generator automatically 
creates a waveform sequence header that takes priority over the individual waveform segment 
headers. During a waveform sequence playback, the segment headers are ignored, except to verify 
that all required options are installed. Storing a waveform sequence also stores its file header. 

Some of the current signal generator settings shown in the file header appear as part of the softkey 
labels, and others appear in the dual ARB summary display, shown in the following example.

page 142

Mode > Dual ARB >  
More > 
Header Utilities

For details on each key, 
use key help 
as described on 
page 34.
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Table 8-1 File Header Entries  

32–Character Description A description entered for the header, such as a the waveform’s function (saved/edited with the Edit 
Description softkey, see Figure 8- 4).

Sample Rate The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown 
in Figure 8- 1 on page 131).

Runtime Scaling The Runtime scaling value is applied in real–time while the waveform is playing. This setting can be 
changed only for files playing in the dual ARB player (see page 181).

RMS When the modulator attenuation setting (see page 131) is set to Auto, this value is used to calculate 
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562.

Marker 1...4 Polarity Marker polarity can be positive or negative (described on page 158). 

ALC Hold Routing Which marker, if any, implements the ALC hold function (described on page 147), which holds the 
ALC at its current level when the marker signal is low. All waveforms generated in the signal 
generator have a marker on the first sample point. To see the results from the three routing 
selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in 
a Waveform Segment” on page 152). 

ARB summary, file
header settings

Softkey labels,
file header
settings

Softkey label,
file header
setting

All settings in this menu can be stored to 
the file header (Table 8-1 on page 140 
lists all settings stored in a file header)

The Runtime 
Scaling softkey is 
only available under 
the Dual ARB menu.

see page 184
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Viewing and Modifying Header Information 

The following example uses the factory–supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM: 

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP_TEST_WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 8- 5 shows the default file header for the factory–supplied waveform RAMP_TEST_WFM. 
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified. 
Unspecified means that there is no setting saved for that particular parameter.

RF Blank Routing Which marker, if any, implements the RF blanking function (described on page 156) when the 
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold 
Routing for the same marker when you are using the RF Blank Routing function. When the marker 
signal goes high, RF blanking discontinues. 

Mod Attenuation The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8- 1 on 
page 131).

BB Freq Offset The baseband frequency offset, in Hz (see page 184).

AWGN: State Indicated whether real–time noise is on (1) or off (0) (see page 229).

AWGN: C/N Ratio Carrier to noise ration, in dB (see page 234).

AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see page 234).

AWGN: Noise BW Bandwidth of the noise, in Hz (see page 234).

AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see page 234).

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 238).

Phase Noise F1 The start frequency for the level mid–frequency characteristics (see page 238).

Phase Noise F2 The end frequency for the level mid–frequency characteristics (see page 238).

Phase Noise Lmid The amplitude for the level mid–frequency characteristics (see page 238).

Modulation Filter The real- time modulation filter type selected (see page 208).

Over–Range Protect Indicated whether DAC Over–Range Protection is on (1) or off (0) (see page 242).

Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and 
Licenses” on page 30

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.

Table 8-1 File Header Entries  (Continued)
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The Current Inst. Settings column shows the current signal generator settings. In this 
example, these are the settings that you will save to the file header. 

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for 
that setting when you select and play the waveform.

Figure 8-5 Example File Header

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now display 
the same values; the Saved Header Settings column lists the settings saved in the file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu:  
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file 
header. Figure 8- 1 on page 131 shows the ARB Setup softkeys used in the following steps.

b. Set the ARB sample clock to 5 MHz:  
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%: 
Press Waveform Runtime Scaling > 60 > %.

The name of the waveform file.

The description can be up to 
32–characters.

Mode > Dual ARB > More > Header Utilities

Default header settings Current signal generator settings

Resets the saved 
header settings 
entries to default 
settings

To calculate the RMS waveform voltage: 
Press Calculate
Then refer to Header Field information.
Note: For greater accuracy, if the waveform has long rise/fall times, a DC 
offset, or noise* already added to the waveform (for a bursted signal), it 
is recommended that the Edit RMS and Edit AWGN RMS Override 
softkeys are used for the best measurement accuracy. 
*Option 403 Real–time AWGN does not affect the Header Field RMS 
value. But, noise added to the waveform prior to downloading and 
playing in the signal generator does affect the Header Field RMS value.

Opens a menu for manually 
defining the carrier RMS value 
to use for calculating the 
AWGN: Carrier RMS value in 
the Header Field. 
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d. Return to the Header Utilities menu:  
Press Return > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the 
changes to the current signal generator setup, but the saved header values have not changed.

e. Save the current settings to the file header:  
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header 
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the 
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column 
and are used instead of the saved header settings. To reapply the saved header settings, reselect the 
waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 141, you can view and edit a waveform’s header information after you select 
the waveform; you can also edit waveform header information without selecting a waveform, or for 
another waveform than the one that is currently selected.

1. Access the file header utilities menu: 
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last 
selected. The following figure shows an example of the factory–supplied waveforms in BBG media.

Values differ between  
the two columns
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2. If the desired catalog is not displayed, select it. 

3. Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file. 

4. To edit the header, press More, and proceed as described in Step 4 on page 142 (Viewing and 
Modifying Header Information section).

Active waveform catalog

Active media

Type:
WFM1 = Volatile Segment
NVWFM = Non–Volatile Segment
SEQ = Sequence

Active catalog

For details on each key, use key help 
as described on page 34.

Catalogs that enable you to 
view files in the active media.

For details on selecting the 
active media, see page 52.

Files in BBG media
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Using Waveform Markers
The signal generator provides four waveform markers to mark specific points on a waveform segment. 
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear 
panel event output that corresponds to the marker number.

• Event 1 is available at both the EVENT 1 BNC connector (see page 16), and a pin on the 
AUXILIARY I/O connector (see page 17).

• Event 2 is available at the TRIG 1 & TRIG 2 connectors (see page 13), and a pin on the 
AUXILIARY I/O connector (see page 17).

• Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 17).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a 
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer 
to “Using Waveform Markers” on page 145 for details.

When you download a waveform file that does not have a marker file associated with it, the signal 
generator creates a marker file without any marker points. Factory–supplied segments 
(RAMP_TEST_WFM and SINE_TEST_WFM) have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. 
These procedures also discuss two types of points: a marker point and a sample point. A marker 
point is a point at which a given marker is set on a waveform; you can set one or more marker 
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

Clearing Marker Points from a Waveform Segment on page 151

Setting Marker Points in a Waveform Segment on page 152

Controlling Markers in a Waveform Sequence on page 158

This section also provides the following information:

• Waveform Marker Concepts on page 146

• Accessing Marker Utilities on page 150

• Viewing Waveform Segment Markers on page 151

• Viewing a Marker Pulse on page 155

• Using the RF Blanking Marker Function on page 156

• Setting Marker Polarity on page 158
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 145



Basic Digital Operation (Option 653/655/656/657) 
Using Waveform Markers 
Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment. 
You can set each marker’s polarity and marker points (on a single sample point or over a range of 
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. 
However some settings such as amplitude, filters, and so forth within the RF output path can create 
delays between the marker EVENT output signal and the modulated RF output. When using the 
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, 
and if needed, reset the marker point positions, include delay (page 192), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker 
file associated with it causes the signal generator to automatically create a marker file, but does not 
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media 
(see “Loading a Waveform Segment into BBG Media” on page 132).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, 
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker 
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header 
(page 139). 

NOTE When you use a waveform that does not have marker routings and polarity settings stored in 
the file header, and the previously played waveform used RF Blanking, ensure that you set 
RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.

Marker 
File
Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF when 
Marker is Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC when 

Marker is Low

When the signal generator encounters an enabled marker (described on page 158), an 
auxiliary output signal is generated and routed to the rear panel. 

Event 1 is available at the EVENT 1 BNC connector (see page 16), and at a pin on the 
AUXILIARY I/O connector (see page 17).

Events 2 through 4 are available at pins on the AUXILIARY I/O connector (see page 17).

RF Blank Only: includes ALC Hold
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before 
or after you set marker points (page 152), setting a marker function before setting marker points may 
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, 
burst ramps, or when the increased dynamic range encountered with RF blanking (page 156) is not 
desired. 

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points 
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output 
signal (the carrier plus any modulating signal) when the marker signal goes high:

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer 
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 103.

CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike 
in the RF output, potentially damaging a DUT or connected instrument. To prevent this 
condition, ensure that you set markers to let the ALC sample over an amplitude that 
accounts for the higher power levels encountered within the signal.

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

Positive Polarity
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Close–up of averaging

The ALC samples the waveform when the marker signal goes 
high, and uses the average of the sampled waveform to set the 
ALC circuitry.

Here the ALC samples during the on marker points (positive 
polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points 
Marker range: 95–97 
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of 
highest amplitude. Note that the marker is set well before the 
waveform’s area of lowest amplitude. This takes into account any 
response difference between the marker and the waveform signal.

 
 

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Positive

This example shows a marker set to sample the low part of the 
same waveform, which sets the ALC modulator circuitry for 
that level; this usually results in an unleveled condition for the 
signal generator when it encounters the high amplitude of the 
pulse.

MarkerMarker
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Sample range begins on first point of signal

Negative range set between signal and  
off time

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during 
the marker on points; the marker signal goes high during the off 
points. The ALC samples the waveform during the off marker 
points.

Marker On Marker On

Sampling both on and off time sets the modulator circuitry 
incorrectly for higher signal levels. Note the increased amplitude 
at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Note: This is the 
second Arb menu.

The display below shows the I and Q components of the waveform, and 

First sample point 
shown on display

These softkeys change 
the range of waveform 
sample points shown 
on the marker display.

Each press of the 
softkey changes the 
sample range by 
approximately a factor 
of two.Marker points 

on first  
sample point

For details on each key, use key help 
as described on page 34.

The settings in these menus 
can be stored to the file 
header, see page 139.

page 42
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a 
segment (this example uses the factory–supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max. 

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range 
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set points, view the segment (page 151) 
and remove any unwanted points. With all markers cleared, the level of the event output signal is 0V. 
To clear marker points on a segment, the segment must reside in BBG media (page 132).

Clearing All Marker Points
1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:

a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the 
waveform. The factory–supplied waveform (SINE_TEST_WFM) contains 200 samples. To clear all 
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other 
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10−20. This 
makes it easy to see the affected marker points. The same process applies whether the existing points 
are set over a range or as a single point (page 152).‘

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13): 
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this 
example, 17): 
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

 
This turns off all marker points for 
the active marker within the range 
set in Steps 2 and 3, as shown at 
right.

How to view markers is described 
on page 151.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 151, but set both the first 
and last marker point to the value of the point you want to clear. For example, if you want to clear 
a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 132).

When you set marker points, they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set marker points within a segment, view 
the segment (page 151) and remove any unwanted points (page 151).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in 
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends 
on sample point 20, as shown in the following figure.

How to view markers is described on page 151
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: 
Press Marker 1 2 3 4.

4. Press  Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 152, but set both the 
first and last marker point to the value of the point you want to set. For example, if you want to set 
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped 
points) between each marker. You must set the spacing before you apply the marker settings; you 
cannot apply skipped points to a previously set range of points.

NOTE The skipped points value is limited to the size of the range of points.

1. Remove any existing marker points (page 146).

2. In the second Arb menu (page 150), press Marker Utilities > Set Markers.

3. Highlight the desired waveform segment. 

4. Select the desired marker number:  
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5): 
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than or 
equal to the number of points in the waveform, and greater than or equal to the first marker 
point, in this example, 25): 
Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1): 
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.
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This causes the marker to occur on 
every other point (one sample point is 
skipped) within the marker point range, 
as shown at right.

How to view markers is described on 
page 151.

One application of the skipped point 
feature is the creation of a clock signal 
as the EVENT output.
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Viewing a Marker Pulse

When a waveform plays (page 138), you can detect a set and enabled marker’s pulse at the rear 
panel event connector/Aux I/O pin that corresponds to that marker number. This example 
demonstrates how to view a marker pulse generated by a waveform segment that has at least one 
marker point set (page 152). The process is the same for a waveform sequence.  

This example uses the factory–supplied segment, SINE_TEST_WFM in the dual ARB Player. 
Factory–supplied segments have a marker point on the first sample point for all four markers, as 
shown.

1. In the first Arb menu (page 131), press Select Waveform.

2. Highlight the SINE_TEST_WFM segment and press Select Waveform.

3. Press ARB Off On to On.

4. Connect the signal generator’s rear panel Q OUT output to the oscilloscope’s channel 1 input.

5. Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2 input. 

When marker 1 is present, the Agilent MXG/EXG outputs a signal through EVENT 1 as shown in 
the following example.

Marker points on 
first sample point of 
waveform segment

How to view markers is described on page 151

Q OUT

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker 
Utilities menu) either before or after setting the marker points (page 152), setting a marker function 
before you set marker points may change the RF output. RF Blanking includes ALC hold (described 
on page 147, note Caution regarding unleveled power). The signal generator blanks the RF output 
when the marker signal goes low. This example is a continuation of the previous example, Viewing a 
Marker Pulse.

1. Using the factory–supplied segment SINE_TEST_WFM, set Marker 1 across points 1−180 (page 152).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:  

In the second Arb menu (page 150), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker 
1.
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Marker Polarity = Positive
When marker polarity is positive (the default 
setting), the RF output is blanked during the off 
marker points.

200180Point 1
Marker

Segment

RF Signal

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on marker 
points

≈3.3V

0V

≈3.3V

0V

RF Signal

RF Signal
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 150), press Marker Utilities > Marker Polarity.

2. For each marker, set the marker polarity as desired.

• The default marker polarity is positive.

• Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 146.

As shown on page 156:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed 
to the rear panel EVENT output (described in “Rear Panel Overview” on page 12) corresponding to 
that marker number. For a waveform sequence, you enable or disable markers on a 
segment–by–segment basis; this enables you to output markers for some segments in a sequence, but 
not for others. Unless you change the sequence marker settings or cycle the power, the marker setting 
for the last segment edited in the sequence applies to all segments in the next sequence that you 
build. For information on building a waveform sequence, see “Creating a Sequence” on page 136.
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Figure 8-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > 
More 

Note: This is the second Arb menu.

For details on each key, use key help 
as described on page 34.

Enable/Disable markers while 
creating a waveform sequence

Edit a sequence to 
enable/disable markers
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s 
markers independently. You can enable or disable the markers either at the time of creating the 
sequence or after the sequence has been created and stored. If the sequence has already been stored, 
you must store the sequence again after making any changes. Enabling a marker that has no marker 
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker 
Points in a Waveform Segment” on page 152. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 132).

2. From the second Arb menu, press Waveform Sequences.

3. Highlight the desired waveform sequence.

4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.

5. Toggle the markers: 

a. Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.

6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 133) or just press Enter to save 
the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory–supplied waveform segments; a 
factory–supplied segment has a marker point on the first sample for all four markers. In this 
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and 
markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output 
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is 
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second 
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.

Sequence marker column

This entry shows that markers 
3 and 4 are enabled for this 
segment.
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Using the EVENT Output Signal as an Instrument Trigger

 
One of the uses for the EVENT 
output signal (marker signal) is to 
trigger a measurement instrument. 
You can set up the markers to start 
the measurement at the beginning 
of the waveform, at any single point 
in the waveform, or on multiple 
points in the waveform. To optimize 
the use of the EVENT signal for 
measurements, you may also need 
to adjust the sample rate. The 
location of the sample rate setting 
is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter 
can be minimized in either of two ways. 

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can 
be represented exactly on the display.  
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on. 

If the result cannot be represented exactly on the display, jitter will be present. 
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when 
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns. 
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz 
provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause 
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample 
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the 
original waveform with a sample rate change, you will have to also recalculate the sample values. The 
following figures illustrate the marker signal jitter and its affect on the waveform.

Sample 
rate  
setting

The settings in this menu 
can be stored to the file 
header, see page 139.

For details on each key, use key help as described on page 34.

The jitter is gone with
an optimal sample rate

Waveform appears to exhibit jitter when
triggered using EVENT signal with jitter.

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal

EVENT output signal exhibits jitter
due to a non–optimal sample rate
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Triggering a Waveform

Figure 8-7 Triggering Softkeys

Triggers control data transmission by controlling when the signal generator transmits the modulating 
signal. You can configure trigger settings so that data transmission occurs once (Single mode), 
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, 
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is 
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To 
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages 
set to values other than zero. 

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering 
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF 
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. 
This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a 
trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF 
carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:

• Type determines the behavior of the waveform when it plays (see Trigger Type on page 163).

• Source determines how the signal generator receives the trigger that starts the modulating 
waveform playing (see Trigger Source on page 164).

Mode > Dual ARB

page 163

page 164

For details on each key, use key help 
as described on page 34.
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered. 

NOTE The example below shows Dual ARB Mode, but trigger functionality is similar for other 
modulation modes. Available trigger types vary depending on the modulation mode selected.

• Continuous mode repeats the waveform until you turn the signal off or select a different waveform, 
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

• Single mode plays the waveform once. 

NOTE In Single No Retrigger, do not use Continuous Reset & Run mode due to the variable latency of 
this setup.

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is dependent 
on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start again. 
The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the 
playback while this is occurring. It will reset itself for every trigger it receives.

Mode > 
Dual ARB > 
Trigger Type

Immediately triggers and plays the waveform; triggers 
received while the waveform is playing are ignored.

Plays the waveform when a trigger is received; 
subsequent triggers are ignored.

Plays the waveform when a trigger is received; subsequent 
triggers restart the waveform.

The waveform stops during the inactive 
state of the trigger source, and plays 
during the active state.

Ignores an early trigger 
received while a 
waveform is playing.

An early trigger received 
while a waveform is 
playing waits until the 
current waveform 
completes, then plays 
the waveform once 

An early trigger received 
while the waveform is 
playing immediately 
restarts the waveform.

A segment in a sequence plays 
once, ignoring the repetition 
setting, after which the dual ARB 
player stops and waits for a 
trigger before advancing to the 
next segment. The next segment 
then plays to completion.  
 
If a trigger is received while a 
segment is playing, the segment 
plays to completion. The dual 
ARB player then advances to the 
next segment and plays that 
segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger.  
 
If a trigger is received while a segment is playing, the segment plays to completion. The 
dual ARB player then advances to the next segment and plays that segment continuously. 

For details on each key, use key help 
as described on page 34.
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• Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls 
segment–to–segment playing (see Example: Segment Advance Triggering on page 165). A trigger 
received during the last segment loops play to the first segment in the sequence.

• Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and 
stops playing the waveform in response to an externally applied gating signal. See Example: Gated 
Triggering on page 166.

Trigger Source

External Trigger Polarity
• In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the external 

trigger polarity.

• In Gated mode, the Active Low and Active High softkeys (page 163) determine the external 
trigger polarity. 

Mode > 
Dual ARB > 
Trigger Source

Patt Trig In BNC connector  
(see page 16)

Aux I/O connector  
(see page 17)

Neg = the signal generator 
responds during the trigger signal 
low state.

Pos = the signal generator 
responds during the trigger signal 
high state.

For details on each key, use key help 
as described on page 34.

Key inactive until Ext 
Delay is enabled On.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. 
This type of triggering ignores the repetition value (page 137). For example if a segment has 
repetition value of 50 and you select Single as the segment advance triggering mode, the segment still 
plays only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 136.

1. Preset the signal generator.

2. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.

c. Press Select Waveform.

4. Set the triggering as follows:

• Trigger Type: continuous Segment Advance 
Press Trigger Type > Segment Advance > Continuous.

• Trigger source: Trigger hardkey 
Press Trigger Source > Trigger Key.

5. Generate the waveform sequence:  
Press ARB Off On until On highlights.

6. (Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the 
oscilloscope so that you can see the signal.

7. Trigger the first waveform segment to begin playing continuously:  
Press the Trigger hardkey.

8. Trigger the second segment:  
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment 
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first 
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN 
connector, as shown in the following figure. This connection is applicable to all external triggering 
methods. The optional oscilloscope connection enables you to see the effect that the trigger signal 
has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.

c. Press Select Waveform.

5. Set the triggering as follows:

• Trigger type: Gated 
Press Trigger Type > Gated.

• Active state: Low 
Press Active Low.

• Trigger source: External 
Press Trigger Source > Ext.

• Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.
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7. On the function generator, configure a TTL signal for the external gating trigger.

8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external 
triggering signal. You will see the waveform modulating the output during the gate active periods 
(low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

Externally Applied Gating Signal 
Gate Active = Low
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal 
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel 
BNC connector

1. Connect the signal generator to the function generator as shown above.

2. Configure the RF output:

• Set the desired frequency.
• Set the desired amplitude.
• Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform:  
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single 
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external 
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive 
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms 
Press More > Ext Delay until On highlights 
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

• Waveform: 0.1 Hz square wave
• Output Level: 3.5V to 5V. 
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Clipping a Waveform
Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in 
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function 
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its 
highest peak, thereby reducing spectral regrowth.

• How Power Peaks Develop on page 170

• How Peaks Cause Spectral Regrowth on page 172

• How Clipping Reduces Peak–to–Average Power on page 173

• Configuring Circular Clipping on page 176

• Configuring Rectangular Clipping on page 177

Figure 8-8 Clipping Softkeys

Mode > Dual ARB > More 

Available only when  
clipping type = |I|, |Q|

For details on each key, use key help 
as described on page 34.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop 
as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit 
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an 
unusually high power peak (positive or negative) occurs in the summed waveform. 

Because the high and low states of the bits in channel waveforms are random and generally result in 
a cancelling effect, high power peaks occur infrequently with multiple channel summing.
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 Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform
Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude 

of the RF envelope is , where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms 
do not cancel each other, but combine to create an even greater peak.
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Basic Digital Operation (Option 653/655/656/657) 
Clipping a Waveform 
How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high 
peak–to–average power ratio, as illustrated in the following figure. 

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high 
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation 
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops 
on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see 
the following figure). Clipping provides a solution to this problem by reducing the peak–to–average 
power ratio.
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 Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform
How Clipping Reduces Peak–to–Average Power

You can reduce peak–to–average power, and consequently spectral regrowth, by clipping the 
waveform. Clipping limits waveform power peaks by clipping the I and Q data to a selected 
percentage of its highest peak. The Signal Generator provides two methods of clipping:

• Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 8- 9, the clipping level is constant for all phases of the vector and appears as 
a circle in the vector representation.

• Rectangular clipping is independently applied the I and Q data.

 As shown in Figure 8- 10 on page 174, the clipping level is different for I and Q, and appears as 
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces 
spectral regrowth but does not compromise the integrity of the signal. The two complementary 
cumulative distribution plots in Figure 8- 11 on page 175 show the reduction in peak–to–average 
power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is 
clipped). The peaks can often be clipped without substantially interfering with the rest of the 
waveform. In many cases, data that might otherwise be lost in the clipping process is retained 
because of the error correction inherent in the coded systems. If you apply excessive clipping, 
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that 
reduces spectral regrowth while retaining needed data.

Figure 8-9 Circular Clipping
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Basic Digital Operation (Option 653/655/656/657) 
Clipping a Waveform 
Figure 8-10 Rectangular Clipping
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 Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform
Figure 8-11 Reduction of Peak–to–Average Power
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Basic Digital Operation (Option 653/655/656/657) 
Clipping a Waveform 
Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak–to–average power 
ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally). 
For more information about circular clipping, refer to “How Clipping Reduces Peak–to–Average 
Power” on page 173.

CAUTION Clipping is non–reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_CIRC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate circular clipping: Press 
Return > Clipping > Clipping Type until 
|I+jQ| highlights.

6. Set circular clipping to 80%:  
Press Clip |I+jQ| To > 80 > %.

7. Apply 80% clipping to the I and Q 
data: Press Apply to Waveform.

8. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

9. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak–to–average power relative to the 
previous plot.

Example waveform curve before clipping 

Example waveform curve after circular clipping
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 Basic Digital Operation (Option 653/655/656/657)
Clipping a Waveform
Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data 
independently. For more information about rectangular clipping, refer to “How Clipping Reduces 
Peak–to–Average Power” on page 173.

CAUTION Clipping is non–reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_REC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate rectangular clipping: Press 
Return > Clipping > Clipping Type until 
|I|,|Q| highlights.

6. Set 80% clipping for the I data: Press 
Clip |I| To > 80 > %.

7. Set 40% clipping for the Q data: Press 
Clip |Q| To > 40 > %.

8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

10. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak–to–average power relative to the 
previous plot.

Example waveform curve before clipping 

Example waveform curve after rectangular clipping
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Basic Digital Operation (Option 653/655/656/657) 
Scaling a Waveform 
Scaling a Waveform
The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when 
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which 
may create a DAC over–range error condition. This chapter describes how DAC over–range errors 
occur and how you can use waveform scaling to eliminate these errors.

• How DAC Over–Range Errors Occur on page 179

• How Scaling Eliminates DAC Over–Range Errors on page 180

• Agilent MXG/EXG waveform scaling on page 181 and page 182:

— Waveform runtime scaling to scale a currently–playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a 
non–playing waveform file in BBG media

Figure 8-12 Scaling Softkeys

For details on each key, use key help 
as described on page 34.

The settings in this menu 
can be stored to the file 
header, see page 139.

Waveform Runtime Scaling, see page 181.

Waveform Scaling, see page 182.
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 Basic Digital Operation (Option 653/655/656/657)
Scaling a Waveform
How DAC Over–Range Errors Occur

The signal generator uses an interpolator 
filter when it converts digital I and Q 
baseband waveforms to analog 
waveforms. Because the clock rate of the 
interpolator is four times that of the 
baseband clock, the interpolator 
calculates sample points between the 
incoming baseband samples and smooths 
the waveform as shown in the figure at 
the right.

The interpolation filters in the DACs 
overshoot the baseband waveform. If a 
baseband waveform has a fast–rising 
edge, the interpolator filter’s overshoot 
becomes a component of the interpolated 
baseband waveform. This response 
causes a ripple or ringing effect at the 
peak of the rising edge. If this ripple 
overshoots the upper limit of the DAC 
range, the interpolator calculates 
erroneous sample points and is unable 
to replicate the true form of the ripple 
(see the figure at the right). As a result, 
the signal generator reports a DAC 
over–range error.
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Basic Digital Operation (Option 653/655/656/657) 
Scaling a Waveform 
How Scaling Eliminates DAC Over–Range Errors

Scaling reduces the amplitude of the baseband 
waveform while maintaining its basic shape and 
characteristics, such as peak–to–average power 
ratio. If the fast–rising baseband waveform is 
scaled enough to allow an adequate margin for 
the interpolator filter overshoot, the interpolator 
filter can calculate sample points that include 
the ripple effect and eliminate the over–range 
error (see the figure at the right).

Although scaling maintains the basic shape of 
the waveform, excessive scaling can compromise 
waveform integrity. For example, if the bit 
resolution becomes too low the waveform 
becomes corrupted with quantization noise. To 
achieve maximum accuracy and optimize 
dynamic range, scale the waveform no more 
than is required to remove the DAC over–range 
error. Optimum scaling varies with waveform 
content.
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 Basic Digital Operation (Option 653/655/656/657)
Scaling a Waveform
Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can 
apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB 
is on or off. This type of scaling is well suited for eliminating DAC over–range errors. Runtime scaling 
adjustments are not cumulative; the scaling value is applied to the original amplitude of the 
waveform file. There are two ways to save the runtime scaling setting: by using the save function 
(page 58) and by saving the setting to the file header (page 141). Saving to the file header saves the 
value with the waveform file, saving with the Save function stores the value as the current 
instrument setting.

Use this example to learn how to scale the currently selected waveform. 

1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.

3. Set the Waveform Runtime Scaling value: 

a. Press ARB Setup > Waveform Runtime Scaling. 

b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is no 
single value that is optimal for all waveforms. To achieve the maximum dynamic range, use 
the largest scaling value that does not result in a DAC over–range error. 

c. Press Return. 
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Basic Digital Operation (Option 653/655/656/657) 
Scaling a Waveform 
Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data 
and only applies to waveform segments stored in BBG media. You scale the waveform either up or 
down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method, 
you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that 
they conform to the desired scaling value. When you initiate scaling, the signal generator performs 
the following actions:

• locates the waveform file’s absolute peak sample value
• determines its current percentage of full scale
• calculates the ratio of the desired scale value to the determined absolute peak sample scale value
• multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs 
almost every time you reduce or increase the scaling value, and causes quantization errors. 
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. 
You lose data when either the signal generator rounds fractional data down or the scaling value is 
derived using the results from a power of two. This means that scaling a waveform in half (power of 
two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not 
correctable and may cause waveform distortion. It is always best to make a copy of the original file 
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the 
factory–supplied waveform RAMP_TEST_WFM, it is the same for any waveform file.

Copy a Waveform File
1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Peak sample

85% of full scale—Prescaling

60% of full scale–Post scaling

DAC full scale 100%

Scaled sample value = scaling ratio × prescale sample val

Scaling ratio = desired scale val / current scale val
                     = 60 / 85
                     = 0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

Original ramp waveform Scaled ramp waveform

= Samples
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 Basic Digital Operation (Option 653/655/656/657)
Scaling a Waveform
Apply Scaling to the Copied Waveform File

CAUTION This type of scaling is non–reversible. Any data lost in the scaling operation cannot be 
restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu: 

Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied): 

Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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Basic Digital Operation (Option 653/655/656/657) 
Setting the Baseband Frequency Offset 
Setting the Baseband Frequency Offset
The baseband frequency offset specifies a value to shift the baseband frequency up to ±50 MHz 
within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator 
option. While the following figure shows how to access the control using the Dual ARB player, the 
location of the Baseband Frequency Offset softkey within each ARB format, through the ARB Setup 
softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non–zero, the hardware rotator accumulates phase–shift of 
the baseband signal. This residual phase remains even after the offset value is returned to zero. To 
remove this phase accumulation, either restart the personality or select the Baseband Frequency Offset 
Phase Reset softkey. This softkey will grey out whenever the phase, due to the frequency offset, is 
zero. In addition, while there is a non–zero residual phase present in the signal, the DAC Over–Range 
Protection feature will automatically ensure that the reduced internal scaling is applied. This reduced 
scaling will be removed when both the frequency offset is returned to zero and the phase is reset. 

Figure 8-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Common uses for the offset feature include:

• offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
• sum the baseband signal with external I and Q inputs to create a multicarrier signal
• use the signal generator’s I/Q signal as an IF

page 229

Sets the Baseband 
Frequency Offset value 
entered in the signal to 
baseband.

Clears the phase 
accumulation and so zeros 
the phase shift. Causes a 
sudden phase shift 
discontinuity of the 
baseband signal.

The settings in this menu 
can be stored to the file 
header, see page 139.

For details on each key, use key help 
as described on page 34.

page 229

page 186

page 210

page 178

page 210
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 Basic Digital Operation (Option 653/655/656/657)
Setting the Baseband Frequency Offset
NOTE Changing the baseband frequency offset may cause a DAC over range condition that 
generates error 628, Baseband Generator DAC over range. The signal generator 
incorporates an automatic scaling feature to minimize this occurrence. For more information, 
see “DAC Over–Range Conditions and Scaling” on page 186.

The baseband frequency offset value is one of the file header parameters (page 139), which means 
you can store this value with the waveform. When you select a waveform with a stored frequency 
offset value, the signal generator changes the current value to match the stored file header value. If 
there is no stored baseband offset frequency value for the current waveform, the signal generator 
uses the last set frequency offset value. 

You can also use the Save function (page 58) to store this value as part of the signal generator setup. 
When you Recall a setup stored with the Save function, the baseband frequency offset value becomes 
the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the 
factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output for 
this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the 
following figures.
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Basic Digital Operation (Option 653/655/656/657) 
Setting the Baseband Frequency Offset 
DAC Over–Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a 
DAC over–range condition, which causes the Agilent MXG/EXG to generate an error. To minimize this 
condition with the frequency offset feature, the Agilent MXG/EXG incorporates an automatic DAC 
over–range protection feature that scales down the I/Q data by 1/square root of 2 when the offset is 
something other than zero. Because it can scale the data by more than what is actually need, it 
typically decreases the dynamic range of the waveform. This is especially noticeable when using a 
constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over–range feature can be turned off. When on, it is active 
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual 
ARB DAC over–range protection feature is located in the key path as shown in Figure 8- 14.

Modulated carrier with 0 Hz 
baseband frequency offset

Modulated carrier with 20 MHz 
baseband frequency offset Modulated RF signal

LO/carrier feedthrough

Spectrum analyzer set to a span of 100 MHz
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 Basic Digital Operation (Option 653/655/656/657)
Setting the Baseband Frequency Offset
Figure 8-14 Dual ARB DAC Over–Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over–range conditions.

For details on each key, use key help 
as described on page 34.

Default setting is On. Available only 
when Phase Noise or AWGN are on 
(see page 237), or when the 
baseband frequency offset is set to a 
value other than zero.
Turn off when you want to manually 
control scaling while using the 
baseband frequency offset feature. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
above.
Enables or disables the automatic 
internal scaling used to keep DAC 
over-range errors from occuring with 
the Phase Noise, AWGN and 
Frequency Offset features. This 
automatic scaling can be excessive 
(particularly for a constant amplitude 
signal) and thus reduce the dynamic 
range more than is necessary.
When the protection is disabled, no 
automatic scaling occurs, so the 
Runtime Scaling feature must be 
used to adjust for the highest scaling 
value that does not cause DAC 
overranges.
Since the over-range protection 
works with only three features, this 
key grays out until one of the three 
features is active even when the 
protection is on. 

When the DAC over–range protection is off, 
eliminate over–range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on page 181).

page 210
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Basic Digital Operation (Option 653/655/656/657) 
I/Q Modulation 
I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides 
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 48.
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 Basic Digital Operation (Option 653/655/656/657)
I/Q Modulation
Figure 8-15 I/Q Display and Softkeys

These selections are 
reflected in the  
I/Q Routing & 
Optimization graphic.page 192

This panel displays the current 
settings for the I/Q signal routing 
and I/Q correction optimized path.

This panel displays the current status and settings 
of the I/Q adjustments. Use the Page Up and 
Page Down keys to scroll through these 
parameters. Grey indicates an inactive (off) 
adjustment.

Used only with internally generated, bursted modulation 
formats. Enables/disables the RF burst modulator.

For details on each key, use key help 
as described on page 34.

Each path requires different optimization values; 
when you select a path, you are selecting the 
unique optimization values required by that path. 

The signal generator applies the selected 
optimization values to all paths, which impairs the 
unselected paths.

Inverts an internally generated Q signal, so that the I component lags the 
Q component by 90 degrees.

Opens the internal I/Q Equalization Filter which can be used 
to correct and/or impair the RF and External I/Q outputs for 
the internal I/Q source.
Selects between optimizing the internal I/Q channel for EVM (in channel 
performance) at the expense of ACP (out of channel performance) or 
optimizing for ACP at the expense of EVM.
EVM is an 80% nyquist filter (100Mhz wide) with a wide transition band. 
When an equalization filter is active, this filter is not active.
ACP is also an 80% nyquist filter (100Mhz wide), but the transition band 
is very narrow, thus reducing images for wide-band signals. This filter will 
be convolved with the active equalization filter and the Int Channel 
Correction filter (if it is on), the result of which will be truncated to the 
center 256 taps.
SCPI Commands:

[:SOURce]:DM:INTernal:CHANnel:OPTimization EVM|ACP

[:SOURce]:DM:INTernal:CHANnel:OPTimization?

Toggles on or off the application of the internal baseband generator RF, and baseband magnitude and 
phase corrections across the 160MHz baseband bandwidth at the current RF frequency.
When this feature is on, arbitrary frequency switching while the baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms the first time that frequency is specified. After that, switching to that 
frequency will take up to an additional 1.3ms.

Up to 1024 unique frequencies can be cached before the oldest cache will be forgotten. If a frequency 
sweep is activated, then the calculation and caching will occur up front for the first 1024 unique 
frequencies, and all further unique frequencies will have the characteristics of arbitrary frequency 
switching.

If the I/Q Correction Optimized Path is set to Ext I/Q Output, then only the baseband corrections will be 
applied and the frequency switching speed will be unaffected.
This correction will be convolved with the ACP Internal I/Q Channel Optimization filter and the 
Equalization filter if they are active. The resulting filter will be truncated to 256 taps.
SCPI Commands:

[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0

[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?

page 194
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Basic Digital Operation (Option 653/655/656/657) 
I/Q Modulation 
Using the Rear Panel I and Q Outputs

NOTE The rear panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and 
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in 
analog form. You can use these rear panel I and Q signals to:

• drive a system’s transmitter stage
• test individual analog I and Q components such as an I/Q modulator
• route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and 
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear 
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform
1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path
1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal 

generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the 
rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to another 
signal generator. The MXG/EXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press I/Q > I/Q Correction Optimized Path > Ext I/Q Output.

When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized

Rear panel I/Q path optimized
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 Basic Digital Operation (Option 653/655/656/657)
I/Q Modulation
Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front panel I 
Input and Q Input. You can use the external signals as the modulating source, or sum the external 
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front panel I Input.

b. Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Set the signal generator to recognize the front panel input signals: 

• To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

• To Sum and Modulate onto the Carrier

Press I/Q > I/Q Source > Sum.

To select and play a waveform for the BB GEN path, see page 133.

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear panel I and Q 
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator:  
Press I/Q Off On to On.

4. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

Signal generator display: both paths are calibrated 
when the I/Q Correction Optimized Path is set to 
Ext I/Q Output (see page 190)

Note: when the optimized path is set to RF, only the 
RF Out path is calibrated.

Signal generator display: both RF paths are calibrated 
when the I/Q Correction Optimized Path is set to 
RF Output (see page 190)
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Basic Digital Operation (Option 653/655/656/657) 
I/Q Adjustments 
I/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments

Available only when a 
waveform is playing.

Adjusts the I signal amplitude relative to the Q 
signal amplitude. Use this as an internal 
impairment, or to compensate for differences in 
signal path loss that occur due to path irregularities 
in the external I and Q output cabling.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The baseband quadrature 
adjustment key is calibrated in units 
of degrees. The external input 
quadrature adjustment is not 
calibrated. 
The function provided by this key is 
not the same as the function 
provided by the I/Q Skew key.

Skew is typically used either to create 
impairments, or to reduce error vectors on large 
bandwidth signals.
Provides a relative time delay correction between 
the I and Q signals. The different signal paths 
traveled by the I and Q signals result in time delay 
differences that show up as an EVM error in large 
bandwidth modulated signals. 

Adding an equal and opposite time delay (skew) in 
the I/Q signals during baseband generation 
eliminates the time delay error, correcting for any 
delays in signals that are generated in the internal 
baseband generator. 

Changes the absolute phase of 
both the I and Q signals with 
respect to triggers and markers. 
Positive values add delay and 
negative values advance the 
signals. This value affects both 
the baseband signal modulated 
onto the RF and the external 
output signals (I and Q). This 
setting cannot be used with 
constant envelope modulation 
and it does not affect external I 
and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range
This changes the adjustment range of the Common Mode I/Q Offset from Coarse (Default) to fine or vice versa. The Coarse 
range corresponds to the default value of ± 2.5V. The Fine range corresponds to a value of ± 100 mV.
Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.

Diff Mode I Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.

Diff Mode Q Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.

The DC offset values are calibrated relative to 
the RMS waveform voltage being played out of 
the ARB. See page 142.

The I/Q Attenuator softkey affects the I/Q signal to 
the RF Output and the External I/Q Outputs.

This softkey is active when the I/Q optimized path is 
set to Ext I/Q Output and a digital modulation 
personality is on. This attenuation is also adjustable 
using the Mod Attenuator key located in the Arb 
Setup menus in each personality. This adjustment is 
not affected by the I/Q Adjustments On/Off key. 

When Auto mode is selected, the signal generator 
automatically optimizes I/Q attenuation for the 
current conditions. When the Manual mode is 
selected, I/Q Attenuation is the active function. The 
value you enter sets the attenuation level of the I/Q 
signal.

SCPI Commands (Refer to the commands for each 
personality):
[:SOURce]:RADio:<personality>:IQ:MODul
ation:ATTen

This feature allows adjustment of the absolute phase of the internal I/Q channel by 
rotating both I and Q, thus adjusting the relative phase of the RF carrier. For option 
012, this is the only way to adjust the RF phase for a unit with an external LO.

Note: The I/Q signal will be 
scaled down by 0.7071 for all 
phase offsets except 0. Use 
-360 or +360, if it is desirable 
to maintain a constant power 
level with the ALC off while 
adjusting the I/Q phase.
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I/Q Adjustments
The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any 
latency between the EVENT output signals (marker signals) and the RF output.

Table 8-2 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q images I/Q path delay

I/Q Skew EVM error
high sample rate phase 
skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio

I/Q Phase I/Q phase rotation RF phase adjustment
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I/Q Calibration
Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected 
depends on whether the signal is internally or externally generated.

When you perform an I/Q calibration, that calibration data takes precedence over the 
factory–supplied calibration data. The calibration routines improve performance that may degrade 
over time or due to temperature changes. An I/Q calibration should be run when the ambient 
temperature has varied by at least ±5 degrees Celsius from the ambient temperature at which the 
previous calibration was run.

• The user I/Q calibration is persistent (i.e. Pressing instrument preset or cycling power does not 
remove the user I/Q calibration from memory).

• If the start and stop frequencies are set to the same value, then the calibration will be performed 
exactly at that frequency and the data will be persisted in the bounding calibration array 
elements.

Correction Internal I and Q External I and Q

Offset X X

Gain Balance X X

Quadrature Error X X
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I/Q Calibration
I/Q > I/Q Calibration

Available only when 
Calibration type = User

DC optimizes the I/Q performance for the current 
instrument settings, and typically completes in several 
seconds. Changing any instrument setting after performing 
a DC calibration voids the DC calibration and causes the 
signal generator to revert to the user calibration data (or 
factory-supplied calibration data, if no user calibration data 
exists)
User provides a quicker calibration when a full calibration 
is not required. You can limit the calibration by specifying 
the calibration start and stop frequencies. 
When you limit the calibration to less than the instrument’s 
full frequency range, the factory−supplied calibration data 
is used for the rest of the range. If the start and stop 
frequencies are set to the same value, then the calibration 
will be performed exactly at that frequency and the data will 
be persisted in the bounding calibration array elements. 
Information is retained through a preset or power cycle*.
Full takes approximately a minute, executing 
measurements over the instrument’s entire frequency 
range. 
Information is retained through a preset or power cycle*.

*Caution: 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved to 
non-volatile memory, the signal generator should always be 
powered down either via the Instrument’s front panel power 
button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down 
with the system rack power switch rather than the 
instrument’s front panel switch display an Error -310 due to 
the instrument not being powered down correctly.

Deletes any user–generated 
calibration data and restores 
the factory−supplied 
calibration data.

Note
A DC calibration requires the following settings:
• I/Q: On
• Optimized Path: RF Output
• Source: Internal

For details on each key, use key help 
as described on page 34.
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Using the Equalization Filter
An equalization FIR file can be created externally, uploaded via SCPI, and subsequently selected from 
the file system (refer to “Working with Files” on page 50). For information related to downloading 
FIR file coefficients, refer to the Programming Guide. For information regarding working with FIR 
file coefficients manually, refer to “Modifying a FIR Filter Using the FIR Table Editor” on page 204.

This filter can be used to correct and/or impair the RF and External I/Q outputs for the internal I/Q 
source. This filter will be convolved with the ACP Internal I/Q Channel Optimization filter if that 
filter is selected, the result of which will be truncated to the center 256 taps. The equalization filter 
operates at 200 MHz, so all equalization filters must be resampled to 200 MHz prior to selection, if 
they are sampled at some other rate.

The MXG/EXG supports equalization filters—either Complex or Real—that are programmable FIR 
filters with two inputs (I, Q) and two outputs (I, Q) per sample. This 256- tap filter has two modes of 
operation:

NOTE The maximum number of taps is 256 (with 2 coefficients per tap for a complex filter) for 
equalization filters. The minimum number of taps is 2.

Equalization filters can also be referred to as predistortion filters or correction filters.

The equalization filter can be turned on and off.

Type of 
Filter

Description

Real The I and Q samples are independently filtered by a single set of real coefficients.

Complex The samples are treated as complex (I + jQ) and convolved with the filter coefficients which 
are specified as (I + jQ) in the time domain. 
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Using the Equalization Filter
Figure 8-16 Int Equalization Filter Softkeys

I/Q > More
For details on each key, use key help 
as described on page 34.

SCPI commands:
Equalization filter state: 
[:SOURce]:DM:INTernal:EQUalization:FILTer:STATe { OFF } | ON 
[:SOURce]:DM:INTernal:EQUalization:FILTer:STATe? 

Equalization filter selection: 
[:SOURce]:DM:INTernal:EQUalization:FILTer:SELect "filename" 
[:SOURce]:DM:INTernal:EQUalization:FILTer:SELect? 

To add a real filter to the file system:
:MEMory:DATA:FIR "filename", [REAL,] osr, coeff1 [,coeff2 […, 
coeffN]]  
:MEMory:DATA:FIR? "filename" 

To add complex filter to the file system: 
:MEMory:DATA:FIR "filename", COMPlex, osr, hIRe0, hQIm0 [, hIRe1, 
hQIm1 […, hIReN, hQImN]]  
:MEMory:DATA:FIR? "filename"

To add I/Q symbol data to the file system: 
:MEMory:DATA “WFM1:filename", <blockdata>

page 199

Opens a file catalog of FIR filters to select as the equalization filter. Equalization filters are 
typically complex and must have an oversample ratio of 1. The filter must not have more than 
256 taps (512 coefficients for a complex filter). The equalization filter operates at 200 MHz, so 
all equalization filters must be resampled to 200 MHz prior to being placed in the signal 
generator.

Enables the internal 
equalization filter.

For more information on the SCPI commands, 
refer to the SCPI Command Reference.

page 189

Note:
Use the FIR Table editor to view the filter’s coefficients. 
Refer to page 204.
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation 
Filter
Finite Impulse Response filters can be used to compress single carrier I/Q waveforms down to just 
the I/Q constellation points and then define the transitions similar to the modulation filter in Arb 
Custom (refer to “Using Finite Impulse Response (FIR) Filters with Custom Modulation” on 
page 281). The key difference for dual ARB real- time modulation is that a filter is applied as the 
waveform plays, rather than in the waveform data itself. 

Figure 8-17      Filter Menu
Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >

This softkey changes, depending 

on the selected filter–type.

Available only when the filter selected =
Root Nyquist or Nyquist

Available only when the 
filter selected = Gaussian

page 204

page 199

For details on each key, use key help as described on page 34.

Opens the IS–95 
filter selection 
menu.

Enables or disables the Modulation Filter. This filter is typically applied to an Arb Waveform 
containing just the I/Q symbol decision points. The Modulation Filter then effectively 
defines the transitions between the symbol decision points. This means that the filter must 
have an oversample ratio of 2 or more. When this feature is active, the Sample Clock Rate 
is actually the Symbol Rate. Also, the filter must be real (refer to page 208).

page 196
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter
Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed 
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Select > Nyquist.

3. Press Define User FIR. 

4. Press More 1 of 2 > Delete All Rows > Confirm Delete of All Rows. 

This will initialize the table editor as shown in Figure 8- 18.

Figure 8-18 Creating a User–Defined FIR Filter Using the FIR Filter Table Editor

Entering the Coefficient Values

1. Press the Return softkey to get to the first page of the table editor. 

2. Use the cursor to highlight the Value field for coefficient 0. 

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define 
User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of All Rows

Opens a menu that 
enables you to select 
and load a saved file 
into volatile memory. 
See page 35.

page 205

Active only when:
FIR filter coefficient table 
has minimum of two 
values visible.

For details on each key, use key help as described on page 34.

Adds a column for 
specifying the imaginary 
coefficients of the filter.* 
(All of the imaginary 
coefficients will be 0 
initially.) If the Convert to 
Complex Filter softkey 
has been selected the 
Convert to Real Filter 
softkey becomes 
available. 
Caution: Selecting the 
Convert to Real Filter 
softkey removes the 
Imaginary Values column 
and the imaginary values 
are lost.

Note:
Modulation filters must be real and have an oversample ratio (OSR) of 2 or greater.
Equalization filers are typically complex and must have an oversample ratio (OSR) of 1.
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter 
3. Use the numeric keypad to type the first value (−0.000076) from Table 8- 3. As you press the 
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can 
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been 
entered.

Table 8-3

Coefficient Value Coefficient Value

0 −0.000076 8 −0.035667

1 −0.001747 9 −0.116753

2 −0.005144 10 −0.157348

3 −0.004424 11 −0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748

6 0.043940 14 0.767329

7 0.025852 15 0.972149
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter
Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in 
reverse order. The signal generator provides a mirror table function that automatically duplicates the 
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the 
first of these coefficients (number 16) highlights, as shown in Figure 8- 19 on page 201. 

Figure 8-19

FIR table coefficient 
values, may be from the 
factory default values or 
entered by the user.

Use the Goto Row 
menu to move around 
and make changes to 
the FIR Values 
coefficient table.For details on each key, use key help as described on page 34.
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Setting the Oversample Ratio

NOTE Modulation filters are real and have an oversample ratio (OSR) of two or greater.

Equalization filters are typically complex and must have an OSR of one (refer to “Using the 
Equalization Filter” on page 196 and to “Setting the Real- Time Modulation Filter” on 
page 208). 

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range 
from 1 through 32; the maximum number of taps allowed by the table editor is 1024. 

The actual limits on OSR, number of coefficients, and number of symbols depends on the feature 
with which the FIR is used. Refer to Table 8- 4.

For modulation filters, if the oversample ratio is different from the internal, optimally selected one, 
then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency 
dimensions.

1. Press More 1 of 2 > Display Filter > Display FFT (fast Fourier transform). 

Refer to Figure 8- 20 on page 203.

Table 8-4

Filter Type Oversampling Ratio 
(OSR)

Number of Taps
(Maximum)

Symbols/Coefficients 
(Maximum)

Equalizationa

aWhen I/Q timing skew, I/Q delay, or the ACP internal I/Q channel optimization features are active, the 
effective number of taps for the equalization filter are reduced.

1 256 - -

ARB Custom 

Modulationb

bThe filter may be sampled to a higher or lower OSR.

≥ 2 - - 512/1024

Dual ARB 
Real- Time 

Modulationc

cThe filter will be decimated to a 16 or lower OSR depending on the symbol rate.

≥ 2 - - 32/1024
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Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter
Figure 8-20

2. Press Return.

3. Press Display Impulse Response. 

Refer to Figure 8- 21.

Figure 8-21

4.  Press Return to return to the menu keys.

Storing the Filter to Memory

 Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory 
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 132, name and store 
this file as FIR_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional 
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The 
amount of memory used is also displayed. The number of files that can be saved depends on the size 
of the files and the amount of memory used. Refer to Figure 8- 22.

For details on each key, use key 
help as described on page 34.

For details on each key, use key 
help as described on page 34.
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Figure 8-22

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new 
filter design. 

Modifying a FIR Filter Using the FIR Table Editor
FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You 
can load the FIR table editor with coefficient values from user–defined FIR files stored in 
non–volatile memory or from one of the default FIR filters. Then you can modify the values and store 
the new files. 

Catalog displays FIR files that 
have been previously saved by 
the user.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 34.
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Modifying a FIR Filter Using the FIR Table Editor
Loading the Default Gaussian FIR File

Figure 8-23  Loading the Default Gaussian FIR File

1. Press Preset.

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define User FIR > More > Load 
Default FIR > Gaussian.

3. Press Filter BbT > 0.300 > Enter.

4. Press Filter Symbols > 8 > Enter.

5. Press Generate. 

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A 
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per 
symbol of the modulation type, and the number of symbols.

6. Press Display Filter > Display Impulse Response (refer to Figure 8- 24).

Mode > Dual ARB > Arb Setup > More > Real-Time 
Modulation Filter

These softkeys select a 
window function 
(apodization function) for 
a filter.

For details on each key, use key help as described on page 34.
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Modifying a FIR Filter Using the FIR Table Editor 
Figure 8-24

7. Press Return.

Modifying the Coefficients

1. Using the front panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 8-25

Refer to Figure 8- 25. The graphic display can provide a useful troubleshooting tool (in this case, 
it indicates that a coefficient value is missing, resulting in an improper Gaussian response).

4. Press Return.

5. Highlight coefficient 15. 

6. Press 1 > Enter. 

For details on each key, use key 
help as described on page 34.

For details on each key, use key 
help as described on page 34.
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Modifying a FIR Filter Using the FIR Table Editor
Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Return > Return > Load/Store > Store To File. 

2. Name the file NEWFIR2.

3. Press Enter. 

The contents of the current FIR table editor are stored to a file in non–volatile memory and the 
catalog of FIR files is updated to show the new file. 
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Setting the Real-Time Modulation Filter
The real- time modulation filter effectively compresses a single carrier I/Q waveform down to just the 
I/Q constellation points and then controls the transitions similar to the modulation filter in Arb 
Custom modulation. The key difference is that this filter is applied as the waveform plays, rather 
than in the waveform data itself. The real- time modulation filter is only available for Dual ARB 
waveforms.

When the real- time modulation filter is on, the sample clock rate acts as the symbol rate. The sample 
clock rate must be set to one half of the sample rate for the real- time Arb modulation filter feature 
to be turned on. The sample rate is determined by the Option 65x baseband generator.

CAUTION Because the Arb format only supports rectangular I/Q data for defining the symbol 
decision points, constant envelope modulation, which should be specified as magnitude 
and phase, are not supported. (Examples of constant envelope modulation are MSK and 
FSK.)

The carrier frequency must be the same for all frequencies used (i.e. only single carrier 
applications work with arb real- time modulation filters).

Figure 8-26 Real-Time Modulation Filter Softkeys for the Dual ARB Player

page 198

The settings in this menu 
can be stored to the file 
header, see page 139.

For details on each key, use key help 
as described on page 34.

Mode > Dual ARB > Arb 
Setup > More 

These are the available 
real-time modulation filters that 
can be applied to a waveform.
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Multiple Baseband Generator Synchronization
Common uses for the real- time modulation feature include:

• Where the single carrier rectangular ideal I/Q symbol decision points are known and are to have 
an over- sampled filter applied. 

• Where greater effective MXG/EXG memory size is required.
• When you have a low rate waveform that could benefit from a higher OSR that does not make the 

waveform longer.

The real- time modulation filter setup is one of the file header parameters (page 139), which means 
you can store this setup with the waveform. When you select a waveform with a stored modulation 
filter setup, the signal generator changes the current setup to match the stored file header setup. If 
there is no stored modulation filter setup for the current waveform, the signal generator uses the last 
set modulation filter setup. 

You can also use the Save function (page 58) to store this value as part of the signal generator setup. 
When you Recall a setup stored with the Save function, the modulation filter value becomes the 
current instrument setting value, disregarding the stored file header value.

Use the following steps to apply a real- time modulation filter to the current waveform loaded into 
volatile memory. This example uses the factory supplied waveform, SINE_TEST_WFM available in the 
Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal 
generator to the input of a spectrum analyzer.

NOTE The following setup assumes you have completed the setup in “Setting the Baseband 
Frequency Offset” on page 184 for creating a modulated RF signal that is offset from the 
carrier frequency by 20 MHz.

1. Configure the modulation filter:

Press Mode > Dual ARB > Arb setup > More > Real-Time Modulation Filter > Select > Root Nyquist

2. Press Filter Alpha > .4 > Enter.

The modulated RF signal now has a real- time modulation filter of type root nyquist, with a filter 
alpha of 0.400.

Multiple Baseband Generator Synchronization
Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen 
Agilent MXG/EXGs so that the baseband generators (BBG) synchronize the playing of waveforms. The 
system count includes one Agilent MXG/EXG to function as the master (see “Equipment Setup” on 
page 213).

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common 
external LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO In/Out 
for Phase Coherency) with Multiple Baseband Generator Synchronization” on page 216 and the Data 
Sheet.
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Multiple Baseband Generator Synchronization 
Figure 8-27 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger Softkeys and Menu Location

For details on each key, use key help 
as described on page 34.

Greys out for slave instruments. 
Remains active for the master 
instrument.

see page 211
BBG sync automatically changes the trigger type to Trigger and Run 
if the current setting is Free Run or Gated. If desired, manually set 
differently on either the master or slaves, or both either before or 
after configuring the BBG sync setup parameters.

Free Run and Gated are unavailable choices while using BBG sync.

Master default settings. If 
desired, change these 
settings after designating the 
instrument as the master

Slave default settings. These 
settings are not accessible 
after selecting an instrument 
as a slave.

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this 
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 211.

see page 132

see page 162

Neg is the factory default setting. 
The slave selection changes it to 
Pos. If desired, manually change to 
Pos prior to selecting as a slave.

Note: A setting conflict error occurs 
when at the time of the master/slave 
selection, the following trigger setting(s) 
is true:
Master
• Free Run or Gated trigger type
Slave
• Free Run or Gated trigger type
• Ext Polarity Neg trigger source
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Multiple Baseband Generator Synchronization
Figure 8-28 Multiple BBG Synchronization Front Panel Displays

For details on each key, use key help 
as described on page 34.

Master Display and Available Softkeys

Slave Display and Available Softkeys

Select Off, Master, or Slave

Synchronizes the baseband 
generators for all instruments in the 
system. 

Note: Press only after pressing 
Listen for Sync on all slave 
instruments and the slaves show 
“Waiting For Sync” as the status.Master shows one of the following messages:

• Out of Sync
• In Sync

Shows after pressing Sync Slaves

Master/slave indicator and setup 
diagram. 

After pressing, the slave waits for the 
synchronization signal initiated by 
the master.

Note: Press before pressing Sync 
Slaves on the master instrument.

Slave shows one of the following messages:
• Out of Sync
• Waiting for Sync

Shows after pressing Listen for Sync
• In Sync

Shows after pressing Sync Slaves on the master

Master/slave indicator and setup diagram. 
The bottom slave indicator is green on the 
last slave in the system.

Select Off, Master, or Slave

This is a persistent setting that 
survives both preset and cycling 
the power.

These are persistent settings that 
survive both preset and cycling the 
power.

Grayed–out on master, active for 
slaves.

Mode > Dual ARB > Arb Setup > More > 
Multi-BBG Sync Setup
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Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform 
generation capability of up to 16 signal generators to within a characteristic value of ± 8 ns between 
the master and the last slave. This minor amount of delay (± 8 ns) can be reduced further to 
picosecond resolution by using the I/Q Delay softkey located in the I/Q menu. To reduce the delay, 
check and adjust the BBG signal alignment for each signal generator in the system. For more 
information on adjusting the delay, see “I/Q Adjustments” on page 192.

The delay value includes compensation for cables that have less than 1 ns of propagation delay 
between the EVENT 1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is an 
Agilent BNC cable, part number 10502A. The use of cables with greater propagation delay may not 
allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one–time event pulse that 
propagates through and to each slave in the system. Prior to this event, each slave must recognize 
that it is waiting for this event pulse, which occurs during the system configuration (see “Configuring 
the Setup” on page 213). In order to properly send the synchronization pulse, the trigger source and 
the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does not incorporate a feedback system between the slaves and the signal 
generator selected as the master. After synchronization, if changes occur to the Multi–BBG Sync 
Setup menu or a signal generator is added to the system, the master does not automatically 
resynchronize the setup. This may cause the signal generators in the system to incorrectly report 
their status as In Sync. 

The system can also misinterpret other signals as the synchronization pulse, which results in an 
incorrect In Sync status. These types of signals include a continuous trigger or an active Marker 
routed to the EVENT 1 connector. Improperly connected rear panel cables can also create a false 
status.

You must resynchronize the entire system after making any change in one or all of the Multi–BBG 
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status of 
a signal generator. Changes to parameters that are outside of the Multi–BBG Sync Setup menu such 
as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have no effect 
on the system synchronization. To resynchronize a system, see “Making Changes to the Multiple 
Synchronization Setup and Resynchronizing the Master/Slave System” on page 215.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 210) for each 
signal generator. For signal generators selected as slaves, you can only modify the trigger type (with 
restrictions). The trigger source is fixed and set to receive a trigger through the rear panel PAT TRIG 
connector. On the master, you can change both the trigger type (with restrictions) and the trigger 
source. The trigger source provides three options for triggering the waveforms: external trigger, front 
panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature 
changes the trigger settings to what is shown on page 210. When this change occurs, the Agilent 
MXG/EXG generates a settings conflict error to alert you to the changes. To avoid the error 
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generation, appropriately configure the trigger settings prior to selecting a signal generator as the 
master or slave.

The system trigger propagates in the same manner as the synchronization pulse initiated by the 
master (see System Synchronization). So if it is not turned off during changes to the synchronization 
parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization 
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger 
type to Free Run or provide a trigger to start the waveform play back.

Equipment Setup

Figure 8-29 Multiple Baseband Synchronization Setup

Configuring the Setup

Set the Common Parameters

Perform the following steps on all signal generators:

1. Set the frequency of the carrier signal.

2. Set the power level of the carrier signal.

3. Select the desired waveform (see page 132).

Do not turn the Dual ARB on.

There can be 1 to 15 
slaves in a setup. 

If not using the Trigger key, provide an external trigger 
source. For information on the PAT TRIG connector, 
see page 16.

PAT TRIG

PAT TRIG

PAT TRIG

10MHz Out

REF IN

10MHz Out

REF IN

REF IN

10MHz Out

EVENT 1

EVENT 1

EVENT 1

RF OUTPUT

RF OUTPUT

RF OUTPUT

RF OUTPUT

Note: To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended 
cable for the rear panel daisy chain connections (see page 212).

PAT TRIG 
or GPIB
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4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the master and slaves. 
If the current trigger settings include unsupported BBG synchronization parameters, the Agilent 
MXG/EXG generates a settings conflict error and changes the trigger settings. To avoid the 
settings conflict error, manually set the trigger parameters as shown on page 210 prior to setting 
the multiple BBG synchronization parameters.

5. Turn on the RF Output.

Set the BBG Synchronization Master Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–Bbg Sync Type > Master.

2. Set the number of slaves using the Number of Slaves softkey.

3. If desired, modify the trigger parameters (see page 210).

The master signal generator allows the modifications of both the trigger type and the trigger 
source.

a. Return to the Dual ARB menu (see page 210).

b. Set the desired trigger type and source.

c. Return to the Multi–BBG Sync Setup menu.

Set the BBG Synchronization Slave Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–BBG Sync Type > Slave.

2. Set the number of Slaves using the Number of Slaves softkey.

3. Set the slave position that the signal generator occupies.

There can be up to fifteen slaves in a system.

4. Press the Listen for Sync softkey and verify that Waiting for Sync appears in the Status area of 
the display.

5. If desired, select a different trigger type parameter:

a. Return to the Dual ARB menu (see page 210).

b. Set the desired trigger type.

c. Return to the Multi–BBG Sync Setup menu.

6. Repeat for each slave signal generator in the system.

Synchronize the System

Perform this procedure only after setting the parameters for both the master and slave signal 
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple 
Synchronization Setup and Resynchronizing the Master/Slave System” on page 215.
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1. On the master, press the Sync Slaves softkey.

NOTE All of the signal generators in the master/slave system must be resynchronized when any 
changes are made to the master/slave settings or with the addition of a slave instrument, 
even if In Sync appears after pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the Status.

Trigger and Play the Waveform
1. On all Agilent signal generators, press Mode > Dual ARB > ARB Off On to On.

2. Start the trigger signal going to the master signal generator.

Making Changes to the Multiple Synchronization Setup and Resynchronizing the Master/Slave 
System

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added to 
the system, the system must be resynchronized even if In Sync appears in the Status portion of the 
display. 

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal 
generators to incorrectly display In Sync as the status after pressing the Listen for Sync softkey. 

2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the 
chain may incorrectly display In Sync after pressing the Listen for Sync softkey.

3. On each of the signal generators, press ARB Setup > More > Multi–BBG Sync Setup.

4. Make the changes in the Multi–BBG Sync Setup menu.

Out Of Sync appears as the status message.

5. On each of the slave signal generators, press Listen for Sync.

6. Ensure that all of the slaves’ Status show Waiting for Sync. If In Sync shows as the status, 
perform the following steps:

a. Check that the PATT TRIG to EVENT 1 cables are properly connected on the rear panel.

A disconnected cable can cause a false In Sync status.

b. If the cables are connected, perform steps 1 and 2.

c. Press Listen for Sync and ensure that Waiting for Sync appears as the status.

7. On the master signal generator, press Sync Slaves.

8. Verify that In Sync appears as the status on all master/slave signal generators.

9. Perform the process “Trigger and Play the Waveform” on page 215.
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Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple 
Baseband Generator Synchronization

NOTE This section assumes that the previous section on Multiple Baseband Generator 
Synchronization has been read and understood. If not, refer to “Multiple Baseband Generator 
Synchronization” on page 209 before continuing.

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common 
external LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator 
Synchronization” on page 209).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO receiver 
perceives any phase differences between the sources as part of the channel conditions and correct for 
them. But, RF phase coherency might be desirable for certain applications such as R&D on 
beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Agilent BNC cable, part number 10502A, is the recommended cable for the standard multi–BBG 
synchronization setup, and is recommended for Option 012 too (see also Figure 8- 29 on page 213). 
Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to the splitter, 
additional cables are required (refer to Table 8- 5, Figure 8- 30 on page 218, and Figure 8- 31 on 
page 219).

NOTE Agilent recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual ARB mode, the 
instrument is unleveled and the instrument displays an Unlevel error message.

All test equipment requires a 12 hour warm–up period to ensure accurate performance.

The phase coherent configuration requires the following:

• The recommended LO input drive level should be in the 0 to 6 dBm range.

NOTE The 0 to 6 dBm LO input drive level ensures the instruments will operate over the full 
frequency and over the full 0 to 55 ambient temperature range1.

• The I/Q calibration and the self–test must be performed with the LO In/Out jumper cable in 
place. Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted to 
minimize the I/Q offsets.

• The phase coherency feature only applies to the Dual ARB modulation mode.

• All cables from the splitter output to the instrument inputs should be of equal lengths.

1LO input power requirements vary with temperature; power <0 dBm may work at 20–30 degree ambient 
temperature conditions. Refer to the Data Sheet.
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Table 8-5 Option 012 (LO In/Out for Phase Coherency) Equipment

MIMO Configuration Parta

aOn all of the MIMO configurations, the same length of SMA flexible cables are connected from the splitter 
output to the inputs on the master and slave instruments. Refer to Figure 8-30 on page 218 and to Figure 8-31 on 
page 219.

Cable Length Notes

2x2 n/a

11636A

As required

n/a

SMA flexible cables are connected from 
the power splitter outputs to the LO 
inputs on the rear panel of both the 
master and the slave MXG/EXGs. Refer 
to Figure 8- 30 on page 218. 
 
Power Divider, DC to 18 GHz. Refer to 
www.agilent.com.

3x3 n/a

 

PS3–20–451/12
S

As required

 

n/a

SMA flexible cables are connected from 
the power splitter outputs to the LO 
inputs on the rear panel of the slave 
MXG/EXGs. Refer to Figure 8- 31 on 
page 219. 
 
3–Way Pulser Microwave Corp., 3–Way 
Wilkinson Dividers

4x4 n/a

 

PS4–16–452/10
S

As required

 

n/a

The SMA flexible cables are connected 
to the power splitter output to the LO 
inputs on the rear panel of the slave 
MXG/EXGs. Refer to Figure 8- 31 on 
page 219. 
 
4–Way Pulser Microwave Corp., 4–Way 
Wilkinson Dividers

All 10502A 22.86 cm (9 inches) Refer to Figure 8- 30 on page 218 and 
Figure 8- 31 on page 219. See also 
“Multiple Baseband Generator 
Synchronization” on page 209.
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2x2 MIMO (LO In/Out for Phase Coherency) Configuration 

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the master MXG/EXG can be 
run through a power splitter and used as the LO input to both the master and the slave signal 
generators. No external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the master MXG LO OUT is 
connected via a power splitter to the slave LO IN. The LO OUT provides a sufficient amplitude LO 
signal when connected directly, to drive the Slave MXG/EXG(s), thus providing phase coherency for 
the RF output signals. In this example, we show two MXG signal generators with Option 012 
connected for a phase coherent 2x2 MIMO solution. Refer to Figure 8- 30.

Figure 8-30 2x2 MIMO (LO In/Out for Phase Coherency) Equipment Setup

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is 
needed to provide the higher LO power required by the power splitter and the additional 
instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5172B/82Bs in 
the system. Also, there is no amplitude adjustment to the LO output of the N5172B/82B. To generate 
phase coherent signals for 3x3 and 4x4 configurations with the MXG/EXG, an external Master LO is 
needed to provide a sufficient amplitude LO input signal to the vector MXG/EXGs (refer to Figure 
8- 31 on page 219). 

NOTE The Master LO is not controlled by any of the Signal Studio software, but must be set 
manually—via the RF frequency settings on the master signal generator—by the user to the 
desired frequency and amplitude.

Note: 
To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 2–way splitter 
connections to the LO IN of the signal generator with Option 012 (see page 216). 

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain 
connections on the EVENT 1 and PAT TRIG BNC connectors (see page 216).
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Figure 8-31 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup

Note: 
A SMA flexible cable is recommended for the input to the 4–way splitter connections to the LO IN and LO OUT of the instruments 
with Option 012 (see page 216).

To optimize the phase coherence, the same length SMA flexible cable is recommended for the output of the 4–way splitter 
connections to the LO IN of the instruments with Option 012 (see page 216).

To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended cable for the rear panel daisy chain 
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Real-Time Applications
The Agilent X- Series signal generators provide access to several real- time applications for signal 
creation. 

Figure 8-32  Real-Time Applications Softkeys

page 130

For details on each key, use key help as described on page 34.

page 297

page 244

page 244

Licensed Signal Studio applications are displayed here.

Refer to www.agilent.com/find/signalstudio.

page 235

page 238

page 162
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Waveform Licensing 
Waveform licensing enables you to license waveforms that you generate and download from any 
Signal Studio application for unlimited playback in a signal generator. Each licensing option (221- 229) 
allows you to permanently license up to five waveforms or (250- 259) allows you to permanently 
license up to 50 waveforms of your choice (i.e. Waveform Option 22x or Option 25x are perpetual 
fixed waveform licenses). 

Waveforms licensed with Options 221- 229 or Options 250- 259 cannot be exchanged for different 
waveforms. Once a waveform is licensed, that license is permanent and cannot be revoked or 
replaced. Option 22x and 25x waveform licenses are signal generator specific (i.e. signal generator 
serial number specific). If a licensed Option 22x or Option 25x waveform file is transferred to 
another signal generator, the file must be licensed by a separate Option 22x or Option 25x that is in 
the other signal generator before it can be played.

To redeem Option 22x or Option 25x, refer to the N5182B–2xx Entitlement Certificate that comes 
with the N5182B–2xx order. For more information on extracting and downloading waveform files, 
refer to the Programming Guide.

Understanding Waveform Licensing

Use any N76xxB Signal Studio software to build and download waveforms to the signal generator. 
Each Option 22x provides 5 available slots and Option 25x license provides 50 available slots, where 
you can add and play waveforms for a trial period of 48 hours per slot. During this time, you can 
replace the waveform any number of times until you are satisfied with it. After the trial period 
expires, the waveform in the slot is no longer playable until the slot is locked for permanent 
playback; however, you can replace the waveform in the slot with another waveform of your choice 
before locking the slot.

To license additional waveforms that exceed the number permitted by an Option 22x or Option 25x, 
you must purchase another Option 22x or Option 25x that you do not already own. For example, if 
you already own Option 250, purchase Option 251 to add an additional 50 slots. Adding all options, 
250- 259, provides a maximum of 500 slots. Adding all options, 221- 229, provides a maximum of 45 
slots. (Repurchasing the same option for the same signal generator, gives you no additional Waveform 
licenses.) 

Installing an Option N5182-22x or Option N5182B–25x 

Load a Waveform License, Option N5182- 22x or Option N5182B–25x, into the signal generator using 
License Manager or a USB media. For more information on loading the Waveform License, refer to 
the N5182B–2xx Entitlement Certificate included with your order.

Licensing a Signal Generator Waveform

Create and download a waveform into the signal generator using any of the N76xxB Signal Studio 
software. Refer to your Signal Studio software help if you need assistance using the application.

Refer to page 226 for steps in adding the waveform to a license slot for a 48- hour trial period. 
During the trial period, the waveform can be played and replaced any number of times. When the 
trial time expires, the slot can no longer be used for playback until the slot is locked for permanent 
playback capability.
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Waveform Licensing Softkeys Overview

Figure 8-33 Waveform Licensing Softkeys

For details on each key, use key help 
as described on page 34.

Mode > Dual ARB > More 

Note: Waveforms licensed with Option 2xx cannot be exchanged for other waveforms. 
Once a waveform is locked into a license slot, that license is permanent and cannot be 
revoked or replaced. 

This softkey is only available if there is an Option 2xx license installed on the instrument.
Pressing this softkey displays the licensing status and associated filename for each slot and 
accesses the waveform licensing menu selections. 

This softkey allows you to add 
a waveform that you select to 
the first available slot. Refer 
to page 223.

Refer to the SCPI Command Reference 
for related license commands.

This softkey allows you to 
replace a waveform in the 
selected slot. Refer to 
page 224.
This softkey clears the 
waveform from the selected 
slot.

This softkey allows you to 
lock a waveform into a slot. 
After the trial period has 
expired, the waveform must 
be locked in order to be able 
to play the waveform. Refer 
to page 224.

This softkey allows you to 
select a specific slot where 
you want to add, replace, or 
clear a waveform. You can 
also select a slot by using 
the front panel arrow keys or 
by scrolling to the slot. Refer 
to page 223.

 
Note: When Waveform Licensing is first accessed, all slots appear as 
Available. For licensing status descriptions after waveforms have been 
added to a slot, refer to Table 8-6 on page 225.

page 224
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Figure 8-34 Waveform Licensing Softkeys

For details on each key, use key help as described on page 34.

Mode > Dual ARB > More > 
Waveform Licensing > Add 
Waveform to First Available Slot
or
Mode > Dual ARB > More > 
Waveform Licensing > Replace 
Waveform in Slot

The softkey is greyed out, if a 
waveform is already licensed or 
does not require licensing.

This softkey displays a 
catalog of the waveform 
segments stored in the Int 
Storage or USB Media.

This softkey displays a 
catalog of the waveforms 
stored in the BBG 
memory.

To select a waveform, 
use the arrow keys to 
highlight the waveform 
and then press Add 
Waveform. 

Note: Waveforms licensed with Option 2xx cannot be “exchanged”. Once 
a slot is locked, that license for the waveform in the locked slot is 
permanent and cannot be revoked or replaced.

Refer to the SCPI Command 
Reference for related License 
Commands.The waveform to be added or replaced can be selected from BBG memory, internal storage, or a 

USB device.
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Figure 8-35 Waveform Licensing Softkeys

For details on each key, 
use key help as described 
on page 34.

Mode > Dual ARB > More > 
Waveform Licensing > Goto Slot

Press this softkey after entering a specific slot number using the front panel 
numeric pad.

Press this softkey to go to the first slot.

Press this softkey to go to the first slot whose status is available.

Press this softkey to go to the last slot. The number of slots depends on the number of 
licensing options installed on the instrument.

Mode > Dual ARB > More > Waveform Licensing 
> Lock Waveform in Slot

This softkey is displayed if the waveform is not found in the internal storage 
memory of the signal generator. Press this softkey to store the waveform into the 
Internal Storage and to activate the Confirm Locking Waveform softkey. Refer to 
Step 4 on page 227. 

Mode > Dual ARB > More > Waveform 
Licensing > More > More

Press this softkey to play 
the waveform in the 
highlighted slot.

Press this softkey to 
locate the waveform in 
memory that was added 
to this slot regardless of 
the name. If the search 
returms no results, the 
original waveform has 
been deleted from 
memory and cannot be 
found.

Press this softkey to confirm that you want to lock the waveform into the slot for 
permanent licensing. If the waveform has not been saved to internal storage, a 
warning message appears. Refer to Step 4 on page 227. 

Refer to the SCPI Command Reference 
for related license commands.
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Table 8-6 Waveform Licensing Slot Status Messages

Status Column Meaning Notes

Available The slot has never had a waveform 
added to it.

50 slots are initially available for 
each Option 25x.

5 slots are initially available for 
each Option 22x.

Locked MM/DD/YY The slot is locked and can no 
longer be modified.

The waveform in this slot is 
licensed to this signal generator 
for unlimited playback.

Remaining Trial Time HH:MM The slot is in a trial period that is 
available for 48 hours that begins 
when a waveform is added.

During the trial period, the 
waveform in this slot can be 
played, cleared, or replaced with 
another waveform.

Lock Required The trial period for the slot has 
expired but the slot has not been 
locked. 

The slot can be cleared or 
replaced with a different waveform 
but the waveform cannot be played 
until the slot is locked. A trial 
period is no longer available.
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Example: Licensing a Signal Studio Waveform

The following steps add a waveform file to a license slot and lock the slot for permanent playback.

1. Press Mode > Dual ARB > More > Waveform Utilities > Waveform Licensing

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in BBG 
Memory.

2. Use the arrow keys to highlight and select the file to be licensed.

3. Press Add Waveform to add the selected waveform to the first available slot.

Figure 8-36      Add Waveform
Mode > Dual ARB > More > Waveform Licensing> 
Add Waveform to First Available Slot

page 223

Status area for the 
waveform N7602B–WFM1 is 
empty and the Add 
Waveform softkey is active, 
indicating the waveform is 
licensable.

The selected 
waveform is added to 
the first available slot. 
The trial time for the 
slot begins as soon as 
the waveform is 
added.
During the 48 hour 
trial period, the 
waveform can be 
played and replaced 
any number of times.
When the trial time 
expires, the licensing 
status of the slot 
changes to Lock 
Required after which 
the waveform can no 
longer be played until 
the slot is locked.
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4. License the waveform:

a. Press Lock Waveform in Slot.

A warning is displayed: *** Waveform Lock Warning!!! ***. If necessary, verify you have 
selected the correct waveform you want for licensing by pressing Return.

Figure 8-37 Waveform Lock Warning

b. Press Confirm Locking Waveform.

The licensing status of the slot will be changed to Locked MM/DD/YY.

c. If the waveform has not been previously backed up in internal storage, a warning is displayed: 
*** Waveform Backup Required!!! ***.

d. Make a backup copy of this waveform on a USB media or a computer before pressing Backup 
Waveform to Int Storage. (If the waveform is lost or deleted on the signal generator, it cannot be 
recovered).

Figure 8-38 Backup Waveform To Int Storage softkey

CAUTION It is important that you make a backup copy of any waveforms that you are licensing. 
Do not store the backup copy on the signal generator. If all copies of the waveforms 
are deleted or lost, there is no way to recover the waveform or reassign the license. 
Refer to “Working with Files” on page 50.

Press this softkey to store 
the waveform into the internal 
storage and to activate the Confirm 
Locking Waveform softkey.

The Confirm Locking 
Waveform softkey remains 
inactive until the waveform is 
stored in internal storage.
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Waveform Licensing Warning Messages

Figure 8-39
This standard warning is 
displayed every time a 
waveform is selected to be 
locked. This notification 
indicates that one of the 
available “license slots” is 
about to be used from 
Option 2xx.
ALWAYS make 
backup copies of 
waveforms in a 
separate 
non–volatile memory 
in case a file is 
deleted or lost from 
the instrument’s 
internal storage.

This warning is displayed 
when an attempt is made 
to lock a waveform that 
has not been saved to 
internal storage or USB 
media (i.e. waveforms 
cannot be locked unless 
they have been stored to 
non–volatile memory). 
Press the Backup 
Waveform To Int Storage 
softkey.

This warning is displayed 
when there is insufficient 
memory or other problems 
with the internal storage, 
or USB media 
(non–volatile memory) and 
the waveform could not be 
saved to non–volatile 
memory.

This warning is displayed 
when the waveform file 
cannot be found in BBG or 
internal storage. You must 
ensure that the waveform 
still resides in the 
instrument before you can 
lock it.
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9 Adding Real–Time Noise to a Signal (Option 403)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

This feature is available only in Agilent X- Series vector signal generators with Option 431. Option 431 
requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform 
generator, which is available only in vector signal generators with Option 403.

• Adding Real–Time Noise to a Dual ARB Waveform on page 229

• Using Real Time I/Q Baseband AWGN on page 235

Adding Real–Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real–Time Noise (AWGN) to 
a waveform, are applicable to the Custom ARB, Multitone, and Two–Tone modulation 
standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN) 
to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. This 
feature appears in each of the arb formats and as a stand–alone menu (Refer to Figure 9- 7 on 
page 235).
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Adding Real–Time Noise to a Signal (Option 403) 
Adding Real–Time Noise to a Dual ARB Waveform 
Figure 9-1 Real Time I/Q Baseband AWGN Softkeys

see page 231

For details on each key, use key help 
as described on page 34.

The state of the noise (on or off) 
is shown on the display.

Figure 9-6 on page 234 
provides additional 
details on these settings.

This is the stand–alone 
Real–Time AWGN and the 2nd 
page of the Modulation Mode 
menu (see page 235).

Static graphic representation of 
ARB Real–Noise AWGN (i.e. 
graphic does not update as 
values change).

The relationship of the values are displayed in the 
static graphic of ARB Real–Time AWGN.
The Total Noise Power is the Noise Power over the 
occupied noise bandwidth (NBW * 1.25). 

see page 231

see page 231

For the selected carrier to noise ratio, 
the bandwidth over which the noise is 
integrated. Typically, Carrier 
Bandwidth (CBW) is the occupied 
bandwidth of the carrier.

Flat Noise Bandwidth (NBW): The 
actual flat noise bandwidth (NBW), 
which should be slightly wider than 
the carrier bandwidth (typically 1.6 
times wider). The occupied 
bandwidth is =  
(1.25 * the Flat Noise Bandwidth)

see page 232

The Carrier Bit Rate softkey sets the 
carrier bit rate. (The default carrier bit 
rate is 1 bps.)

The Carrier Bit Rate softkey is only 
available when the Carrier to Noise 
Ratio Format Softkey is set to Eb/No. 
See also page 233.
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 Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform
Figure 9-2 Real Time I/Q Baseband AWGN - Power Control Mode Softkeys
For details on each key, use key help 
as described on page 34.Mode > Dual ARB > Arb Setup >

Real-Time AWGN Setup

Selecting Total as the power 
control mode makes the total 
power and C/N independent 
variables while making the 
carrier power and total noise 
power dependent variables. The 
dependent variables carrier 
power and total noise power are 
set by the total power, C/N, and 
the rest of the Noise settings. 
The carrier power and total 
noise power change as any 
noise parameter is adjusted to 
keep the total power and the 
C/N at their last specified 
values.

Selecting Carrier as the power 
control mode makes the carrier 
power and C/N independent 
variables while making the total 
power and total noise power 
dependent variables. The 
dependent variables total power 
and total noise power are set by 
the carrier power, C/N, and the 
rest of the Noise settings. The 
total power and total noise 
power change as any noise 
parameter is adjusted to keep 
the carrier power and the C/N at 
their last specified values.

Selecting Total Noise as the 
power control mode makes the 
total noise power and C/N 
independent variables while 
making the total power and 
carrier power dependent 
variables. The dependent 
variables total power and carrier 
power are set by the total noise 
power, C/N, and the rest of the 
Noise settings. The total power 
and carrier power change as 
any noise parameter is adjusted 
to keep the total noise power 
and the C/N at their last 
specified values.

Figure 9-6 on page 234 
provides additional 
details on these settings.

see page 232
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Adding Real–Time Noise to a Dual ARB Waveform 
Figure 9-3 Real Time I/Q Baseband AWGN - Noise Mux Menu Softkeys

Eb/No Adjustment Softkeys for Real Time I/Q Baseband AWGN

This feature allows the AWGN C/N to be set using the Eb/No (energy per bit over noise power density 
at the receiver or signal to noise ratio per bit) form. This requires the carrier bit rate to be known. 
Refer to Figure 9- 4, “Eb/No Carrier Bit Equation.”

Figure 9-4 Eb/No Carrier Bit Equation

For details on each key, use key help 
as described on page 34.

Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup > More

Enables diagnostic control of 
additive noise, so that only the 
noise, only the carrier, or the 
sum of both the noise and the 
carrier are output from the 
internal baseband generator. 
With the ALC off, this feature 
enables direct measurement of 
the carrier or the noise 
contributions independently 
from the total power. The system 
still behaves as if both the noise 
and the carrier are present on 
the output when it comes to 
determining the Auto Modulation 
Attenuation and the RMS level 
for RMS Power Search.

Figure 9-6 on page 234 
provides additional 
details on these settings.

The Carrier Bit 
Rate softkey is 
only available 
when the Carrier 
to Noise softkey 
is set to Eb/No.

C
N Bd
-----------

Eb
N0
-------⎠

⎞ dB 10 10
bitRate

carrierBandwidth
------------------------------------------------⎠

⎞
⎝ ⎠
⎛ ⎞log+⎝ ⎠

⎛ ⎞=
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 Adding Real–Time Noise to a Signal (Option 403)
Adding Real–Time Noise to a Dual ARB Waveform
Figure 9-5 Real Time I/Q Baseband AWGN - Eb/N0 Adjustment Softkeys

For details on each key, use key help 
as described on page 34.

Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup

Selects either the Carrier to 
Noise Ratio (C/N) or energy per 
bit over noise power density at 
the receiver (Eb/No) as the 
variable controlling the ratio of 
the carrier power to noise power 
in the carrier bandwidth. When 
Eb/No is selected, the second 
page of the AWGN Setup menu 
shows the Carrier Bit Rate 
softkey to enable the Eb/No 
value to be calculated.

Figure 9-6 on page 234 
provides additional 
details on these settings.

C/N selected

Eb/No selected

Whether a softkey is available 
depends on the Carrier to 
Noise Ratio Format softkey 
setting (e.g. C/N or Eb/No). 

The Carrier Bit Rate softkey sets the 
carrier bit rate. (The default carrier bit 
rate is 1 bps.)

The Carrier Bit Rate softkey is only 
available when the Carrier to Noise 
Ratio Format Softkey is set to Eb/No.

To view the carrier bit rate equation, 
refer to page 34.

Eb/No is displayed when Carrier to Noise Ratio 
Format softkey is set to Eb/No.

The active 
softkey changes 
with the Carrier to 
Noise Ratio 
Format selected 
(C/N or Eb/No). 
See below.

Display remains grayed out until 
real-time AWGN is enabled.
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Adding Real–Time Noise to a Dual ARB Waveform 
Figure 9-6 Carrier to Noise Ratio Components

Example

Use the following steps to modulate a 1 GHz, –10 dBm carrier with the factory–supplied waveform 
SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB 
carrier–to–noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:

• Frequency: 1 GHz
• Amplitude: −10 dBm
• RF output: on

2. Select the factory–supplied waveform SINE_TEST_WFM:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SINE_TEST_WFM and press Select Waveform.

3. Turn on the dual ARB player: press ARB Off On to highlight On.

4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.

5. Press Real–Time AWGN Setup and set the following:

• Carrier to Noise Ratio: 30 dB
• Carrier Bandwidth: 40 MHz
• Noise Bandwidth: 45 MHz
• Real–time AWGN: on

The signal generator’s displayed power level (–10 dBm) includes the noise power.

Carrier BW 
    (CBW)

RMS  
(total carrier power)

C

Carrier BW 
     (CBW)

Carrier

Noise N

Noise BW 
(NBW) = 
flat noise 
bandwidth

The carrier now appears 
larger because of the 
added noise power.

Carrier Bandwidth (CBW) is typically the 
occupied bandwidth of the carrier and the Noise 
Bandwidth is the flat noise bandwidth (NBW).
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 Adding Real–Time Noise to a Signal (Option 403)
Using Real Time I/Q Baseband AWGN
Using Real Time I/Q Baseband AWGN

Figure 9-7 Real Time I/Q Baseband AWGN Softkeys

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, –10 dBm carrier.

1. Configure the noise:

a. Preset the signal generator.

b. Press Mode > More > Real-Time AWGN

c. Press Bandwidth > 10 > MHz.

2. Generate the noise:

Press Real-Time AWGN Off On until On highlights.

During generation, the AWGN and I/Q 
annunciators activate (as shown at 
right). AWGN is now available to 
modulate the RF carrier.

3. Configure the RF output:

• Frequency: 500 MHz

• Amplitude: −10 dBm

• RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.

For details on each key, use key help 
as described on page 34.
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Using Real Time I/Q Baseband AWGN 
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10 Real–Time Phase Noise Impairments (Option 432)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

This feature is available only in Agilent X- Series vector signal generators with Option 431. Option 431 
requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and 
information on the use of this feature.

• Real–Time Phase Noise Impairment on page 238

• The Agilent X- Series Phase Noise Shape and Additive Phase Noise Impairments on page 239

• Understanding the Phase Noise Adjustments on page 241

• DAC Over–Range Conditions and Scaling on page 242
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Real–Time Phase Noise Impairments (Option 432) 
Real–Time Phase Noise Impairment 
Real–Time Phase Noise Impairment
This feature lets you degrade the phase noise performance of the signal generator by controlling two 
frequency points and an amplitude value. The signal generator adds this phase noise to the phase 
noise normally produced by the signal generator. This feature appears in each of the arb formats and 
as a stand–alone menu. While the following figure shows how to access the controls using both the 
stand–alone menu and the Dual ARB player, the location and softkeys within each arb format is the 
same as for the Dual ARB player.

Figure 10-1 Stand–Alone and Dual ARB Player Real–Time Phase Noise Softkeys

The end frequency for the flat 
mid–frequency characteristics.

The start frequency for the flat 
mid–frequency characteristics.

For details on each key, use key help 
as described on page 34. 

The display updates even 
when the feature is off.

For an explanation on these 
settings see
“The Agilent X-Series Phase 
Noise Shape and Additive Phase 
Noise Impairments” on page 239.

Flat Mid–Frequency Area
Denoted by f1 and f2

This softkey is 
available in all arb 
formats.

The amplitude for the flat 
mid–frequency characteristics. 
(Lmid stands for the level 
amplitude of the mid–frequency 
characteristic.)

NOTE: The phase noise impairment is added to the base phase noise of    
             the signal generator.

Stand–alone menu
Use to add phase noise to the 
CW output without having to 
play a waveform.
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 Real–Time Phase Noise Impairments (Option 432)
The Agilent X-Series Phase Noise Shape and Additive Phase Noise Impairments
The Agilent X-Series Phase Noise Shape and Additive Phase Noise Impairments

Flat mid–frequency offset

−50 dBc/Hz−50 dBc/Hz

Phase Noise Plots Without Phase Noise Impairment

The Agilent X-Series vector signal generator 
demonstrates a definitive shape to its phase 
noise plot. The mid–frequency offsets are 
characterized by a leveling (flattening) of the 
phase noise amplitude from approximately a 
3 kHz offset to approximately a 70 kHz offset.
Close in and far out offsets demonstrate 
sloping characteristics (areas before and 
after the mid–frequency offsets).

The signal generator degrades the phase noise by moving the mid–frequency characteristics and/or 
changing its amplitude using the following settings:

• Start frequency (f1) of the mid–frequency characteristics
• Stop frequency (f2) of the mid–frequency characteristics
• Amplitude (Lmid) of the mid–frequency characteristics

f1 f2

Mid–frequency characteristics

−50 dBc/Hz−50 dBc/Hz

Amplitude
  (Lmid)

This is a plot of the unmodified phase noise 
shape that shows the location that each 
value alters.
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Real–Time Phase Noise Impairments (Option 432) 
The Agilent X-Series Phase Noise Shape and Additive Phase Noise Impairments 
Flat mid–frequency offset 
(Lmid)

f1
f2

characteristics

Phase Noise Plots With Phase Noise Impairments

−50 dBc/Hz −50 dBc/Hz

Flat mid–frequency offset 
(Lmid)characteristics

No additive 
phase noise

Resultant phase
noise plot

When turned on, this phase noise is added 
to the base phase noise of the signal 
generator. 
 
Even though it is only the mid–frequency 
characteristics placement that are modified, 
these changes affect the entire phase noise 
shape. The close in and far out offset 
characteristics change by exhibiting 
approximately a 20 dBc/Hz slope for each 
octave of frequency offset.

The resultant phase noise plot shown on 
the left has the following settings:

• f1 = 100 Hz
• f2 = 1 kHz
• Amplitude (Lmid) = –70 dBc

−20 dBc/Hz 
    slope

f1 f2

−70 dBc

100 Hz 1 kHz

The frequency values entered for the impairments may not be the exact values when viewed on the 
RF output. The entered values are guidelines that the signal generator uses to calculate the real 
values. See “Understanding the Phase Noise Adjustments” on page 241 for more information. 
 
To view the results of the settings (f1, f2, and Lmid), use the front panel graph (below and on 
page 238) or view the phase noise plot on a measurement instrument (shown above—Agilent E4440A 
PSA with  Option 226).

−50 dBc/Hz −50 dBc/Hz

Signal generator front panel plot:

• f1 = 100 Hz
• f2 = 1 kHz
• Lmid = –70 dBc

Ensure that the f1 value is less than or 
equal to f2. If not, f2 changes its value to 
match f1. Conversely if f2 is set to a value 
that is less than f1, f1 changes its value to 
match f2.
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 Real–Time Phase Noise Impairments (Option 432)
Understanding the Phase Noise Adjustments
Understanding the Phase Noise Adjustments
The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1 
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If 
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid 
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary 
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate the 
real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop 
frequency values are an approximation and may not be the values seen on a measurement 
instrument, however they will be close. 

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is 
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior 
more noticeable at higher frequency settings. This becomes apparent when a change in the f1 or f2 
value causes little to no change in the f1 or f2 position. This is easy to view using the signal 
generator’s front panel phase noise graph and demonstrated in Figure 10- 2. This behavior makes the 
frequency adjustments coarser as the f2 frequency value increases.

Figure 10-2 f1 and f2 Frequency Setting Behavior

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing 
the front panel graph or making a measurement. You can view the front panel graph remotely by 
using the LXI interface. For more information on the LXI interface, see the Programming Guide.

f1 and f2 softkey settings for the front 
panel phase noise graph. 

f1 did not change frequency until 
12.1 MHz was set. This means that it 
took an increase of 1.6 MHz to change 
its frequency offset.

f2 did not change frequency until 40 
MHz was set. This means that it took an 
increase of 10 MHz to change its 
frequency offset.

f1—original 10.5 MHz 
setting

f1—12.1 MHz setting that 
moved the offset position

f2—original 30 MHz 
setting

f2—40 MHz setting that 
moved the offset position

For details on each key, use key help 
as described on page 34.
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DAC Over–Range Conditions and Scaling 
DAC Over–Range Conditions and Scaling
When using phase noise impairment, it is possible to create a DAC over–range condition, which 
causes the signal generator to generate an error. To minimize this condition with the phase noise 
impairment feature, the Agilent X- Series signal generator incorporates an automatic DAC over–range 
protection feature that scales down the I/Q data. Because it can scale the data by more than what is 
actually need, it typically decreases the dynamic range of the waveform. This is especially noticeable 
when using a constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over–range protection can be turned off (on is the factory 
default). The control for the Dual ARB DAC over–range protection feature is located in the key path 
as shown in Figure 10- 3.

Figure 10-3 Dual ARB DAC Over–Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
over–range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over–range 
conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over–range condition 
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself. 

For details on each key, use key help 
as described on page 34.

When the DAC over–range protection is off, 
eliminate over–range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on page 181).

Default setting is On. 

Turn off to manually control scaling while 
using the phase noise impairment option. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
shown above.
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11   Custom Digital Modulation (Option 431)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 33 and familiarize yourself with the information in that 
chapter.

This feature is available only in Agilent X- Series vector signal generators with Option 431. Option 431 
requires Option 653 or 655 (N5172B) or Option 656 or 657 (N5182B).

• Custom Modulation on page 244

• Creating and Using Bit Files on page 252

• Using Customized Burst Shape Curves on page 258

• Using the Arbitrary Waveform Generator on page 265

• Using Finite Impulse Response (FIR) Filters with Custom Modulation on page 281

• Modifying a FIR Filter Using the FIR Table Editor on page 287

• Differential Encoding on page 290
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   Custom Digital Modulation (Option 431) 
Custom Modulation 
Custom Modulation 
For creating custom modulation, the signal generator offers two modes of operation: the ARB custom 
modulation mode and the real- time custom modulation mode. The ARB custom modulation mode has 
built- in modulation formats such as NADC or GSM and pre- defined modulation types such as BPSK 
and 16QAM that can be used to create a signal. It also provides the flexibility to modify the digital 
format’s attributes. The real- time custom modulation mode can be used to create custom data 
formats using built- in PN sequences or custom- user files along with various modulation types and 
different built- in filters such as Gaussian or Nyquist. 

Both modes of operation are used to build complex, digitally modulated signals that simulate 
communication standards with the flexibility to modify existing digital formats, define or create 
digitally modulated signals, and add signal impairments.

ARB Custom Modulation Waveform Generator

The signal generator’s ARB Custom Modulation mode is designed for out–of–channel test applications. 
This mode can be used to generate data formats that simulate random communication traffic and can 
be used as a stimulus for component testing. Other capabilities of the ARB Custom Modulation mode 
include: 

• configuring single or multicarrier signals. Up to 100 carriers can be configured. 

• creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing 
where device performance such as adjacent channel power (ACP) can be measured. The 
AUTOGEN_WAVEFORM file, that is automatically created when you turn the ARB Custom Modulation on, 
can be renamed and stored in the signal generator’s non–volatile memory. This file can later be 
loaded into volatile memory and played using the dual ARB waveform player. 

For more information, refer to “Waveform File Basics” on page 130 and “Modes of Operation” on 
page 4.

Real-Time Custom Modulation Waveform Generator

The real- time mode simulates single- channel communication using user- defined modulation types 
along with custom FIR filters, and symbol rates. Data can be downloaded from an external source 
into PRAM memory or supplied as real- time data using an external input. The real- time I/Q 
baseband mode can also generate pre- defined data formats such as PN9 or FIX4. A continuous data 
stream generated in this mode can be used for receiver bit error analysis. This mode is limited to a 
single carrier. The real- time custom modulation mode:

• has more data and modulation types available than the ARB waveform generator mode

• supports custom I/Q constellation formats

• has the capability to generate continuous PN sequences for bit error rate testing (BERT)

• needs no waveform build time when signal parameters are changed.
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    Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-1 ARB Custom Modulation Softkeys

page 246

page 184

page 130

page 278

This softkey changes, 
depending on the selected 
mode of modulation.

Available only when 
Multicarrier is On.

Available only when 
Multicarrier is Off.

page 278

Enables the current ARB 
custom modulation settings.

For details on each key, use key help as described on page 34.

page 162

page 131

page 297

page 249

page 220
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   Custom Digital Modulation (Option 431) 
Custom Modulation 
Figure 11-2 Quick Setup Softkeys

page 247

page 281

page 271

Mode > ARB Custom Modulation > Single Carrier Setup

page 248

This softkey label shows 
the currently selected 
modulation standard.

Press Symbol Rate 
softkey and use 
numeric keypad to 
change value as 
required. 
The default (initial) 
Symbol Rate 
maximum range value 
is dependent upon the 
modulation standard 
selected with the 
Quick Setup softkey.

When one of these pre–defined 
modulation standards is selected, 
default values for components of the 
setup (including filter, symbol rate, and 
modulation type) are automatically 
specified.

For details on each key, use key help as described on page 34.

Default: This softkey selects the 
following default settings:
Modulation Type = QPSK, 
Symbol Rate = 1 Msps, 
Filter = Root Nyquist, and 
Filter Alpha = 0.5
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    Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-3 Mod Type Softkeys

page 281

page 246

page 248

Mode > ARB Custom Modulation > Single Carrier 
Setup

page 267

Sets the modulation depth for the 
Amplitude Shift Keying (ASK).

For details on each key, use key help as described on page 34.

These symbol maps 
utilize Gray coded 
bit mapping.

These symbol maps 
are consistent with 
the symbol maps in 
the VSA software.
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   Custom Digital Modulation (Option 431) 
Custom Modulation 
Figure 11-4 Custom Modulation Formats and Applications

Figure 11-5 Store Custom Dig Mod State Softkeys

Catalog displays digital 
modulation (DMOD) files that 
have been previously saved.

page 270

Mode > ARB Custom Modulation > Single Carrier Setup > Store Custom Dig Mod State

For details on each key, use key help as described on page 34.
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    Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-6  Real-Time Custom Modulation Softkeys

page 130

For details on each key, use key help as described on page 34.

page 297
page 250

Opens a menu from 
which you can set burst 
shape parameters.

page 220

page 244

Enables the current 
custom real-time 
modulation settings.

page 290

page 229

page 238

page 162

page 184
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   Custom Digital Modulation (Option 431) 
Custom Modulation 
Figure 11-7  Modulation Setup Softkeys

page 251

page 281

Mode > Real-Time Custom Modulation > Modulation Setup

page 253

This softkey label shows 
the currently selected 
modulation 

Press Symbol Rate 
softkey and use 
numeric keypad to 
change value as 
required. 
The default (initial) 
Symbol Rate 
maximum range value 
is dependent upon the 
modulation standard 
selected with the 
Quick Setup softkey.

When one of these pre–defined 
modulation standards is selected, 
default values for components of the 
setup (including filter, symbol rate, and 
modulation type) are automatically 
specified.

For details on each key, use key help as described on page 34.
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    Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-8  Modulation Type Softkeys

page 281

page 250

Mode > Real-Time Custom Modulation > 
Modulation Setup

For details on each key, use key help as described on page 34.

page 252

These symbol maps 
utilize Gray coded 
bit mapping.

These symbol maps 
are consistent with 
the symbol maps in 
the VSA software.

page 272

page 273
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   Custom Digital Modulation (Option 431) 
Creating and Using Bit Files 
Creating and Using Bit Files
This procedure teaches you how to use the Bit File Editor to create, edit, and store user- defined 
files for data transmission within real time I/Q baseband generated modulation. For this example, a 
user file is defined within a custom digital communications format.

User files (user- defined data files) can be created on a remote computer and moved to the signal 
generator for subsequent modification, or they can be created and modified using the signal 
generator’s Bit File Editor.

These user files can then be transmitted data as a continuous unframed data stream according to the 
protocol of the active format, transmitted as the data for a custom ARB modulation or real- time 
format. User files are not available for signals generated by the dual ARB waveform generator.

NOTE For information on creating user- defined data files on a remote computer, see the Agilent 
Signal Generators Programming Guide.
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Figure 11-9  Data Selection Softkeys

Creating a User File

Accessing the Table Editor
1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File > Create File.

This opens the Bit File Editor. The Bit File Editor contains three columns: Offset, Binary 
Data, and Hex Data, as well as cursor position (Position) and file name (Name) indicators, as 
shown in the following figure.

 

Mode > Real-Time Custom Modulation > 
Modulation Setup

For details on each key, use key help as described on page 34.

Press this key to select from a 
number of P sequences and 
whether to invert them.

Press this key to select data 
patterns of 1s and 0s.

Press this key to create, select, 
and edit files to use as the bit 
pattern.

Press this key to select a Pattern 
RAM (PRAM) file. 
PRAM files are binary arrays in byte 
format. Each byte consists of a data 
bit (LSB/bit 0), a burst bit (bit 2), and 
an Event 1 output bit (bit 6). The 
PRAM internal format consists of 4 
bytes for each PRAM byte.
PRAM files are useful for specifying 
custom framing structures with fixed 
data.
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Figure 11-10 Bit File Display

NOTE When you create new file, the default name appears as UNTITLED, or UNTITLED1, and so 
forth. This prevents overwriting previous files.

Entering Bit Values

Bit data is entered into the table editor in 1- bit format. The current hexadecimal value of the binary 
data is shown in the Hex Data column, and the cursor position (in hexadecimal) is shown in the 
Position indicator.

1. Refer to the following figure.

2. Enter the 32 bit values shown.

Offset 
(in Hex)

Bit Data Cursor Position Indicator 
(in Hex)

Hexadecimal Data File Name Indicator
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Figure 11-11 Entering Bit Values

Renaming and Saving a User File

In this example, you learn how to store a user file. If you have not created a user file, complete the 
steps in the previous section, “Creating a User File” on page 253.

1. Press More (1 of 2) > Rename > Editing Keys > Clear Text.

2. Enter a file name (for example, USER1) using the alpha keys and the numeric keypad.

3. Press Enter.

The user file has now been renamed and stored to the Bit memory catalog with the name USER1.

Enter these bit values Cursor Position Indicator Hexadecimal Data
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Recalling a User File

In this example, you learn how to recall a user- defined data file from the memory catalog. If you 
have not created and stored a user- defined data file, complete the steps in the previous sections, 
“Creating a User File” on page 253 and “Renaming and Saving a User File” on page 255.

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File.

3. Highlight the file USER1.

4. Press Edit File.

The Bit File Editor opens the file USER1.

Modifying an Existing User File

In this example, you learn how to modify an existing user- defined data file. If you have not created, 
stored, and recalled a user- defined data file, complete the steps in the previous sections, “Creating a 
User File” on page 253, “Renaming and Saving a User File” on page 255 and “Recalling a User File” 
on page 256.

Navigating the Bit Values
1. Press Return > Goto > 4 > C > Enter.

This moves the cursor to bit position 4C in the table, as shown in the following figure.

Figure 11-12 Navigating the Bit Values

Cursor moves to new position

Position indicator changes
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Inverting Bit Values
1. Press 1011.

This inverts the bit values that are positioned 4C through 4F. Notice that hex data in this row has 
now changed to 76DB6DB6, as shown in the following figure.

Figure 11-13 Inverting Bit Values

Applying Bit Errors to a User File 

In this example, you learn how to apply bit errors to a user- defined data file. If you have not created 
and stored a user- defined data file, complete the steps in the previous sections, “Creating a User 
File” on page 253 and “Renaming and Saving a User File” on page 255.

1. Press Apply Bit Errors.

2. Press Bit Errors > 5 > Enter.

3. Press Apply Bit Errors.

Notice both Bit Errors softkeys change value as they are linked.

Bits 4C through 4F are inverted Hex Data changed
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Using Customized Burst Shape Curves
You can adjust the shape of the rise time curve and the fall time curve using the Rise Shape and 
Fall Shape editors. Each editor allows you to enter up to 256 values, equidistant in time, to define 
the shape of the curve. The values are then resampled to create the cubic spline that passes through 
all of the sample points.

The Rise Shape and Fall Shape table editors are available for custom real- time I/Q baseband 
generator waveforms.

Understanding Burst Shape

The default burst shape of each format is implemented according to the standards of the format 
selected. You can, however, modify the following aspects of the burst shape:

Rise time  the period of time, specified in symbols or bits, where the 
burst increases from a minimum of −70 dB (0) to full power 
(1).

Fall time  the period of time, specified in symbols or bits, where the 
burst decreases from full power (1) to a minimum of −70 dB 
(0).

Rise delay  the period of time, specified in symbols or bits, that the start 
of the burst rise is delayed. Rise delay can be either negative 
or positive. Entering a delay other than zero shifts the full 
power point earlier or later than the beginning of the first 
useful symbol.

Fall delay  the period of time, specified in symbols or bits, that the start 
of the burst fall is delayed. Fall delay can be either negative or 
positive. Entering a delay other than zero shifts the full power 
point earlier or later than the end of the last useful symbol.

User- defined burst shape  up to 256 user- entered values which define the shape of the 
curve in the specified rise or fall time. The values can vary 
between 0 (no power) and 1 (full power) and are scaled 
linearly. Once specified, the values are resampled as necessary 
to create the cubic spline that passes through all of the sample 
points.
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Burst shape maximum rise and fall time values are affected by the following factors:

• the symbol rate

• the modulation type

When the rise and fall delays equal 0, the burst shape is attempting to synchronize the maximum 
burst shape power to the beginning of the first valid symbol and the ending of the last valid symbol 
of the timeslot. The following figure illustrates a bursted signal in an EDGE frame with a rise delay 
of 0 and a fall delay of +1 bit.

0

1

Po
w

er Rise 
Delay

Rise 
Time

Fall 
Time

Fall 
Delay

Time 

User-Defined 
Values User-Defined 

Values
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 259



   Custom Digital Modulation (Option 431) 
Using Customized Burst Shape Curves 
The signal generator firmware computes optimum burst shape based on the settings you’ve chosen for 
modulation. You can further optimize burst shape by lining up the data portion with the modulation. 
For example, if you’re designing a new modulation scheme, do the following:

• Adjust the modulation and filtering to set the spectrum you want.

• Adjust the burst rise and fall delay and rise and fall time for the timeslots.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when 
you turn bursting on, you can adjust the burst shape to assist with troubleshooting.
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Figure 11-14 Burst Shape Softkeys

Creating a User-Defined Burst Shape Curve

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall shape 
values to create a symmetrical burst curve.

This section teaches you how to perform the following tasks:

• “Accessing the Table Editors” on page 261

• “Entering Sample Values” on page 262

Accessing the Table Editors
1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Burst Shape.

3. Press More > Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of All Rows.

Mode > Real-Time Custom Modulation 

For details on each key, use key help as described on page 34.
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Entering Sample Values

Use the sample values in the following table.

1. Highlight the value (1.000000) for sample 1.

2. Press .4 > Enter.

3. Press .6 > Enter.

4. Enter the remaining values for samples 3 through 6 from the table above.

5. Press Return > Edit Fall Shape > Load Mirror Image of Rise Shape >  
Confirm Load Mirror Image Of Rise Shape.

This changes the fall shape values to a mirror image of the rise shape values, as shown in Figure 
11- 15 on page 262.

Figure 11-15 Mirror Image of Rise Shape

Rise Shape Editor

Sample Value Sample Value

0 0.000000 4 0.830000

1 0.400000 5 0.900000

2 0.600000 6 1.000000

3 0.750000
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Display the Burst Shape

Press Display Burst Shape.

This displays a graphical representation of the waveform’s rise and fall characteristics, as shown in 
Figure 11- 16.

Figure 11-16 Burst Shape

To return the burst to the default conditions, press the following keys:

Return > Return > Return > Confirm Exit From Table Without Saving > Restore Default Burst Shape.

Storing a User-Defined Burst Shape Curve
1. Press Define User Burst Shape > More (1 of 2) > Load/Store > Store To File.

If there is already a file name from the Catalog of SHAPE Files occupying the active entry 
area, press the following keys:

Editing Keys > Clear Text

2. Enter a file name (for example, NEWBURST) using the alpha keys and the numeric keypad.

The maximum file name length is 23 characters (alphanumeric and special characters).

3. Press Enter.

The contents of the current Rise Shape and Fall Shape table editors are stored to the Catalog of 
SHAPE Files. This burst shape can now be used to customize a modulation or as a basis for a new 
burst shape design.

Recalling a User-Defined Burst Shape Curve

Once a user- defined burst shape file is stored in memory, it can be recalled for use with real- time 
I/Q baseband generated digital modulation.

This example requires a user- defined burst shape file stored in memory. If you have not created and 
stored a user- defined burst shape file, complete the steps in the previous sections, “Creating a 
User- Defined Burst Shape Curve” on page 261 and “Storing a User- Defined Burst Shape Curve” on 
page 263.

1. Press Preset.
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2. Press Mode > Real-Time Custom Modulation > Burst Shape > Burst Shape Type > User File.

3. Highlight the desired burst shape file (for example, NEWBURST).

4. Press Select File.

The selected burst shape file is now applied to the current real time I/Q baseband digital 
modulation state.
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Using the Arbitrary Waveform Generator
This section teaches you how to build dual arbitrary (ARB) waveform files containing custom digital 
modulation for testing component designs. 

Figure 11-17 Adding Custom Modulation to a Waveform

Using Predefined Custom Digital Modulation

This section teaches you how to perform the following tasks:

• Selecting a Predefined EDGE Setup on page 265

• Generating the Waveform on page 265

• Configuring the RF Output on page 266

Selecting a Predefined EDGE Setup
1. Press Preset.

2. In the ARB Custom Modulation menu (page 265), press Single Carrier Setup > Quick Setup > EDGE.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the pre–defined EDGE state selected in the step. The display changes 
to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q annunciators appear and 
the pre–defined digital modulation state is stored in volatile memory (BBG). The waveform is now 
modulating the RF carrier.

page 281

page 248

This softkey label updates to reflect 
the current modulation type.

Mode > ARB Custom Modulation > Single Carrier Setup

page 247

page 271

For details on each key, use key help as described on page 34.
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Configuring the RF Output
1. Set the RF output frequency to 891 MHz. 

2. Set the output amplitude to −5 dBm. 

3. Press RF On/Off.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.
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Creating a Custom Digital Modulation State

In this procedure, you learn how to set up a single–carrier NADC digital modulation with customized 
modulation type, symbol rate, and filtering.

Figure 11-18 Setting a Digital Modulation Filter

This softkey label updates to reflect 
the current modulation standard.

Mode > ARB Custom Modulation > Single Carrier Setup

page 271

This softkey 
sets the filter 
bandwidth 
parameter, 
alpha. The 
default Alpha 
value changes 
with the 
modulation 
standard (see 
page 281) and 
modulation 
type selected 
(see 
page 247).

For details on each key, use key help as described on page 34.

This softkey sets 
the filter shape. page 268

Opens a menu to select a 
IS-95 filter.
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Figure 11-19 Modifying a Digital Modulation Type

This section teaches you how to perform the following tasks:

• Selecting a Digital Modulation Setup on page 268

• Configuring the RF Output on page 266

• Selecting the Filter on page 269

• Configuring the RF Output on page 266

Selecting a Digital Modulation Setup
1. Press Preset.

2. In the ARB Custom Modulation menu (page 267), press Single Carrier Setup > Quick Setup > NADC.

Modifying the Modulation Type and Symbol Rate
1. In the ARB Custom Modulation menu (page 267), press Single Carrier Setup > Modulation Type > Select 

> PSK > QPSK and OQPSK > QPSK.

2. Press Return > Symbol Rate > 56 > ksps.

Note: This is the 
2nd page of the 
PSK menu.

Note: This is the 
2nd page of the 
QPSK menu.

Mode > ARB Custom Modulation > Single Carrier Setup >  
Modulation Type > Select

For details on each key, use key help as described on page 34.

These softkeys, 
open a menu to 
select an 
existing user I/Q 
or user FSK file 
that can be 
selected and 
applied to the 
current 
modulation type.
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Selecting the Filter
1. In the Setup Mod menu (page 267), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the custom, single–carrier NADC, digital modulation state created in 
the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During waveform 
generation, the DIGMOD and I/Q annunciators appear and the custom single–carrier digital 
modulation state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, single–carrier NADC, digital modulation state to the 
non–volatile memory catalog, see Storing a Custom Digital Modulation State on page 269. 

Configuring the RF Output
1. Set the RF output frequency to 835 MHz. 

2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The user–defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom 
multicarrier digital modulation state to non–volatile memory.

If you have not created a custom, single–carrier, digital modulation state, complete the steps in the 
previous section, Creating a Custom Digital Modulation State on page 267.
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Figure 11-20 Storing a Custom Digital Modulation State

1. Return to the top–level ARB Custom Modulation menu, where Digital Modulation Off On is the first 
softkey.

2. In the ARB Custom Modulation menu (page 270), press Single Carrier Setup > Store Custom Dig Mod 
State > Store To File.

If there is already a file name from the Catalog of DMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user–defined, single–carrier, digital modulation state is now stored in non–volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a 
user–defined, digital modulation state file.

Catalog displays DMOD files that 
have been previously saved by 
the user.

Mode > ARB Custom Modulation > Single 
Carrier Setup

page 35

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 34.
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Recalling a Custom Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal 
non–volatile memory.

If you have not created and stored a user- defined, single–carrier, digital modulation state, complete 
the steps in the previous sections, Creating a Custom Digital Modulation State on page 267 and 
Storing a Custom Digital Modulation State on page 269, then preset the signal generator to clear the 
stored user–defined, digital modulation waveform from volatile ARB memory.

Figure 11-21 Recalling a Custom Digital Modulation State

1. In the Quick Setup menu, press Custom Digital Mod State.

2. Highlight the desired file (for example, NADCQPSK).

3. Press Select File > Return.

4. Press Digital Modulation Off On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After 
waveform generation, the custom, digital modulation waveform is available to be modulated on the 
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 266.

Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup

Loads the highlighted file 
into the instrument 

memory.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key 
help as described on page 34.
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Defining a Modulation

You can build a unique modulation by utilizing two tools, the FSK table editor or the I/Q table editor. 
These tables map data onto specific absolute modulation states. To map transitions between states, a 
differential table editor is provided.

Building an Asymmetric FSK Modulation with the FSK Table Editor

You can use the FSK table editor to create customized asymmetric FSK modulation of up to 16 levels, 
then apply the custom FSK modulation to one of the modulation standards. An example of this 
capability is to create an interfering signal for adjacent channel selectivity testing of FLEXΤΜ pagers. 
To do this, build a 4- level FSK modulation at 4.8 kHz and 1.6 kHz in the FSK table editor, shown in 
Figure 11- 22. Then use this signal to modulate a PN15 data transmission. In the FLEXΤΜ protocol, 
each of the levels in 4- level FSK represents a 2- bit sequence.

Create a Continuous 4-Level FSK Signal

Use this procedure to create a 4- level FSK signal for adjacent channel testing of FLEXΤΜ pagers.

1. Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User FSK. 
3. Enter the frequency deviations shown in Figure 11- 22 into the FSK table editor.

4. Store the file as 4FSK. Press Load/Store > Store To File > 4FSK > Enter.

5. Load the file. Press Load from Selected File > Confirm Load From File.

6. Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.

7. Set the Frequency to the desired carrier frequency for the adjacent channel.

8. Set the desired Amplitude.

9. Press RF On. The amplitude of the interferer can then be adjusted to measure the performance of 
the device under test.
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Figure 11-22 FSK Table Editor

Mapping I/Q Values with the I/Q Table Editor

In most digital radio systems, the frequency of the carrier is fixed so only phase and magnitude need 
to be considered. The phase and magnitude of symbols can be represented as a discrete point in the 
I/Q plane. I represents "in phase" and Q represents "quadrature".

Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User FSK

For details on each key, use key 
help as described on page 34.
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Figure 11-23 I/Q Constellation Diagram

By modulating the carrier to one of several predetermined positions in the I/Q plane, you can then 
transmit encoded information. Each position or state represents a certain bit pattern that can be 
decoded at the receiver. The mapping of the states at each symbol decision point on the I/Q plane is 
referred to as a constellation diagram. You can create a unique signal by mapping your constellation 
diagram into the I/Q table editor, shown in Figure 11- 24. The table editor also has a display feature, 
which provides a quick visual check of the expected I/Q constellation. 

Figure 11-24 I/Q Table Editor

For details on each key, use key 
help as described on page 34.

Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User I/Q
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Utilizing this I/Q mapping flexibility, you can create unique modulation schemes. For example, a 
circular constellation arrangement called a STAR QAM is easily implemented and saved for later 
recall with the real- time I/Q baseband generator. Figure 11- 25 shows that the STAR QAM has 16 
states or symbols. Four data bits define each symbol. Thus, the diagram and the table are 
equivalents.

Create a STAR QAM Modulation Scheme
1. Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User IQ. 
3. Enter the values shown in Figure 11- 25 for I and Q using the numeric keypad and arrow keys.  

Press Display IQ Map to check your entry and adjust any entry errors.

4. Press Return > Store To File > Clear Text.

5. Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.

6. Name the file STAR and press Enter.

7. Load the file. Highlight STAR and press Load from Selected File > Confirm Load From File.

8. Turn on Custom Modulation. Press Return > Return > Return > Return > Real-Time Custom On.

9. Set the Frequency and Amplitude to the desired values.

10. Press RF On. 

Figure 11-25 STAR QAM Diagram and Table
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 275



   Custom Digital Modulation (Option 431) 
Using the Arbitrary Waveform Generator 
Figure 11- 26 shows the X- Series setup and the I/Q display.

Figure 11-26 Custom Modulation and I/Q Display

Hints for Constructing Modulations
• The map is limited to 16 total signal levels for I and Q combined. The readout on the right- hand 

side of the table tracks the number of I and Q levels utilized. Levels are I or Q values. Figure 
11- 27 shows an 8PSK signal built in two different ways. The 8PSK signal in Figure 11- 27 utilizes 
five of the available sixteen I/Q values on the left, and utilizes four of the available sixteen I/Q 
values on the right.

• Following this example, the real- time I/Q baseband generator supports a symmetric 256QAM 
constellation but not an asymmetric 256QAM constellation, since the asymmetry requires more 
than sixteen I/Q values.

• The levels do not have to be equally spaced or symmetric in the I/Q plane. For example, the 
16QAM modulations shown in Figure 11- 28 are both possible.
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Figure 11-27 8PSK Signal Built Two Ways

Figure 11-28 16QAM I/Q Map with Even and Uneven Levels
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Creating a Custom Multicarrier Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup by 
creating a custom, 3–carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

• Creating a Multicarrier Digital Modulation Setup on page 279

• Modifying Carrier Frequency Offset on page 279

• Modifying Carrier Power on page 279

• Generating the Waveform on page 279

• Configuring the RF Output on page 279

Figure 11-29 Creating a Multicarrier Digital Modulation Setup

Mode > ARB Custom Modulation

Becomes active when a change 
has been made to the 
Multicarrier Setup table values 
or to the multicarrier menu 
values (i.e. Carrier Setup, # of 
Carriers, Freq Spacing, or to the 
Carrier Phases).

For details on each key, use key help as described on page 34.
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Creating a Multicarrier Digital Modulation Setup
1. Press Preset.

2. Press Mode > ARB Custom Modulation > Multicarrier Off On to On.

3. Press Multicarrier Setup > Select Carrier and Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset
1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.

2. Press –625 > kHz.

Modifying Carrier Power
1. Highlight the Power value (0.00 dB) for the carrier in row 2.

2. Press –10 > dB.

You now have a custom 2–carrier EDGE waveform with a carrier at a frequency offset of 
−625 kHz and a power level of −10.00 dBm, as shown in the following figure.

Generating the Waveform

Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous 
sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During waveform 
generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, EDGE state 
is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non–volatile memory, see 
“Storing a Custom Multicarrier Digital Modulation State” on page 280. 

Configuring the RF Output
1. Set the RF output frequency to 890.01 MHz. 

2. Set the output amplitude to −10 dBm. 

3. Press RF On/Off.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.

If Digital Modulation is already on, you 
must press Apply Multicarrier to apply 
the changes and generate a new 
custom multicarrier digital modulation 
waveform based on the updated 
values.

For details on each key, use key 
help as described on page 34.
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Storing a Custom Multicarrier Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, digital modulation state to 
non–volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the 
previous section, “Creating a Custom Multicarrier Digital Modulation State” on page 278.

Figure 11-30 Storing a Custom Multicarrier Softkeys

1. Return to the top–level Digital Modulation menu, where Digital Modulation Off On is the first softkey.

2. Press Multicarrier Setup > More > Load/ Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user–defined, multicarrier, digital modulation state is now stored in non–volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a 
user–defined, digital modulation state file.

Applying Changes to an Active Multicarrier Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes 
are made in the Multicarrier Setup table editor, you must apply the changes before the updated 
waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and generate 
a new custom multicarrier digital modulation waveform based on the updated values.

page 35

Fixed: All the carriers are set to a 
phase of 0.
Random: All of the carriers are 
set to a random phase value.

For details on each key, use key help as 
described on page 34.
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Using Finite Impulse Response (FIR) Filters with Custom Modulation 
Finite Impulse Response filters can be used to refine the transitions between symbol decision points 
of the generated waveforms. 

Figure 11-31     Filter Menu

Understanding FIR Filters 

FIR filters are used to limit the bandwidth of the input to the I and Q modulators. Several different 
types of FIR filters exist. The NADC, PDC, PHS, and TETRA standards specify a root Nyquist filter in 
both the transmitter and the receiver. The combined response is equivalent to a Nyquist filter. The 
Nyquist filter has an impulse response that rings at the data clock rate so nulls appear at all symbol 
decision points except the desired one at the center of the impulse response. Since each symbol 
causes zero response at all undesired decision points, there can be no inter- symbol interference (ISI). 
The alpha term (α) defined for Nyquist- type filters identifies the frequency cutoff point were the 
filter response is zero. The closer the alpha term is to zero, the steeper the filter roll- off becomes. 
Alpha gives a direct measure of the occupied bandwidth of the system and is calculated as

Occupied Bandwidth = Symbol Rate x (1 + α)

Mode > ARB Custom Modulation > Single Carrier Setup > Filter

This replaces the 
current FIR filter with 
the factory installed 
default filter settings 
for the current 
modulation type.

This softkey changes, depending 

on the selected filter–type.

Available only when the filter selected =
Root Nyquist or Nyquist

Available only when the 
filter selected = Gaussian

page 287
Only applies to Dual 
ARB Modulation. Refer 
to page 129.

For details on each key, use key help as described on page 34.

Opens the IS–95 
filter selection 
menu.

page 283
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The NADC and TETRA standards specify an alpha of 0.35. PDC and PHS standards specify an alpha 
of 0.50. For each of these standards, the Agilent X- Series signal generator provides a root Nyquist 
filter with the designated alphas as the default premodulation filter. Figure 11- 32 shows the Nyquist 
impulse response for several values of alpha.

Notice that the half- amplitude point is always at the half- symbol rate. Since all of the information is 
contained within the half symbol rate bandwidth, alpha is a measure of the additional occupied 
bandwidth.

Another type of FIR filter, which is specified in the GSM and DECT standards, is the Gaussian filter. 
Gaussian filters typically have more inter- symbol interference than Nyquist filters, but their adjacent 
channel power performance is better for constant- amplitude modes like MSK, where Nyquist filtering 
of I and Q is not possible. The bandwidth bit time (BbT) product (similar to α) is defined by the 
GSM standard as 0.30 and by the DECT standard as 0.50. For each of these standards, the Agilent 
X- Series signal generator provides a Gaussian filter with the designated BbT product as the default 
premodulation filter.

Figure 11-32 Nyquist Filter Impulse Response

Selecting a Filter and the Alpha (α) or Bandwidth Bit Time (Bbt) Product

Due to individual system design requirements, you may decide to change the filter or the filter α or 
BbT. You can adjust the alpha from 0 to 1 and the BbT from 0.1 to 1.

To change the filter alpha:

1. Preset the instrument.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Filter > Select Nyquist > Filter Alpha.

3. Enter a new value between 0 and 1. Press Enter.

4. To restore the default filter values, press Restore Default Filter.
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NOTE To change the filter Bbt, press Mode > Real-Time Custom Modulation > Modulation Setup > Filter > 
Select Gaussian > Filter Bbt.

Enter a new value between 0.1 and 1.

Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed 
sync function filter with an oversample ratio of 4.

Accessing the Table Editor
1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Filter > Select > Nyquist.

3. Press Filter > Define User FIR. 

4. Press More 2 of 2 > Delete All Rows > Confirm Delete of All Rows. 

This will initialize the table editor as shown in Figure 11- 33.

Figure 11-33 Creating a User–Defined FIR Filter Using the FIR Filter Table Editor

Mode > ARB Custom Modulation> Single Carrier Setup > Filter > Define 
User FIR > More > Delete All Rows > Confirm Delete of All Rows

Opens a menu that 
enables you to select 
and load a saved file 
into volatile memory. 
See page 35.

page 199

Active only when:
FIR filter coefficient table 
has minimum of two 
values visible.

For details on each key, use key help as described on page 34.

Note:
Modulation filters are typically real and have an oversample ratio (OSR) of two or greater.
Equalization filers are typically complex and have an oversample ratio (OSR) of one (Dual ARB only).
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Entering the Coefficient Values
1. Press the Return softkey to get to the first page of the table editor. 

2. Use the cursor to highlight the Value field for coefficient 0. 

3. Use the numeric keypad to type the first value (−0.000076) from Table 11- 1. As you press the 
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can 
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been 
entered.

Table 11-1

Coefficient Value Coefficient Value

0 −0.000076 8 −0.035667

1 −0.001747 9 −0.116753

2 −0.005144 10 −0.157348

3 −0.004424 11 −0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748

6 0.043940 14 0.767329

7 0.025852 15 0.972149
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in 
reverse order. The signal generator provides a mirror table function that automatically duplicates the 
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the 
first of these coefficients (number 16) highlights, as shown in Figure 11- 34 on page 285. 

Figure 11-34

Setting the Oversample Ratio

NOTE Modulation filters must be real and have an oversample ratio (OSR) of two or greater.

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range 
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the table 
editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an oversample 
ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 512 
coefficients, the instrument is unable to use the filter. If the oversample ratio is different from the 
internal, optimally selected one, then the filter is automatically resampled to an optimal oversample 
ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency 
dimensions.

1. Press More > Display Filter > Display FFT (fast Fourier transform). 

Refer to Figure 11- 35 on page 286.

FIR table coefficient 
values, may be from the 
factory default values or 
entered by the user.

Use the Goto Row 
menu to move around 
and make changes to 
the FIR Values 
coefficient table.For details on each key, use key help as described on page 34.
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Figure 11-35

2. Press Return.

3. Press Display Impulse Response. 

Refer to Figure 11- 36.

Figure 11-36

4.  Press Return to return to the menu keys.

Storing the Filter to Memory

 Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory 
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 132, name and store 
this file as FIR_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional 
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The 
amount of memory used is also displayed. The number of files that can be saved depends on the size 
of the files and the amount of memory used. Refer to Figure 11- 37.

For details on each key, use key 
help as described on page 34.

For details on each key, use key 
help as described on page 34.
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Figure 11-37

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new 
filter design. 

Modifying a FIR Filter Using the FIR Table Editor
FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You 
can load the FIR table editor with coefficient values from user–defined FIR files stored in 
non–volatile memory or from one of the default FIR filters. Then you can modify the values and store 
the new files. 

Catalog displays FIR files that 
have been previously saved by 
the user.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 34.
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Loading the Default Gaussian FIR File

Figure 11-38 Loading the Default Gaussian FIR File

1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup > NADC.

3. Press Filter > Define User FIR > More 1 of 2 > Load Default FIR > Gaussian.

4. Press Filter BbT > 0.300 > Enter.

Mode > ARB Custom Modulation > Single Carrier 
Setup

These softkeys select a 
window function 
(apodization function) for 
a filter.

For details on each key, use key help as described on page 34.
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate. 

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A 
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per 
symbol of the modulation type, and the number of symbols.

7. Press Display Filter > Display Impulse Response (refer to Figure 11- 39).

Figure 11-39 Impulse Response Display

8. Press Return.

Modifying the Coefficients
1. Using the front panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 11-40 Impulse Response Display with Modified Coefficients

For details on each key, use key 
help as described on page 34.

For details on each key, use key 
help as described on page 34.
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Refer to Figure 11- 40 on page 289. The graphic display can provide a useful troubleshooting tool 
(in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian 
response).

4. Press Return.

5. Highlight coefficient 15. 

6. Press 1 > Enter. 

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Return > Load/Store > Store To File. 

2. Name the file NEWFIR2.

3. Press Enter. 

The contents of the current FIR table editor are stored to a file in non–volatile memory and the 
catalog of FIR files is updated to show the new file. 

Differential Encoding
Differential encoding is a digital–encoding technique whereby a binary value is denoted by a signal 
change rather than a particular signal state. Using differential encoding, binary data in any 
user–defined I/Q or FSK modulation can be encoded during the modulation process via symbol table 
offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user–defined 
modulation based on the default 4QAM template, the I/Q Values table editor contains data that 
represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values, 
1.000000 and −1.000000. The following illustration shows the 4QAM modulation in the I/Q Values 
table editor.
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The following illustration shows a 4QAM modulation I/Q State Map.

Differential encoding employs relative offsets between the states in the symbol table to encode 
user–defined modulation schemes. The Differential State Map table editor is used to introduce 
symbol table offset values which in turn cause transitions through the I/Q State Map based on their 
associated data value. Whenever a data value is modulated, the offset value stored in the Differential 
State Map is used to encode the data by transitioning through the I/Q State Map in a direction and 
distance defined by the symbol table offset value.

Entering a value of +1 will cause a 1–state forward transition through the I/Q State Map, as shown 
in the following illustration. 

NOTE The following I/Q State Map illustrations show all of the possible state transitions using a 
particular symbol table offset value. The actual state–to–state transition would depend upon 
the state in which the modulation had started.

As an example, consider the following data/symbol table offset values.

Table 11-2

Data Offset Value

00000000 +1

00000001 –1

1st Symbol

Distinct values: +1, +1
Data = 00000000

2nd Symbol

Distinct values: –1, +1
Data = 00000001

4th Symbol

Distinct values: +1, –1
Data = 00000011

3rd Symbol

Distinct values: –1, –1
Data = 00000010

12

3 4
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NOTE The number of bits per symbol can be expressed using the following formula. Because the 
equation is a ceiling function, if the value of x contains a fraction, x is rounded up to the 
next whole number. 

Where x = bits per symbol, and y = the number of differential states.

00000010 +2

00000011 0

Table 11-2

Data Offset Value
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These symbol table offsets will result in one of the transitions, as shown.

When applied to the user–defined default 4QAM I/Q map, starting from the 1st symbol (data 00), the 
differential encoding transitions for the data stream (in 2–bit symbols) 0011100001 appear in the 
following illustration. 

Data Value 00000001 

transition 1 state backward
with Symbol Table Offset –1

Data Value 00000010 

transition 2 states forward
with Symbol Table Offset +2

Data Value 00000011 

no transition
with Symbol Table Offset 0

Data Value 00000000 

transition 1 state forward
with Symbol Table Offset +1
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As you can see from the previous illustration, the 1st and 4th symbols, having the same data value 
(00), produce the same state transition (forward 1 state). In differential encoding, symbol values do 
not define location; they define the direction and distance of a transition through the I/Q State Map.

Using Differential Encoding

The signal generator’s Differential State Map table editor enables you to modify the differential 
state map associated with user–defined I/Q and user–defined FSK modulations. In this procedure, 
you create a user–defined I/Q modulation and then configure, activate, and apply differential 
encoding to the user–defined modulation. For more information, see “Differential Encoding” on 
page 290.

Configuring User–Defined I/Q Modulation
1. Press Preset.

2. Perform the following keypress sequence required for your format type.

For Custom ARB Format

Press Mode > ARB Custom Modulation > Single Carrier Setup > Modulation Type > Select > More 1 of 2 > 
Define User I/Q > More > Load Default I/Q Map > QAM > 4QAM.

Or this alternate sequence:

Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup (desired format) > 
Modulation Type > Select > More > Define User I/Q > More 1 of 2 > Load Default I/Q Map > QAM > 4QAM.

Data Value Symbol Table Offset
00
01
10
11

+1
–1
+2
+0

Data = 0011100001
{{

{ {

{
5th Symbol1st Symbol

3rd Symbol

4th Symbol2nd Symbol

1st 

2nd 

3rd 
5th 4th 
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This loads a default 4QAM I/Q modulation and displays it in the I/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11) 
mapped into the I/Q plane using 2 distinct values (1.000000 and −1.000000). These 4 symbols will be 
traversed during the modulation process by the symbol table offset values associated with each 
symbol of data. Refer to Figure 11- 41.

Figure 11-41

Accessing the Differential State Map Table Editor

Press Configure Differential Encoding. 

This opens the Differential State Map table editor, as shown. At this point, you see the data for 
the 1st symbol (00000000) and the cursor prepared to accept an offset value.You are now prepared to 
create a custom differential encoding for the user–defined default 4QAM I/Q modulation. Refer to 
Figure 11- 42 on page 295.

Figure 11-42

Data Symbol Table Offset Values Entry Area
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Editing the Differential State Map
1. Press 1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward 
through the state map by 1 value when a data value of 0 is modulated.

2. Press +/– > 1 > Enter. 

This encodes the second symbol by adding a symbol table offset of −1. The symbol rotates 
backward through the state map by 1 value when a data value of 1 is modulated.

NOTE At this point, the modulation has one bit per symbol. For the first two data values (00000000 
and 00000001) only the last bits (the 0 and the 1, respectively) are significant. 

3. Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward 
through the state map by 2 values when a data value of 10 is modulated.

4. Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate 
through the state map when a data value of 11 is modulated.

NOTE At this point, the modulation has two bits per symbol. For the data values 00000000, 
00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

Applying Custom Differential Encoding

Press Return > Differential Encoding Off On. 

This applies the custom differential encoding to a user–defined modulation. 

NOTE Notice that (UNSTORED) appears next to Differential State Map on the signal generator’s 
display. Differential state maps are associated with the user–defined modulation for which 
they were created. 

In order to save a custom differential state map, you must store the user–defined modulation 
for which it was designed. Otherwise the symbol table offset data is purged when you press 
the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK table editor.
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Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Basic Operation on page 33 and familiarize yourself with the information in that chapter.

This feature is available only in Agilent X- Series vector signal generators with Option 430. Option 430 
requires Option 653 or 656.

Creating a Custom Two–Tone Waveform
Using the Two-Tone menu, you can define, and modify user–defined Two–Tone waveforms. Two–Tone 
waveforms are generated by the dual arbitrary waveform generator.

The section Using Two–Tone Modulation on page 297 teaches you how to perform the following tasks:

• Creating a Two–Tone Waveform on page 298

• Viewing a Two–Tone Waveform on page 299

• Minimizing Carrier Feedthrough on page 300

• Changing the Alignment of a Two–Tone Waveform on page 301

Creating a Custom Multitone Waveform
Using the Multitone Setup table editor, you can define, modify and store user–defined multitone 
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 303 teaches you how to perform the following tasks:

• Initializing the Multitone Setup Table Editor on page 303

• Configuring Tone Powers and Tone Phases on page 304

• Removing a Tone on page 304

• Generating the Waveform on page 304

• Configuring the RF Output on page 304

Using Two–Tone Modulation
In the following sections, this chapter describes the two–tone mode, which is available only in Agilent 
X- Series vector signal generators with Option 430:

• Creating a Two–Tone Waveform on page 298

• Viewing a Two–Tone Waveform on page 299

• Minimizing Carrier Feedthrough on page 300
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• Changing the Alignment of a Two–Tone Waveform on page 301

See also: Saving a Waveform’s Settings & Parameters on page 139

NOTE For more information about two–tone waveform characteristics, and the two–tone standard, 
download Application Note 1410 from our website by going to http://www.agilent.com and 
searching for “AN 1410” in Test & Measurement. 

Two–Tone Modulation Softkeys

Creating a Two–Tone Waveform

This procedure describes how to create a basic, centered, two–tone waveform.

1. Preset the signal generator.

2. Set the signal generator RF output frequency to 6 GHz.

3. Set the signal generator RF output amplitude to –10 dBm.

Becomes active when a change is made to the Freq 
Separation or Alignment Softkeys. Becomes active when Two Tone is 

turned On.

Active when 
Two–Tone enabled.
For softkey usage, 
see page 131.

page 229

For details on each key, use key help as described on page 34.

page 303

page 238

see page 131
(Two–Tone’s Arb Setup is similar to the Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi–BBG Sync Setup softkey, and 
> No DAC Over–Range Protection softkey
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4. Press Mode > More > Two–Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two–tone signal is now available at the signal generator RF OUTPUT connector. Figure 12- 1 on 
page 299 shows what the signal generator display should look like after all steps have been 
completed. Notice that the T-TONE, I/Q, annunciators are displayed; the RF ON, MOD ON  are on; and 
the parameter settings for the signal are shown in the status area of the signal generator display.

Figure 12-1

Viewing a Two–Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two–tone waveform and 
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are 
using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 6 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a –10 dBm reference. 

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. 
A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.

7. Set the attenuation to 4 dB, so you’re not overdriving the input mixer on the spectrum analyzer. 

You should now see a two–tone waveform with a 6 GHz center carrier frequency that is similar to 
the one shown in Figure 12- 2 on page 300. You will also see IMD products at 10 MHz intervals above 
and below the generated tones, and a carrier feedthrough spike at the center frequency with carrier 
feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.

Mode > Two–Tone

For details on 
each key, use 
key help as 
described on 
page 34.
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Figure 12-2

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power 
between the tones and their intermodulation distortion products. Before beginning this procedure, it 
is important that a recent I/Q calibration has been performed on the instrument. The procedure for 
performing an I/Q calibration (refer to “I/Q Calibration” on page 194).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about  
100 to 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make 
adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments Off On to On.

3. Press Internal Baseband Adjustments > I Offset and turn the rotary knob while observing the carrier 
feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce 
the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.

7. Turn on waveform averaging.

 

Intermodulation
Distortion

Two–Tone
Channels

Carrier Feedthrough
Distortion

Carrier
Feedthrough

For details on each key, use key help as described on page 34.
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8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which 
should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product. 

You should now see a display that is similar to the one shown in Figure 12- 3 on page 301. Your 
optimized two–tone signal can now be used to measure the IMD products generated by a 
device–under–test. 

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to 
periodically readjust your I and Q offsets to keep your signal optimized.

Figure 12-3

Changing the Alignment of a Two–Tone Waveform

This procedure describes how to align a two–tone waveform left or right, relative to the center 
carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency, 
this alignment typically hides any carrier feedthrough. However, image frequency interference caused 
by left or right alignment may cause minor distortion of the two–tone signal. This procedure builds 
upon the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.

 

Main Marker

Delta Marker

Minimized
Carrier
Feedthrough

For details on each 
key, use key help as 
described on page 34.
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Multitone and Two–Tone Waveforms (Option 430) 
Using Two–Tone Modulation 
NOTE Whenever a change is made to a setting while the two–tone generator is operating 
(Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey 
before the updated waveform will be generated. When you apply a change, the baseband 
generator creates a two–tone waveform using the new settings and replaces the existing 
waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more 
quickly. You should now see a left–aligned two–tone waveform that is similar to the one shown in 
Figure 12- 4.

Figure 12-4

Carrier
Frequency

Upper Tone
Aligned with

Intermodulation
Distortion

Two–Tone
Channels

Carrier
Frequency

For details on each key, use key help as described on page 34.
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 Multitone and Two–Tone Waveforms (Option 430)
Using Multitone Modulation
Using Multitone Modulation

Multitone Modulation Softkeys

Initializing the Multitone Setup Table Editor
1. Press Preset.

2. Press Mode > Multitone

3. Press Initialize Table > Number of Tones > 5 > Enter.

4. Press Freq Spacing > 20 > kHz.

page 304

page 303

This softkey is active if changes have been 
made to the current Multitone waveform in 
the table editor. The softkey must be 
pressed to apply those changes.

page 305

page 305

Active when 
Multitone enabled.
For softkey usage, 
see page 130 page 130

see page 131
(Multitone’s ARB Setup is similar to Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi–BBG Sync Setup softkey, and 
> No DAC Over–Range Protection softkey

For details on each key, use key help as 
described on page 34.
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Multitone and Two–Tone Waveforms (Option 430) 
Using Multitone Modulation 
Figure 12-5 

5. Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at 
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center 
tone.

Configuring Tone Powers and Tone Phases
1. Highlight the value (0 dB) in the Power column for the tone in row 2.

2. Press Edit Table > Edit Item > –4.5 > dB.

3. Highlight the value (0) in the Phase column for the tone in row 2.

4. Press Edit Item > 123 > deg.

Removing a Tone
1. Highlight the value (On) in the State column for the tone in row 4.

2. Press Toggle State.

Generating the Waveform

Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During 
waveform generation, the M-TONE and I/Q annunciators activate and the multitone waveform is 
stored in volatile ARB memory. The waveform is now modulating the RF carrier.

Configuring the RF Output
1. Set the RF output frequency to 100 MHz.

The Random Seed 
softkey that affects the 
Multitone’s phase values 
is not used in the following 
examples and is shown 
for reference, only.

For details on each key, use key help as described on page 34.
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 Multitone and Two–Tone Waveforms (Option 430)
Using Multitone Modulation
2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in 
the Multitone Setup table editor, you must apply the changes before the updated waveform will be 
generated.

From the Multitone Setup table editor, press the following key to apply the changes and generate a 
multitone waveform based on the updated values: Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone 
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on page 
297.

1. Press Load/Store > Store To File.

If there is already a file name from the Catalog of MTONE Files occupying the active entry 
area, press the following keys (see page 35):

Edit Keys > Clear Text

2. Enter a file name (for example, 5TONE) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters (see page 35).

3. Press Enter.

The multitone waveform is now stored in the Catalog of MTONE Files.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a 
multitone waveform file. Similarly, the multitone settings are not stored as part of the 
instrument state. Therefore, in most cases you should save both the instrument states and 
the multitone settings to be able to restore all of your settings later.
 Agilent MXG and EXG X-Series Signal Generators User’s Guide 305



Multitone and Two–Tone Waveforms (Option 430) 
Using Multitone Modulation 
Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s 
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous 
sections, Creating a Custom Multitone Waveform on page 297 and Storing a Multitone Waveform on 
page 305, then preset the signal generator to clear the stored multitone waveform from volatile ARB 
memory.

1. Press Mode > Multitone.

2. Press Load/Store.

3. Highlight the desired file (for example, 5TONE).

4. Press Load From Selected File > Confirm Load From File.

5. Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the 
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 304.
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13  Working in a Secure Environment

If you are using the instrument in a secure environment, you may need details of how to clear or 
sanitize its memory, in compliance with published security standards of the United States Department 
of Defense, or other similar authorities.

For the Series B MXG and EXG instruments, this information is contained in the PDF document 
"Security Features and Document of Volatility". This document is not included in the Documentation 
CD, but it may be downloaded from Agilent’s web site, as described below.

The document includes the following topics:

• Security Terms and Definitions

• Instrument Memory Types

• Memory Clearing and Sanitization (Erase All, Erase and Sanitize All functions)

• Clearing Persistent State information

• Using the Secure Display feature (also documented in “Using Secure Display” on page 308 below)

• Declassifying a Faulty Instrument

How to Obtain the Security Features Document
Step Action

1 Click on or browse to the following URL:

http://www.agilent.com/find/security

2 To locate and download the document, select Model Number "N5182B", “N5181B”, “N5172B” or 
“N5171B”, then click "Submit".

3 Follow the on- screen instructions to download the PDF file.
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  Working in a Secure Environment
Using Secure Display
Using Secure Display
This function prevents unauthorized personnel from reading the instrument display or tampering with 
the current configuration via the front panel. When Secure Display is active, the display is blank, 
except for an advisory message, as shown in Figure 13- 1 below. All front panel keys are disabled.

To set Secure Display, press: Utility > Display > More > Activate Secure Display > Confirm Secure Display.

Once Secure Display has been activated, the power must be cycled to re- enable the display and front 
panel keys.

Figure 13-1 Signal Generator Screen with Secure Display Activated
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14 Troubleshooting

• Display on page 310

• Signal Generator Lock–Up on page 310

• RF Output on page 310

— No RF Output
— Power Supply Shuts Down
— No Modulation at the RF Output
— RF Output Power too Low
— Distortion
— Signal Loss While Working with a Spectrum Analyzer
— Signal Loss While Working with a Mixer

• Sweep on page 314

— Cannot Turn Off Sweep
— Sweep Appears Stalled
— Incorrect List Sweep Dwell Time
— List Sweep Information is Missing from a Recalled Register
— Amplitude Does Not Change in List or Step Sweep

• Internal Media Data Storage on page 315

— Instrument State Saved but the Register is Empty or Contains the Wrong State

• USB Media Data Storage on page 315

— Instrument Recognizes USB Media Connection, but Does Not Display Files

• Preset on page 315

— The Signal Generator Does Not Respond
— Pressing Preset Performs a User Preset

• Error Messages on page 316

• Front Panel Tests on page 317

• Self Test Overview on page 318

• Licenses on page 321

• Contacting Agilent Technologies on page 321

— Returning a Signal Generator to Agilent
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Troubleshooting 
Display 
Display

The Display is Too Dark to Read

Brightness may be set to minimum. Use the figure in “Display Settings” on page 20 to locate the 
brightness softkey and adjust the value so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black. 
Cycle instrument power.

Signal Generator Lock–Up
• Ensure that the signal generator is not in remote mode (the R annunciator shows on the display). 

To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

• Ensure that the signal generator is not in local lockout, which prevents front panel operation. For 
information on local lockout, refer to the Programming Guide.

• If a progress bar appears on the signal generator display, an operation is in progress.

• Preset the signal generator.

• Cycle power on the signal generator.

RF Output

No RF Output
• Check the RF ON/OFF LED (shown on page 5). If it is off, press RF On/Off to turn the output on.

• Ensure that the amplitude is set within the signal generator’s range.

• If the instrument is playing a waveform, ensure that marker polarity and routing settings are 
correct (see “Saving Marker Polarity and Routing Settings” on page 146).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the 
instrument, send the signal generator to an Agilent service center for repair (see “Contacting Agilent 
Technologies” on page 321).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on. 
See also “Modulating the Carrier Signal” on page 48.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the 
I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating 
within the signal generator’s specified limits.
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 Troubleshooting
RF Output
RF Output Power too Low
• If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:

Press Amptd > More 1 of 2 > Amptd Offset > 0 > dB. See also “Setting an Output Offset” on page 105.

• If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:

1. Press Amptd > More > Amptd Ref Off On until Off highlights.

2. Reset the output power to the desired level.

See also “Setting an Output Reference” on page 106.

• If you are using the signal generator with an external mixer, see page 312.

• If you are using the signal generator with a spectrum analyzer, see page 311.

• If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically 
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display 
the sequence header information and recalculate the RMS value (see page 139).

Signal Loss While Working with a Spectrum Analyzer

CAUTION To avoid damaging or degrading the performance of the signal generator, do not exceed 
33 dBm (2W) maximum of reverse power levels at the RF input. See also Tips for 
Preventing Signal Generator Damage on www.agilent.com.

The effects of reverse power can cause problems with the RF output when you use the signal 
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode 
(described on page 102).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some 
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than 
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF output. 
The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO 
feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes. 

See:

• “ALC Off Mode” on page 102

and

• “Power Search Mode” on page 103
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Troubleshooting 
RF Output 
Signal Loss While Working with a Mixer

CAUTION To avoid damaging or degrading the performance of the signal generator, do not exceed 
33 dBm (2W) maximum of reverse power levels at the RF input. See also Tips for 
Preventing Signal Generator Damage on www.agilent.com.

To fix signal loss at the signal generator’s RF output during low–amplitude coupled operation with a 
mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a 
configuration in which the 
signal generator provides a 
low amplitude signal to a 
mixer.

The internally leveled signal 
generator RF output (and ALC 
level) is −8 dBm. The mixer is 
driven with an LO of +10 dBm 
and has an LO–to–RF 
isolation of 15 dB. The 
resulting −5 dBm LO 
feedthrough enters the signal 
generator’s RF output 
connector and arrives at the 
internal detector.

Depending on frequency, it is 
possible for most of this LO 
feedthrough energy to enter the detector. Because the detector responds to its total input power 
regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example, 
the reverse power across the detector is actually greater than the ALC level, which can result in loss 
of signal at the RF output.

Mixer

LO 

ALC Level 
= −8 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
−8 dBm 
ALC level

Detector 
measures 
−5 dBm 
reverse 
power

LO Feedthru 
= −5 dBm

RF Output 
= −8 dBm

LO Level 
= +10 dBm

IF 

Effects of Reverse Power on ALC
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 Troubleshooting
RF Output
The solution at right shows a 
similar configuration with the 
addition of a 10 dB 
attenuator connected between 
the RF output of the signal 
generator and the input of 
the mixer. The signal 
generator’s ALC level 
increases to +2 dBm and 
transmits through a 10 dB 
attenuator to achieve the 
required −8 dBm amplitude 
at the mixer input. 

Compared to the original 
configuration, the ALC level 
is 10 dB higher while the 
attenuator reduces the LO 
feedthrough (and the signal 
generator’s RF output) by 10 
dB. Using the attenuated 
configuration, the detector is exposed to a +2 dBm desired signal versus the −15 dBm undesired LO 
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 
0.1 dB shift in the signal generator’s RF output level.

Mixer

LO 

ALC Level/ 
RF Output 
= +2 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
+2 dBm 
ALC level

Detector 
measures 
−15 dBm 
reverse 
power

LO Feedthru 
= −5 dBm

RF Output 
= −8 dBm

LO Level 
= +10 dBm

IF 

Reverse Power Solution

10 dB 
ATTEN
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Troubleshooting 
Sweep 
Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see 
“Configuring a Swept Output” on page 40). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq 
Sweep > Sweep > Amptd 
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey. 

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too 
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time
1. Press Sweep > More > Configure List Sweep.

2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them. 
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step 
sweep rather than list sweep.

See also “Configuring a Swept Output” on page 40.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. 
Only the current list sweep is available to the signal generator. You can store list sweep data in the 
instrument catalog (see “Loading (Recalling) a Stored File” on page 55).

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep 
type is set to frequency (Freq) or waveform.
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 Troubleshooting
Internal Media Data Storage
Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall 
register 99. If you selected a register number greater than 99, the signal generator automatically saves 
the instrument state in register 99.

See also “Working with Instrument State Files” on page 57.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the 
signal generator; try a different USB media. Refer to http://www.agilent.com/find/mxg for details on 
compatible USB media. 

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which 
locks the keypad. 

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward–compatible SCPI command. To return the signal 
generator to normal use, send the command :SYST:PRESet:TYPE NORM. 

For information on SCPI commands, refer to the SCPI Command Reference.
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Troubleshooting 
Error Messages 
Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query 
error does not generate a device–specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a 
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class 
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors 
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

• Either an attempt is being made to read data from the output queue when no output is either 
present or pending, or

• data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation 
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes 
are also used for self–test response errors. Errors in this class set the device–specific error bit (bit 3) 
in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that 
the instrument detected an error within the GPIB system, within the instrument’s firmware or 
hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s 
execution control block. Errors in this class set the execution error bit (bit 4) in the event status 
register (IEEE 488.2, section 11.5.1). In this case:

• Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of 
its legal input range or is otherwise inconsistent with the device’s capabilities, or

• a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. 
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 
488.2, section 11.5.1). In this case:

• Either an IEEE 488.2 syntax error has been detected by the parser (a control–to–device message 
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data 
element that violates device listening formats or whose type is unacceptable to the device.), or

• an unrecognized header was received. These include incorrect device–specific headers and 
incorrect or unimplemented IEEE 488.2 common commands.
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 Troubleshooting
Front Panel Tests
Front Panel Tests

Set all display pixels to the selected color. 
To return to normal operation, press any key.

Blink RF On/Off, Mod on/Off, and More LEDs

Correct operation:
Full CCW = –10
Full CW = 10

Displays a keyboard map.  
As you press a key, the map indicates the key location.

For details on each key, use key help 
as described on page 34.
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Troubleshooting 
Self Test Overview 
Self Test Overview
The self test is a series of internal tests that checks different signal generator functions. The self test, 
is also available by via the remote web interface. For more information on the Web- Enabled MXG, 
refer to the Programming Guide.
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 Troubleshooting
Self Test Overview
For details on each key, use key help 
as described on page 34.

Automatically runs 
diagnostic self test. 

Self Test Summary 
displays current status.

Opens a table in which user 
selects specific tests and 
view details in Test Editor 
display.

Utility > Instrument Info

Displays detailed 
information of 
highlighted test. Refer 
to page 34

Executes highlighted 
operation.

Executes all selected 
operations.

Selects or deselects 
highlighted operation.

Selects or deselects 
all operations.

Runs a loop of 
selected tests until a 
failure occurs.

Opens the Go To 
Menu. Adds 
navigation keys to the 
self test menu.
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Troubleshooting 
Self Test Overview 
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 Troubleshooting
Licenses
Licenses

A Time–Based License Quits Working
• The instrument’s time or date may have been reset forward causing the time–based license to 

expire.

• The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time–based licenses.

See page 22 for details and cautions on setting time and date.

Cannot Load a Time–Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time–based licenses.

See page 22 for details and cautions on setting time and date.

Contacting Agilent Technologies
• assistance with test and measurements needs, and information on finding a local Agilent office: 

http://www.agilent.com/find/assist

• accessories or documentation: http://www.agilent.com/find/X- Series_SG.

• new firmware releases: http://www.agilent.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model 
number and full serial number. With this information, the Agilent representative can 
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent

Use the following steps to return a signal generator to Agilent Technologies for servicing:

1. Gather as much information as possible regarding the signal generator’s problem. 

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific 
to your geographic location. If you do not have access to the Internet, contact your Agilent field 
engineer. 

After sharing information regarding the signal generator and its condition, you will receive 
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar 
packaging to properly protect the signal generator.
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Contacting Agilent Technologies 
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Glossary

A

Active Entry The currently selected, and 
therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive 
white Gaussian noise

B

BBG Media Baseband generator media. Volatile 
memory, where waveform files are played or 
edited.

BNC Connector Bayonet Neill- Concelman 
connector. A type of RF connector used to 
terminate coaxial cable. 

C

CCW Counterclockwise

C/N Carrier- to- noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 42), the 
time that the signal is settled and you can make 
a measurement before the sweep moves to the 
next point.

E

EVM Error vector magnitude; the magnitude of 
the vector difference at a given instant between 
the ideal reference signal and the measured 
signal.
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F

Filter factor Alpha The filter’s alpha coefficient. 
It is only valid for root nyquist and nyquist 
filters.

Filter Factor BbT The filter’s 
bandwidth- bit- time (BbT). It is only valid for a 
Gaussian filter (similar to alpha). BbT is defined 
by the GSM standard as 0.3 and by the DECT 
standard as 0.5.

G

Gaussian filter The Gaussian filter does not 
have a zero Inter- Symbol Interference (ISI). 
Wireless system architects must decide just how 
much of the ISI can be tolerated in a system and 
combine that with noise and interference. The 
Gaussian filter is gaussian shaped in both the 
time and frequency domains, and it does not 
ring like the root nyquist filters do. The effects 
of this filter in the time domain are relatively 
short and each symbol interacts significantly (or 
causes ISI) with only the preceding and 
succeeding symbols. This reduces the tendency 
for particular sequences of symbols to interact, 
which makes amplifiers easier to build and more 
efficient.

GPIB General purpose interface bus. An 8- bit 
parallel bus common on test equipment.

H

Hardkey A labeled button on the instrument.

I

IF Intermediate frequency

Int Media Internal media. Non−volatile signal 
generator memory, where waveform files are 
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stored.

 
 
IP Internet protocol. The network layer for the 
TCP/IP protocol suite widely used on Ethernet 
networks.

L

LAN Local area network

LO Local oscillator

LXI LAN eXtension for Instrumentation. An 
instrumentation platform based on industry 
standard Ethernet technology designed to 
provide modularity, flexibility, and performance 
to small-  and medium- sized systems. See also 
http://www.lxistandard.org

M

Modulation Format Custom modulation, Two 
Tone, or Multitone.

Modulation Mode Dual ARB, Custom 
modulation, Two Tone, or Multitone.

Modulation Standard Refers to a Cellular 
standard format (i.e. NADC, PDC, PHS, etc.).

Modulation Type Refers to the various I/Q 
constellation types (i.e. PSK, MSK, FSK, C4FM, 
etc.)

N

Non−volatile That which survives a power cycle 
(such as files stored in USB media).

Nyquist filter Also referred to as a cosine filter. 
These filters have the property that their 
impulse response rings at the symbol rate. 
Adjacent symbols do not interfere with each 
other at the symbol times because the response 
324
equals zero at all symbol times except the center 
(desired) one.

P

Persistent That which is unaffected by preset, 
user preset, or power cycle.

Point- to- point Time In a step sweep (page 42), 
the sum of the dwell time, processing time, 
switching time, and settling time.

R

Rectangular filter Also referred to as a ideal 
low pass filter. These filters have very steep 
cut- off characteristics. The pass band is set to 
equal the symbol rate of the signal. Due to a 
finite number of coefficients, the filter has a 
predefined length and is not truly “ideal”. The 
resulting ripple in the cut- off band is effectively 
minimized with a Hamming window. This filter 
is recommended for achieving optimal ACP. A 
symbol length of 32 or greater is recommended 
for this filter.

Root Nyquist filter Also referred to as a Root 
cosine filter. These filters have the property that 
their impulse response rings at the symbol rate. 
Adjacent symbols do not interfere with each 
other at the symbol times because the response 
equals zero at all symbol times except the center 
(desired) one. Root nyquist filters heavily filter 
the signal without blurring the symbols together 
at the symbol times. This is important for 
transmitting information without errors caused 
by ISI. Note that ISI does exist at all times 
except the symbol (decision) times. A cascade of 
two of these filters has the transfer function of 
a Nyquist filter. One is in the transmitter, the 
other in the receiver, so that the system taken 
as a whole has the zero- ISI properties of an ISI 
filter.

RMS Root mean square. A time- varying signal’s 
effective value (the equivalent DC voltage 
required to generate the equivalent heat across 
a given resistor). For a sinewave, RMS = 0.707 x 
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peak value. 

S

Softkey A button located along the instrument’s 
display that performs whatever function is 
shown next to it on that display.

 
T

TCP Transmission control protocol. The most 
common transport layer protocol used on 
Ethernet and the Internet.

Terminator A unit indicator (such as Hz or 
dBm) that completes an entry. For example, for 
the entry 100 Hz, Hz is the terminator.

Type- N Connector Threaded RF connector used 
to join coaxial cables.

U

USB Universal serial bus. See also 
http://www.usb.org

User FIR Selects a user- defined set of 
coefficient values. Each line in the FIR values 
table contains one coefficient value. The number 
of coefficient values listed must be a multiple of 
the selected oversampling ratio. Each coefficient 
applies to both I and Q components.

V

Volatile That which does not survive a power 
cycle (such as files stored in BBG media).
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Symbols
, 198
ΦM

annunciator, 9
dc offset, removing, 67
hardkey, 63
softkeys, 63, 67

# points softkey, 43
# Skipped Points softkey, 150

Numerics
10 MHz OUT connector, 14
100Base- T LAN cable, 25
128 QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
1410, application note, 298
16- Lvl FSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
16QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
256 QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
2- Lvl FSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
32QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
430, option

multitone mode, 303
two- tone, 297

4- Lvl FSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
4QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
628, error, 184
64QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
651/652/654, option

description, 4
multitone mode, 303
two- tone mode, 297

670/671/672, option
description, 4

8557D GPIB only softkey, 27, 28
8648A/B/C/D GPIB only softkey, 27, 28
8656B,8657A/B GPIB only softkey, 27, 28
8- Lvl FSK softkey, 247, 251, 253, 254, 255, 256, 257, 261

A
AC power receptacle, 12
ACP, 244
Activate Secure Display softkey, 20
active

entry, 323, 9
Active High softkey, 163
Active Low softkey, 163
Add Comment To softkey, 57
additive white Gaussian noise. See AWGN
address, GPIB, 24
Adjust Phase softkey, 37, 39
Adjustable doublet softkey, 114
adjustments

I/Q, 127, 192
quadrature, 192
real- time phase noise, 241

advance, segment, 165
Advanced Settings softkey, 25
Aeroflex softkey, 27, 28
Agilent MXG

modes of operation, 4
Agilent sales and service offices, 321
ALC

hold, 146, 147
OFF annunciator, 9
off mode, 101
softkeys, 37, 39, 150

alc
setting, 39

All softkey, 51
Alpha, 323
AM

annunciator, 9
external source, 67
hardkey, 63
softkeys, 63
wideband, 67

amplitude
display area, 10
hardkey, 37, 39
LF output, 70, 71
modulation, 63
offset, 104
reference, 105
setting, 37, 39
troubleshooting sweep, 314

AMPTD hardkey, 37, 39
analog modulation, 4, 63

configuring, 64, 69
angle, quadrature, 127
annunciators, 9
APCO 25 w/C4FM softkey, 246, 250
APCO 25 w/CQPSK softkey, 246, 250
apodization settings, FIR filter, 205, 288
application notes

1410, 298
Apply To Waveform softkey, 150
ARB

definition, 323
player, dual, 130
softkeys, 130, 161, 230, 231, 232, 233, 238
waveform clipping, 169

arb, 244
Arb Custom

FIR filters, 281, 287
Arb Segment softkey, 56
Arb Sequence softkey, 56
arb setup

softkey, 208
ARMED annunciator, 9
arrow keys, 35
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ASK Depth softkey, 247, 251, 253, 254, 255, 256, 257, 261
ASK softkey, 247, 251, 253, 254, 255, 256, 257, 261
ATTEN HOLD annunciator, 9
Atten/ALC Control softkey, 37, 39
Auto softkeys

(DHCP/Auto- IP), 25
Auto, 101
Recall, 111

AUTOGEN_WAVEFORM file, 244
auto- IP, 25
Auto- IP softkey, 25
Automatically Use USB Media If Present softkey, 51
AUX I/O connector, 17
Auxiliary Software Options softkey, 30
AWGN

adding, 229, 9
definition, 323, 229
softkeys, 235

AWGN softkeys, 230, 231, 232, 233

B
backspace hardkey, 35
bandwidth ratio, 235
Bandwidth softkey, 235
baseband, 17

aligning signals at, 146
clipping, 169
frequency offset

softkey location, 184
, 184
I/Q output connectors, 15
memory, 130
noise, 229, 9
quadrature adjustment, 192
real time I/Q AWGN, 230, 231, 232, 233, 235
softkey, 184, 191
waveforms convert to analog, 179

baseband frequency offset
DAC over range & scaling, 186
softkey, 184

baseband generator, 244
custom arb mode, 4
dual arb mode, 5
multiple BBG synchronization, 209, 4, 5, 303
two- tone mode, 297

BB GEN, 191
BBG

media, 130, 132, 323
Memory softkey, 56
routing, 191
Segments softkey, 51, 139

BBG sync, 209
configure setup, 213
equipment setup, 213

resynchronization, 215
system, 212
trigger setup, 212

BbT, 323
Binary softkey, 51
bit file editor, using, 252
bits per symbol, equation, 292
Bk Sp hardkey, 35
Bluetooth softkey, 246, 247, 250, 251, 253, 254, 255, 256, 257, 261
BNC, 323
Bright Color softkey, 20
brightness adjustment, 20
Brightness softkey, 20
Buffered Trig softkey, 163
Build New Waveform Sequence softkey, 135, 159
Burst Envelope softkey, 189
Bus softkey, 41

C
C/N, 323
C4FM softkey, 247, 251, 253, 254, 255, 256, 257, 261
cables

crossover, 25
multi- BBG sync, 212

cables, 100Base- T LAN, 25
Calculate softkey, 139
calibration

I/Q, 194
softkey, 194

Calibration Type softkey, 194
Cancel hardkey, 7
carrier

bandwidth, 229
configuring, 38
feedthrough, 127
modulating, 48
softkeys, 230, 231, 232, 233
to noise ratio, 229

Carrier Bandwidth softkey, 230, 231, 232, 233
carrier feedthrough, minimizing, 300
Carrier Softkey, 230, 231, 232, 233
Carrier to Noise softkey, 230, 231
Carrier+Noise softkey, 230, 232, 233
Catalog Type softkey, 51, 52, 56, 139
catalog, state files, 60
ccw, 323
CDPD softkey, 246, 247, 250, 251, 253, 254, 255, 256, 257, 261
ceiling function, bits per symbol, 292
Channel Band softkey, 37, 39
channel bandwidth, 235
Channel Number softkey, 37, 39
circular clipping, 173, 176
classified. See security
Clear softkeys
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Error Queue(s), 62
Header, 139
Text, 35

clipping
circular, 173, 176
rectangular, 174, 177
softkeys, 169

clock, sample rate, 17
coefficient values, entering, 199, 284
color palette, display, 20
comments, adding & editing (instrument state), 58
component test, 244
Config Type softkey, 25
Configure softkeys

Cal Array, 83
List Sweep, 41, 44
Step Array, 83, 41, 43

Confirm Load From File softkey, 55
Connection Monitoring softkey, 25
Connection Type softkeys

Sockets, 86
USB, 86
VXI- 11, 86

connectors
external triggering source, 166, 168
front panel, 5
rear panel

n5161a, 12
, 42

Continuous softkey, 163
continuous step sweep example, 47
continuous wave

description, 4
continuous wave output, 38
contrast adjustment, 20
Contrast softkey, 20
Copy & softkeys

Play Sequence, 55
Select User Flatness, 55

Copy softkeys
All Files, 56
File, 51, 56

correction array (user flatness), 88
viewing, 89
See also user flatness correction

corrections, internal channel, 91
cosine filter. See nyquist filter
Create Directory softkey, 51, 56
crossover cable, 25
custom

multicarrier TDMA waveforms
creating, 278

TDMA digital modulation, 265
custom arb, 220, 244
Custom ARB softkeys, 220, 245, 249

custom arb waveform generator, 4
custom mode, 244
custom modulation

adding to a waveform, 265
waveform, adding to, 265

cw, 323
CW (no modulation) softkey, 44
CW mode

description, 4

D
DAC over range error, 179, 184
DAC over range protection

baseband frequency offset, 186
phase noise, 242

Dark Color softkey, 20
data

entry softkeys, 35, 307
files, 50–57
removing, 307
serial, synchronizing, 17

comments, adding and editing, 58
troubleshooting, 315, 61
using, 50

data files
creating, 253
modifying, 256

date, setting, 22
dc offset, 127
dc offset, removing, 67
DCFMΦ/DCfM Cal softkey, 65
Declassifying faulty instrument, 307
DECT softkey, 246, 250
Default Gateway softkey, 25
default settings

restoring, 21, 25, 194
system, restoring, 34

Default softkey, 246, 250
delay

I/Q, 192
multiple BBG sync, 212

Delete softkeys
All Regs in Seq, 57, 132, 51, 57, 111, 135, 159
File, 51, 53, 56, 61
Item, 44
Row, 44
Selected Waveform, 135, 159, 57
Waveform Sequence, 159

description & plots, phase noise, 239
DETHTR annunciator, 10
Device softkey, 37, 39
DHCP, 25, 323
DHCP softkey, 25
Diff Mode softkeys, 192
differential encoding, 290
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differential encoding, bits per symbol, 292
differential state map, bits per symbol, 292
DIGBUS annunciator, 10
digital bus, 16
digital modulation

formats, 4
IQ map, QAM, 291
multitone, 303–306
TDMA, 265
two tone, 297–302

digital modulation type
modifying, 268

digital operation, 129, 221
digital signal to analog waveform, 179
display

blanking, 307
error message area, 11
overview, 5, 9
secure, 307, 20, 11, 19, 35, 150
tests, 317, 11, 310

Display softkeys
Case, 35
display, 19
Waveform And Markers, 150

Displayed Case softkeys, 35
distortion, troubleshooting, 311
DNS Server Override softkey, 25
DNS Server softkey, 25
documentation, xv
Domain Name softkey, 25
doublet

adjustable, 116
softkeys, 114
trigger, 116

Dual ARB
FIR table editor, 199, 204
real- time modulation, 208
user- defined FIR, 199

dual ARB
multi- BBG sync, 209
player, 130
real- time noise, 229
softkeys, 131, 230, 231, 232, 233, 238

dual arb, 244
dual ARB player, 5
Dual ARB Real- Time

filters, 198
dual arbitrary waveform generator, 5
dual display, power meter, 74
dwell time, 44, 323
Dwell Type softkey, 44
dwell, troubleshooting, 314
Dynamic DNS Naming softkey, 25
Dynamic Hostname Services softkey, 25

E
E4428C, E4438C softkey, 27, 28
E442xB, E443xB softkey, 27, 28
E8241A, E8244A, E8251A, E8254A softkey, 27, 28
E8247C, E8257C, E8267C softkey, 27, 28
E8257D, E8267D softkey, 27, 28
EDGE

custom digital modulation, predefined, 265
EDGE softkey, 246, 250
Edit softkeys

Description, 139
Noise RMS Override, 139
Repetitions, 159, 139
Selected Waveform Sequence, 135, 159

Editing Keys softkey, 35
Editing Mode softkey, 35
editor, bit file, 252
Enable/Disable Markers softkey, 135, 159
Enter Directory softkey, 55
entry, active, 323
equalization

filter, 196
equipment setup, 213
equipment, user flatness correction, 84, 85
Erase All, 307
Erase and Sanitize All, 307
ERR annunciator, 10
Error hardkey, 62
error messages, 62

DAC over range, 179, 184
display area, 11
message format, 62
types, 316

Esc hardkey, 7
EVENT

connector, AUX I/O, 17, 16, 145
output jitter, 161, 145

EVM, 323
EVM error, 127
example

Waveform license, Opt 25x
adding a waveform, 226
locking a slot, 226

examples
FIR filters

creating, 199, 281, 283
modifying, 204, 287

LF output, configuring, 69
Execute Cal softkey, 194
EXT CLOCK connector, 16
EXT REF annunciator, 9, 10
Ext softkeys

Delay, 164
Ext, 41
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I/Q Output, 189, 190
Pulse, 114
Source, 164

extension, file, 55
external

I and Q signals, 191
media, 61, 315, 67
reference oscillator, using, 38
trigger source, 166, 168

external leveling, 93–100
softkeys, 93

external leveling, configuring, 97
External softkeys

External, 189
Input, 192, 126
Output, 192

F
factory defaults, restoring, 21, 25, 194
features, 2
feedthrough, 127
feedthrough, carrier, minimizing, 300
File hardkey, 51, 60
file headers

creating, 139
editing, 141, 142
viewing a different file, 143

files
catalog. See data storage
extensions, 55
working with, 50

filter
equalization, 196
real- time modulation

softkey location, 208
user, equalization, 196

filter, interpolator, 179
filters

finite impulse response, 198, 281
FIR, 198, 281
gaussian, loading default, 205, 288
nyquist, selecting, 269

filters Dual ARB, 198
finite impulse response filters

using, 198, 281
FIR filter

apodization settings, 205, 288
Hamming, 205, 288, 205, 288
Kaiser, 205, 288
window settings, 205, 288

FIR filters
Arb Custom, 281
creating, 199, 281, 283
modifying, 204, 287
storing, 203, 286

using, 198, 281
FIR table editor

accessing, 199, 283
Arb Custom, 287
coefficients, duplicating, 201, 285, 199, 284, 206, 289
Dual ARB, 199, 204
files, loading, 205, 288

creating, 199, 281, 283
modifying, 204, 287
storing, 203, 207, 286, 290

oversample ratio, setting, 202, 285
firmware

upgrading, 23, 321
First Mkr Point softkey, 150
First Sample Point softkey, 150
Fixed softkey, 101
flat bandwidth, 235
flatness correction. See user flatness correction
Flatness softkey, 83
FM

annunciator, 10
dc offset, removing, 67
external source, 67
hardkey, 63
softkeys, 63

Free Run softkey, 41, 108, 163
Free- Run softkey, 114
Freq Dev softkey, 247, 251, 253, 254, 255, 256, 257, 261
FREQ hardkey, 37, 39
Freq softkeys, 83
frequency

display area, 9
hardkey, 7, 8, 37, 39
LF output, 70

start and stop, swept- sine, 71
modulation, 63, 106
offset, 104, 184
reference, 105
setting, 37, 39, 37, 39

frequency units, 37
front panel

disabling keys, 307, 9
I/Q inputs, using, 127
knob resolution, 22
overview, 5
tests, 317

FSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
FTP Server softkey, 26
fundamental operation See basic operation

G
Gated softkey, 114, 163
gated triggering, 164, 166
Gaussian

definition, 323
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gaussian filter, loading default, 205, 288
Gaussian. See AWGN
glossary, 323
Go To Default Path softkey, 51, 53, 61
Goto Row softkey, 44, 51
GPIB

connector, 14
definition, 323
setup, 24

Address, 24
Setup, 24

green LED, 8
GSM softkey, 246, 250
guides, content of, xv

H
hardkeys

definition, 323
help on, 34
overview, 5
See also specific key

header utilities softkeys, 139
Help hardkey, 7, 34
Hostname softkey, 25
hostname, setting, 25
HP 3300A, emulating, 111

I
I connector, 8
I Offset softkey, 192
I OUT connector, 15
I/O Config softkey, 19
I/Q

adjustments, 127, 192
front panel inputs, using, 127, 191
Int Equalization Filter softkeys location, 197
modulation, 126, 188
optimizing, 190
rear panel outputs, 15, 190
signal path, optimizing, 190, 146, 197, 126, 189–195
waveform, clipping, 169

ideal low- pass filter. See rectangular filter
IF, 323
images, 127
impairments

I/Q adjustments, 127
impairments, real- time

phase noise, 237
Import Waveform softkey, 159
improve non- harmonics, 37
Incr Set hardkey, 8
information, removing from memory, 307
Insert softkeys

Insert, 135, 44
Row, 44

Waveform, 135
Install Assembly softkey, 31
Install licenses softkey, 55
installation guide content, xv
instrument

firmware, upgrading, 23
softkeys

Adjustments, 19
Info, 19
Options, 30
associating with waveform, 58
files, 57, 60
register. See data storage
softkey, 56

Int Equalization Filter
softkeys, 197

int media, 323
Int Phase Polarity softkey, 189
interface

GPIB, 24
LAN, 25

internal
reference oscillator, using, 23

Internal Baseband Adjustments softkey, 192
internal media, 61
Internal Storage to USB softkey, 56
Internal/USB Storage Selection softkey, 51
interpolator filter, 179
IP

Address softkey, 25
address, setting, 25
definition, 324

IQ map, QAM modulation, 291

J
jitter on EVENT output, 161

K
keyboard, using, 111
keys

disabling, 307
front panel, 5
help on, 34
numeric, 6
test, 317
See also specific key

knob, 8, 22, 35

L
L annunciator, 10
LAN

connector, 14
definition, 324
Services Setup softkey, 24
setup, 25
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Setup softkey, 24

Last Mkr Point softkey, 150
Last softkey, 21
LEDs, 8

blink test, 317
front panel, 8
modulation, 49

leveling
external, 93–100
turn off ALC, 101

LF Out, 69
LF output

amplitude, 70, 71
configuration example, 70, 71
description, 69
frequency, 70
source

function generator, 71
internal modulation monitor, 70
start frequency, 71

waveform, 64, 69, 71
LFO. See LF output
licenses

manager, 29
service software, 29
time- based, 22, 321
viewing, 29
waveform, 29

line power (green) LED, 8
linear sweep, 42
list mode values, 45
List softkey, 51
list sweep

parameters, 45
status information, 45
troubleshooting, 314
using, 44
waveform, 46

listener mode annunciator, 10
LO, 324
Load From Selected File softkey, 53, 55
Load List softkey, 55
Load softkeys

All From Int Media, 132
Cal Array From Step Array, 83
From Selected File, 54, 55
Load/Store, 44, 54, 55
Segment From Int Media, 132, 55

Load/Store softkey, 44, 53, 55
Local hardkey, 7
lock up, troubleshooting, 310
logarithmic sweep, 42
low frequency output. See LF output
low spurs, 37
LVDS compatibility with the PXB, 3

LXI, 324

M
manual control, sweep, 48
Manual softkey, 101
Manual softkeys

Config Settings, 25
Manual, 25, 41
Point, 41

manuals, content of, xv
Marker softkeys, 150
markers, aligning signal, 146
markers, waveform, 145–161
media

BBG, 323
erasing, 307
Flash Drive, 61
int, 323
storage, 61
types, 130, 307
USB, 61, 315

memory
erasing data from, 307
See also media

menu keys, 6
messages, error, 316
messages, warning

Opt 25x Licensing, 228
mirror table, duplicating coefficients, 201, 285
mixer, troubleshooting signal loss, 312
Mod On/Off hardkey, 7, 48, 49
Mod On/Off, Option UNT, 63
Mod Type Softkeys, 247, 251, 253, 254, 255, 256, 257, 261
Mode hardkey, 131, 230, 231, 232, 233, 235, 238
mode, modulation, 324
modes of operation, 4
Modulated softkey, 101
modulation

AM, 63
analog, 4

configuring, 64, 69
, 10
carrier signal, 48
digital, 4
external source, using, 67
FM, 63
generating, 48
I/Q, 126, 188
phase, 63, 4, 113
real- time filter, softkeys, 208
simultaneous, 50
troubleshooting, 310

Modulator Atten softkey, 235
monochrome display, setting, 20
Monochrome softkey, 20
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MSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
MULT annunciator, 10
multi- BBG sync, 209

configure setup, 213
equipment setup, 213
resynchronize, 215
system delay, 212
trigger setup, 212

multicarrier setup
APCO 25 w/C4FM, 278
Bluetooth, 278
CDPD, 278
DECT, 278
EDGE, 278
GSM, 278
NADC, 278
PDC, 278
TETRA, 278

multicarrier setup softkeys, 278
multicarrier TDMA waveforms

creating, 278
multicarrier, Default softkey. See quick setup, Default 
softkey, settings
multiplier, using, 106
multitone, 244, 303–306
multitone mode, 4, 5
Multitone softkeys, 303
multitone waveform, setup, 297

N
NADC softkey, 246, 250
Name And Store softkey, 159
Next REG softkey, 111
Next SEQ softkey, 111
No action softkey, 55
No Retrigger softkey, 163
noise, 229
noise bandwidth factor, 229
Noise Bandwidth softkey, 230
Noise Mux softkeys, 232, 233
Noise softkey, 230, 232, 233
non- harmonics, 37
non- volatile memory, 130
non- volatile, definition, 324
number keys, 35
numeric keypad, 6
nyquist filter

definition
nyquist filter, selecting, 269

O
OFFS annunciator, 10
offset, 127
offsets

baseband frequency, 184

I/Q, 192
output, using, 104

on/off switch, 8
operation

modes of, 4
operation, basic, 33
operation, remote, 24
optimization, I/Q, 126, 189
option

430
multitone mode, 303
two tone mode, 297

Option U01, 91
internal channel correction, 91

Option UNT
Mod On/Off hardkey, 63

options
651/652/654

description, 4
multitone mode, 303
two- tone mode, 297

, 4
enabling, 19, 29
resource, 3
UNT, 4

Options 250- 259, 221
Options Info softkey, 30
oscillator, external reference, 38
oscillator, internal reference, 23
Output Blanking softkey, 37, 39
Output Mux softkeys, 230
output, swept, 40
over range error, DAC, 179, 186, 242
overshoot, 179
overview, signal generator, 1

P
Page Up hardkey, 6
parameters, saving a waveform’s, 139
path delay, 127
PATT TRIG IN connector, 16
Patt Trig In softkeys, 164
PDC softkey, 246, 250
peak- to- average power, reducing, 173
performance, optimizing, 73
persistent settings

definition, 324
resetting, 34, 21

phase noise
adjustments, 241
DAC over range & scaling, 242
description & plots, 239
impairments, 237
softkeys, 238

Phase Ref Set softkey, 37, 39
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phase skew, 127
PHS softkey, 246, 250
pixel test, 317
Plot CDDF softkey, 178
PM Config

Calibrate Sensor, 86
Zero Sensor, 86

PM Config softkeys
Connection Type, 86
PM VXI- 11 Device Name, 86

Point Trigger softkey, 41
point- to- point time, 324
polarity, external trigger, 164
polarity, marker, setting, 158
power

meter, 82, 87
on, settings, 21
peak- to- average, reducing, 173
receptacle, 12
search, 102, 104, 84, 85, 37, 39, 19, 21, 101, 310, 8
troubleshooting, 311
user settable, maximum, 39

Power Control Mode softkeys, 231
power meter

configuration, 87
U2000 Series, 87

dual display, 74
power meter configuration sofkeys. See PM Config soft-
keys
power meter sofkeys. See PM Config softkeys
Power Search Reference softkey, 101
Power Search References, 102
Power softkeys

On, 21, 19
Search, 101

power units, 37
preferences, setting, 19
preset

hardkey location, 7
settings, 21
troubleshooting, 315
using, 34

Preset softkeys
Language, 21, 44, 83
Preset, 21

Prev REG softkey, 111
Prev SEQ softkey, 111
Proceed With Reconfiguration softkey, 25, 26
programming guide content, xv
protection, DAC over range

baseband offset frequency, 186
phase noise impairment, 242

PSK softkey, 247, 251, 253, 254, 255, 256, 257, 261
pulse

annunciator, 10

characteristics, 115, 13
marker, viewing, 155, 113
narrow, 101
sync signal, 42
video signal, 42

Pulse hardkey, 114
pulse modulation, 4
Pulse softkeys, 42, 114
Pulse/RF Blank softkey, 150
PWT softkey, 246, 250

Q
Q connector, 8
Q Offset softkey, 192
QAM modulation IQ map, 291
QAM softkey, 247, 251, 253, 254, 255, 256, 257, 261
quadrature adjustment, 192
quadrature angle, 127
Quadrature Angle Adjustment softkey, 126, 192
queue, error, 62
quick setup

Default softkey
settings, 246, 250

Quick Setup Softkeys, 246, 250

R
R annunciator, 10
raised cosine filter. See nyquist filter
real time, 220, 244
real- time

AWGN
softkeys, 230, 231, 232, 233

I/Q Baseband AWGN softkeys, 235
modulation filter, 208
noise, 229
phase noise, 237

adjustments, 241
DAC over range & scaling, 242
description & plots, 239
impairments, 237
softkeys, 238

real- time AWGN,bandwidth ratio, 235
real- time AWGN,channel bandwidth, 235
real- time AWGN,flat bandwidth, 235
real- time modulation

Dual ARB, 208
real- time modulation filter

softkey, 208
rear panel

I/Q outputs, 190
overview

n5161a, 12
Recall hardkey, 57
Recall keys

hardkey, 111
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Instrument State, 51, 55
Reg, 111
State, 55

recall register, troubleshooting, 314
receiver test, 244
rectangular clipping, 174, 177
rectangular filter

definition, 324
REF annunciator, 10
REF IN connector, 13
Ref Oscillator Ext Bandwidth key, 38
Ref Oscillator Ext Freq key, 38
Ref Oscillator Source softkey, 37, 39
Ref Oscillator Tune key, 23
reference oscillator tune, internal, 23
reference oscillator, external, 38
reference, using, 105
references, content of, xv
regrowth, spectral, 172
remote interface, emulate HP 3300A, 111
Remote Language softkey, 24, 27, 28
remote operation annunciator, 10
remote operation preferences, 24
Remove Assembly softkey, 31
Rename File softkey, 51
Rename Segment softkey, 132
Reset & Run softkey, 163
Restart on Trig softkey, 163
Restore softkeys

LAN Settings to Default Values, 25
System Settings to Default Values, 21

resynchronize, multi- BBGs, 215
Return hardkey, 8
Reverse Power Protection softkey, 21
Revert to Default Cal Settings softkey, 194
RF

blanking
marker function, 156
settings, saving, 146

hardkey, 7
output

configuring, 38, 7
leveling, external, 93–100
troubleshooting, 310

RF During Power Search softkey, 101
RF Output softkey, 189, 190
RFC NETBIOS Naming softkey, 25
ringing, 179
ripple, 179
RMS, 324
RMS softkey, 101
Rohde & Schwarz softkey, 27, 28
roort, 324
root cosine filter. See root nyquist filter
root mean square, 324

Root Nyquist Filter
definition, 324

root nyquist filter
definition, 324

rotary knob, 35
Route Connectors softkey, 41, 114
Route To softkeys, 42, 114
routing

I/Q, 126, 189
marker

ALC hold, 147
RF blanking, 156
saving settings, 146

RPG test, 317
runtime scaling, 181

S
S annunciator, 10
sales, Agilent offices, 321
sample rate clock, 17
sample rate softkey, 161
Save hardkey, 57
SAVE Seq Reg softkey, 57
Save Setup To Header softkey, 139
Scale Waveform Data softkey, 178
scaling softkeys, 178
SCPI

enabling, 26
reference content, xv
softkey, 27, 28

screen saver settings, 20
Screen Saver softkey, 20
search, power, 102
secure

display, 307
security, 307
Security softkey, 51
Segment Advance softkey, 163
segment advance triggering, 164
segments

advance triggering, 165
file headers, 139
loading, 132
softkeys, 132

Select hardkey, 35
Select Seq softkey, 111
Select softkeys

Color Palette, 20
Different Header, 139, 143
Header, 139
Internal File(s) to Copy to USB, 56
Reg, 57
Seq, 57
Waveform, 44

self test, 318
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Sequence softkey, 51, 139
sequences

editing, 137
file headers, 139
marker control, 158
playing, 138
waveform, 135

serial data, synchronizing, 17
server, enabling, 26
service

Agilent offices, 321
guide content, xv
request annunciator, 10

Set Marker softkeys, 150
settings, persistent, 324
settings, phase noise, 241
Show softkeys

Alpha Table, 35
Waveform Sequence, 135, 159

signal generator
modes, 4

Signal Studio, 3
signal studio licenses, 29
sinewave, 324
Single softkey, 163
Single Sweep softkey, 41
skew, I/Q, 192
Sockets SCPI softkey, 26
sockets, enabling, 26
softkeys

definition of, 325
help on, 34
label area, 11, 6
See also specific key

source settled signal, 42
Source Settled softkey, 42, 114
Span softkey, 101
Specify Default Storage Path for User Media softkey, 51
spectral regrowth, 172
spectrum analyzer, troubleshooting signal loss, 311
square root raised cosine filter. See root nyquist filter
Square softkey, 114
standard, modulation, 324
standby (yellow) LED, 8
State softkey, 51
states, persistent, 324
step array (user flatness), 88

See also user flatness correction
Step Dwell softkey, 43, 108
Step Spacing softkey, 43
step sweep

spacing, 42
troubleshooting, 314
using, 42

Step/Knob Ratio softkey, 22

Storage Type softkey, 53, 61
Store Custom Dig Mod State softkey, 248
Store To File softkey, 53, 54, 55
Stored Segments softkey, 51, 139
Subnet Mask softkey, 25
Sum softkey, 189
sweep

annunciator, 10
hardkey, 41
linear, 42, 45, 42
manual control, 48, 4
out connector, 13, 42
softkeys, 41–48, 114, 42
troubleshooting, 314
waveform, including, 46

SWEEP hardkey, 41
Sweep softkeys, 41–48, 56, 114
swept output, 40
switch, power, 8
SWMAN annunciator, 10
synchronize multi- BBGs, 209

configure setup, 213
equipment setup, 213
resynchronize, 215
system delay, 212
trigger setup, 212

system defaults, restoring, 21

T
T annunciator, 10
talker mode annunciator, 10
TCP, 325
TCP Keep Alive softkeys, 25
TDMA

custom digital modulation, predefined, 265
TDMA digital modulation, 265
terminator, 325
test, self, 318
test, self- web- enabled, 318
tests, front panel, 317
TETRA softkey, 246, 250
text area (on display), 11
text entry softkeys, 132
time, dwell, 323
time, setting, 22
time/date reference point, 22
Time/Date softkey, 22
time- based license, 22, 321
Timer Trigger softkey, 41, 108
Toggle softkeys, 159
Total Noise softkey, 231
Total softkey, 231
Trig

in connector, 13
out connector, 42
Agilent MXG and EXG X-Series Signal Generators User’s Guide  337



Index

trigger

connectors, 13
hardkey, 7
initiating, 7
multiple BBG sync, 212

Trigger setup softkeys, 110
Trigger softkeys

& Run, 163
Doublet, 114
Key, 41
Out Polarity, 41
Source, 162
Triggered, 114, 162

Triggered softkey, 114
triggering

gated, 164, 166
multiple BBG sync, 212

equipment setup, 213
segment advance, 164, 162
waveforms, 162

troubleshooting, 309
two tone, 244, 297–302
two tone softkeys, 298
two- tone softkeys, 298
two- tone waveform, setup, 297
type, modulation, 324

U
UNLEVEL annunciator, 10
unleveled operation, 101
UNLOCK annunciator, 10
Unspecified softkey, 139
UNT, option, 4
UNU, option, 4
UNW, option, 4
Up Directory softkey, 51, 53, 56
Update in Remote softkey, 20
urls, 3, 23, 29, 321
USB

connecting media, 61
definition, 325, 14
host connector, 5, 14
keyboard, using, 111
softkeys

File Manager, 51, 52
Keyboard Control, 111

to BBG Memory softkey, 56, 315
Use softkeys

As, 55
Current Directory As Default Path, 51, 61
Only Internal Storage, 51

user
documentation content, xv
files, backup and restore, 50, 82
preset, 34, 315

user files
modifying, 256

user files, data, 253, 256
user FIR

definition, 325
User softkeys

Configure Power Meter, 83, 53
Do Cal, 83
Flatness, 37, 39, 51, 83, 56
Span, 101
User, 21

user- defined FIR
Dual ARB, 199

Utility hardkey, 19
Utility softkey, 31

V
vector operation, 129, 221
View Next Error Page softkey, 62
View Previous Error Page softkey, 62
volatile memory, 130, 132
volatile, definition, 325
VXI- 11, enabling, 26
VXT- 11 SCPI softkey, 26

W
waveform

adding custom modulation, 265
Waveform license, Opt 25x

adding a waveform, 223
backup warning, 228
file missing warning, 228
license status messages, 225, 221, 228
replacing a waveform, 223
status messages, 225
using, 221
waveform licensing softkeys, 223

Waveform softkeys
Licenses, 30
Runtime Scaling, 178
Segments, 132, 135, 159
Utilities, 178
Waveform, 41, 44

waveforms
clipping, 169
file headers, 139, 179
in a sweep, 46
license, 29
markers, 145, 146, 209, 303–306
overview, 130
saving instrument state, 58, 178, 132, 135, 132
triggering, 162, 297–302

Web Server softkey, 26
wideband AM, 67
window settings, FIR filter, 205, 288
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WINIT annunciator, 10

Y
yellow LED, 8

Z
Zoom softkeys, 150
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